排查适用于企业的 Microsoft Store与教育版与 Configuration Manager 集成的问题

本文提供有关适用于企业的 Microsoft Store和教育 (MSfB) 与 Configuration Manager 集成的一些主要问题的关键故障排除提示和修补程序。

有关将 适用于企业的 Microsoft Store 和教育版与Configuration Manager配合使用的详细信息,请参阅使用 Configuration Manager 管理 适用于企业的 Microsoft Store 中的应用和教育版。

监视

组件状态

在Configuration Manager控制台中,转到“监视”工作区,展开“系统状态”,然后选择“组件状态”节点。 监视以下组件的状态:

  • SMS_BUSINESS_APP_PROCESS_MANAGER
  • SMS_CLOUDCONNECTION

同步状态

在Configuration Manager控制台中,转到“管理”工作区,展开“云服务”,然后选择“适用于企业的 Microsoft Store”节点。 检查“ 上次同步状态” 列。

查看同步的应用

在Configuration Manager控制台中,转到“软件库”工作区,展开“应用程序管理”,然后选择“应用商店应用的许可证信息”节点。

日志文件

WSfBSyncWorker.log

此日志文件位于Configuration Manager安装目录下\Logs的服务连接点上。 它记录有关与云服务的通信的信息。 此信息包括元数据、图标、包和许可证文件检索。

若要更改日志级别,请将LoggingLevel注册表项中的HKLM\SOFTWARE\Microsoft\SMS\Tracing\SMS_CLOUDCONNECTION值更改为 0 。 有关详细信息,请参阅 配置日志记录选项

SMS_CLOUDCONNECTION.log

此日志文件位于Configuration Manager安装目录下\Logs的服务连接点上。 如果 WSfBSyncWorker 服务未启动或反复启动和停止,请查看此日志文件中的条目。

注意

此日志文件与其他功能共享。

BusinessAppProcessWorker.log

此日志文件位于层次结构中顶级站点的站点服务器上。 它位于 \Logs Configuration Manager 安装目录中。 它记录有关以下进程的信息:

  • 将 BusinessAppProcessWorker 组件同步的元数据信息插入数据库
  • 处理中的文件 \InstallDir\inboxes\businessappprocess.box

SMS_BUSINESS_APP_PROCESS_MANAGER.log

此日志文件位于层次结构中顶级站点的站点服务器上。 它位于 \Logs Configuration Manager 安装目录中。 如果 BusinessAppProcessWorker 服务未启动或反复启动和停止,请查看此日志文件中的条目。

上次同步失败

当上次同步状态 失败时,首先查看以下 日志文件 以确定症状:

  • WSfbSyncWorker.log
  • SMS_CLOUDCONNECTION.log

然后查看以下部分之一,了解常见问题:

授权错误

原因

如果配置的Microsoft Entra应用程序无权管理此租户的适用于企业的 Microsoft Store和教育,则可能会出现此问题。

解决方法

  1. 以管理员身份登录到 适用于企业的 Microsoft Store 或教育门户。
  2. 转到 “设置”,然后选择“ 管理工具”。
  3. 如果未列出应用程序,请选择“ 添加管理工具”。 然后,按名称搜索并选择与 Configuration Manager 相同的 ClientID 关联的Microsoft Entra应用程序。
  4. 如果状态未显示“活动”,请在“操作”部分选择“激活”。
  5. 在Configuration Manager控制台中,转到“管理”工作区,展开“云服务”,然后选择“适用于企业的 Microsoft Store”节点。 与存储同步,或等待下一个同步间隔发生。

提示

若要在 Configuration Manager中查找 ClientID,请执行以下命令:

  1. 在Configuration Manager控制台中,转到“管理”工作区,展开“云服务”,然后选择“Microsoft Entra Tennts”节点。
  2. 选择用于适用于企业的 Microsoft Store和教育集成的租户。
  3. 在结果窗格中,找到匹配的应用程序,并查看 “客户端 ID” 列。

密钥无效

原因

如果适用于企业的 Microsoft Store和教育配置的 Microsoft Entra 应用上的密钥已过期,则可能会出现此问题。

解决方案

续订Microsoft Entra应用程序的密钥。 有关详细信息,请参阅 续订密钥

获取应用程序令牌时出错

原因

如果已连接的应用不再存在于Microsoft Entra ID中,则可能会出现此问题。

解决方案

删除并重新创建与 适用于企业的 Microsoft Store 和教育的连接。

  1. 在Configuration Manager控制台中,转到“管理”工作区,展开“云服务”,然后选择“适用于企业的 Microsoft Store”节点。
  2. 选择现有连接。
  3. 在功能区中选择 “删除 ”。

然后重新创建连接。 有关详细信息,请参阅以下文章:

内容位置不存在或权限不正确

原因

设置适用于企业的 Microsoft Store和教育连接时,可以指定用于存储同步内容的网络共享。 如果此共享不存在或具有不正确的权限,则可能会出现此问题。 服务连接点的计算机帐户应是此目录和任何子目录的所有者。 否则,将看到类似于以下错误的错误:

Failed to download package d788cc1b-ab00-bb5f-1548-f2dfe717583b-X86-Arm for product 9WZDNCRFJ3PS\0015.  
System.IO.IOException: This security ID may not be assigned as the owner of this object.

若要查看配置的位置,请执行以下操作:

  1. 在Configuration Manager控制台中,转到“管理”工作区,展开“云服务”,然后选择“适用于企业的 Microsoft Store”节点。

  2. 选择帐户并打开其“属性”。

  3. 切换到“配置”选项卡。“位置”设置显示用于存储从 适用于企业的 Microsoft Store 和教育下载的应用程序内容的网络路径。

解决方法

  1. 如果尚不存在,请创建共享。

  2. 检查文件夹的 NTFS 权限和对网络共享的权限。 授予服务连接点的计算机帐户 读取写入 权限。

如果要重新配置位置,请删除并重新创建与新内容位置的连接。

调用“GET”方法的 http 请求时出错

原因

如果存储区中应用程序的同步时间过长,内容 URL 已过期,则可能会出现此问题。

解决方法

重试同步过程

  1. 在Configuration Manager控制台中,转到“管理”工作区,展开“云服务”,然后选择“适用于企业的 Microsoft Store”节点。
  2. 选择连接。 在功能区中,选择“从适用于企业的 Microsoft Store同步”。

每次都会继续。 可能需要多次重试,具体取决于以下因素:

  • 脱机应用程序的数量
  • 包的大小
  • 网络速度

每次尝试时,应看到错误次数更少。 如果错误数不减少,则会出现另一个问题。

无法向缓冲区写入更多字节

原因

如果应用程序的包大于 500 MB,则可能会出现此问题。 Configuration Manager仅支持自动同步包小于 500 MB 的脱机应用程序。

解决方法

无法自动同步这些应用,但可以下载内容并手动创建应用程序:

  1. WSfbSynWorker.log 中的以下行中获取失败的应用程序 ID:

    Error(s) syncing or downloading application <ApplicationID> from the Microsoft Store for Business.

  2. 以管理员身份登录到 适用于企业的 Microsoft Store 或教育门户。 查找此应用程序的页面。

    提示

    页面的 URL 类似于: https://businessstore.microsoft.com/en-us/store/p/app/ApplicationID

    1. 如果尚未选择,请选择“ 脱机”。 然后选择“ 管理”。

    2. 在应用程序内容共享上为所有受支持的平台创建单独的文件夹。

    3. 将包下载到包文件夹。

    4. 将编码的许可证文件作为 .bin 文件下载到包文件夹。

    5. 将所有必需的框架下载到包文件夹。

  3. 在Configuration Manager控制台中,转到“软件库”工作区,展开“应用程序管理”,然后选择“应用程序”节点。

  4. 创建应用程序,手动指定应用程序信息。

    1. 为之前下载的每个受支持的平台创建部署类型。

    2. 类型: Windows 应用包 (*.appx、*.appxbundle)

    3. 为实际应用包指定 appx/appxbundle,而不是所需的依赖项包。

在最终的 “导入信息 ”页上确认以下详细信息:

  • 许可证文件: 指定 .bin 文件。 脱机应用需要此许可证文件。
  • Windows 应用依赖项: 验证是否已为此包下载所有必需的依赖项。

联机应用程序下载失败,0x8024500c

原因

下载过程中出现0x8024500c错误通常是由阻止Windows 更新访问的任何Windows 更新 Internet 位置组策略引起的。

解决方法

不要启用“不连接到任何Windows 更新 Internet 位置”组策略对象。

同步未运行

本部分介绍以下同步问题:

  • 手动启动同步过程,但它不会运行
  • 网站不会每天自动同步

首先查看以下 日志文件 以确定症状:

  • BusinessAppProcessWorker.log
  • SMS_BUSINESS_APP_PROCESS_MANAGER.log
  • WsfbSyncWorker.log
  • SMS_CLOUDCONNECTION.log

然后查看以下部分之一,了解常见问题:

手动同步无法启动

原因

如果在上次同步后不到 10 分钟启动同步,则可能会出现此问题。同步频率不能超过每 10 分钟一次。

解决方案

在开始另一个同步之前,请至少等待 10 分钟。

自动每日同步未运行,并在 SMS_BUSINESS_APP_PROCESS_MANAGER.log 中出现“关闭 #辅助角色”错误

原因

如果 SMS_BUSINESS_APP_PROCESS_MANAGER 组件停止 WsfbSyncWorker 线程,则可能会出现此问题。 此错误可能指定 24 辅助角色。

解决方法

重启 SMS_EXECUTIVE 服务。

如果无法重启该main服务,请使用 MSfB 辅助角色停止这两个组件,然后启动这两个组件:

  1. 在运行服务连接点的服务器上打开 Windows 注册表

  2. 转到 HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_EXECUTIVE\Threads\SMS_CLOUDCONNECTION

    1. 将“请求的操作”设置为 “停止”。

    2. 刷新以验证当前状态 = 已停止

  3. 转到 HKLM\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_EXECUTIVE\Threads\SMS_BUSINESS_APP_PROCESS_MANAGER

    1. 将“请求的操作”设置为 “停止”。

    2. 刷新以验证当前状态 = 已停止

  4. “SMS_CLOUDCONNECTION”中,将“请求的操作 ”设置为“启动”。

  5. “SMS_BUSINESS_APP_PROCESS_MANAGER”中,将“请求的操作 ”设置为“启动”。

本部分包括以下常见问题:

不应用语言选择更改

原因

如果语言选择已缓存,并且属性值更改后未清除,则可能会出现此问题。

解决方法

若要解决此问题,请重启 SMS_Executive 服务。

并非所有许可证信息都存在所有所选语言

原因

如果适用于企业的 Microsoft Store和教育应用程序的许可证信息不包含指定语言的本地化数据,则可能会出现此问题。

解决方法

为创建的应用程序手动添加任何缺少的语言。

脱机应用程序

本部分包括以下常见问题:

无法创建脱机应用程序,因为无法验证内容

原因

如果脱机应用程序的同步内容已损坏或修改,则可能会出现此问题。

解决方法

开始新的同步。同步完成后,它应验证并下载任何不正确的内容文件。

无法安装从脱机许可证信息创建的应用程序

原因

如果将应用程序部署到运行版本 1511 之前的 Windows 10 的客户端,则可能会出现此问题。 适用于企业的 Microsoft Store和教育版的脱机许可应用仅在Windows 10版本 1511 及更高版本上受支持。

解决方案

安装最新版本的 Windows 10。

后续步骤

若要查找其他帮助,请参阅查找有关使用Configuration Manager的帮助