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疑難排解 Windows Defender 或 Endpoint Protection 用戶端

適用於:Configuration Manager (目前的分支)

如果您遇到 Windows Defender 或 Endpoint Protection 的問題,請使用本文來針對下列問題進行疑難解答:

更新 Windows Defender 或 Endpoint Protection

徵狀

Windows Defender 或 Endpoint Protection 會自動與 Microsoft Update 搭配運作,以確保您的病毒和間諜軟體定義保持在最新狀態。

本節解決自動更新的常見問題,包括下列情況:

  • 您會看到錯誤訊息,指出更新已失敗。

  • 當您檢查更新時,您會收到錯誤訊息,指出無法檢查、下載或安裝病毒和間諜軟體定義更新。

  • 即使您的裝置已連線到因特網,更新仍會失敗。

  • 匯報 不會依排程自動安裝。

原因

最常見的更新問題原因是因特網連線問題。 如果您知道您的裝置已連線到因特網,因為您可以流覽至其他網站,則問題可能是因為與 Windows 中的因特網設定衝突所造成。

要解析的選項

步驟 1:重設因特網設定

  1. 結束所有開啟的程式,包括網頁瀏覽器。

    注意事項

    當您重設這些因特網設定時,可能會刪除瀏覽器暫存盤、Cookie、瀏覽歷程記錄和在線密碼。 它不會刪除您的最愛。

  2. 移至 [ 開始 ] 選單,然後開啟 inetcpl.cpl

  3. 切換至 [ 進階 ] 索引標籤。

  4. 在 [ 重設 Internet Explorer 設定] 區段中,選取 [ 重設],然後再次選取 [ 重設 ] 以確認。

  5. 重設設定時,請選取 [ 確定 ]。

  6. 再次嘗試更新 Windows Defender。

如果問題持續發生,請繼續進行下一個步驟。

步驟 2:確定您的電腦上已正確設定日期和時間

如果錯誤訊息包含程式代碼0x80072f8f,問題很可能是因為您電腦上的日期或時間設定不正確所造成。 移至 [ 開始 ] 功能表,選取 [ 設定],選 取 [時間 & 語言],然後選 取 [日期 & 時間]

步驟 3:重新命名電腦上的 [軟體發佈] 資料夾

  1. 停止 Windows Update 服務。

    1. 移至 [開始],然後開啟 services.msc

    2. 取 Windows Update 服務。 移至 [ 動作] 功能表,然後選取 [ 停止]

  2. 重新命名 SoftwareDistribution 目錄。

    1. 以系統管理員身分開啟命令提示字元。

    2. 輸入下列命令:

      cd %windir%
      ren SoftwareDistribution SDTemp
      exit
      
  3. 重新啟動 Windows Update服務。

    1. 切換回 [ 服務] 視窗。

    2. 取 Windows Update 服務。 移至 [ 動作] 功能表,然後選取 [ 開始]

    3. 關閉 [服務] 視窗。

步驟 4:在您的電腦上重設 Microsoft 防病毒軟體更新引擎

  1. 以系統管理員身分開啟命令提示字元。

  2. 輸入下列命令:

    cd \
    
    cd program files\windows defender
    
    MpCmdRun -RemoveDefinitions -all
    
    exit
    
  3. 重新啟動電腦。

  4. 再次嘗試更新 Windows Defender。

如果問題持續發生,請繼續進行下一個步驟。

步驟 5:手動安裝定義更新

手動下載最新的更新

步驟 6:連絡 Microsoft 支持服務

如果這些步驟無法解決問題,請連絡 Microsoft 支持服務。 如需詳細資訊,請 參閱支援選項和社群資源

啟動 Windows Defender 或 Endpoint Protection 服務

徵兆

您會收到一則訊息,通知您 Windows Defender 或 Endpoint Protection 未監視您的電腦,因為程式的服務已停止。您現在應該重新啟動它。

解決方案

步驟 1:重新啟動電腦

關閉所有應用程式並重新啟動電腦。

步驟 2:檢查 Windows 服務

  1. 移至 [開始],然後開啟 services.msc

  2. 取 [Windows Defender 防病毒軟體服務]

  3. 請確定 [ 啟動類型 ] 已設定為 [ 自動]

  4. 移至 [ 動作] 功能表,然後選取 [ 開始]

    1. 如果無法使用此動作,請選取 [ 停止]。 等候服務停止,然後選取 [啟動 ] 動作以重新啟動服務。

請注意,在此程式期間可能會出現的任何錯誤。 請連 Microsoft 支援服務 並提供錯誤資訊。

步驟 3:移除任何第三方安全性程式

注意事項

某些安全性應用程式不會完全卸載。 您可能需要下載並執行先前安全性應用程式的清除公用程式,才能完全移除它。

  1. 移至 [開始 ] 並開 啟appwiz.cpl

  2. 在已安裝的程式清單中,卸載任何第三方安全性程式。

  3. Restart your computer.

注意

當您移除安全性程式時,您的電腦可能未受到保護。 如果您在移除現有的安全性程序之後安裝 Windows Defender 時發生問題,請連絡 Microsoft 支援服務。 選取 [安全性產品系列],然後選取 Windows Defender 產品。

因特網聯機問題

若要讓電腦接收來自 Windows Update 的最新更新,請將它連線到因特網。

  1. 移至 [開始 ] 並開 啟ncpa.cpl

  2. 開啟連接名稱以檢視連線 狀態

  3. 如果您的計算機已連線, IPv4 連線 和/或 IPv6 連線 狀態會是 因特網

  4. 如果您的電腦似乎未連線,請選取連線名稱,然後選取 [診斷此連線]

關閉任何開啟的程式,然後重新啟動您的計算機。

偵測到的威脅無法補救

當 Windows Defender 或 Endpoint Protection 偵測到潛在威脅時,它會嘗試藉由隔離或移除威脅來降低威脅。 這些威脅可能會隱藏在壓縮的封存 () .zip 或網路共用中。

拿掉或掃描檔案

  • 如果偵測到的威脅位於壓縮的封存盤案中,請流覽至檔案。 刪除檔案,或手動掃描檔案。 以滑鼠右鍵按下檔案,然後選取 [使用 Windows Defender 掃描]。 如果 Windows Defender 偵測到檔案中的其他威脅,它會通知您。 然後,您可以選擇適當的動作。

  • 如果偵測到的威脅是在網路共用中,請開啟共用,然後手動掃描它。 以滑鼠右鍵按下檔案,然後選取 [使用 Windows Defender 掃描]。 如果 Windows Defender 在網路共用中偵測到其他威脅,它會通知您。 然後,您可以選擇適當的動作。

  • 如果您不確定檔案的來源,請在計算機上執行完整掃描。 完整掃描可能需要一些時間才能完成。

另請參閱

Endpoint Protection 用戶端常見問題

Endpoint Protection 用戶端電腦說明