無法刪除由已啟用 SLA 的實體所組成的受控解決方案
本文提供您無法刪除由服務等級協定所組成的受控解決方案, (客戶服務中已啟用 SLA) 實體的問題 Dynamics 365 解決方案。
徵狀
您無法刪除包含已啟用 SLA 之實體的受控解決方案。 此實體已建立為先前匯入解決方案的一部分。
原因
在實體上啟用后,就無法停用 SLA。
使用此範例來了解問題:
- Create Org1 中的新解決方案,並將它命名為 Field 解決方案。
- Create Field 解決方案中的新實體,並將它命名為 Field work。
- 將 欄位解決方案 匯出為受控解決方案。
- 將 欄位解決方案 匯入名為 Org2 的新組織。
下一步:
- Create Org1 中的另一個解決方案,並將它命名為 Delta Field 解決方案。
- 將實體 Field 與 Delta Field 解決方案建立關聯。 在實體上啟用 SLA。
- 將 Delta Field 解決方案 導出為受控解決方案。
- 將 Delta 欄位解決方案 匯入 至 Org2。
現在,如果您嘗試從 Org2 刪除 Delta Field 解決方案 ,則無法將其刪除,因為其具有已啟用 SLA 的相關聯 Field 工作 實體。
解決方案
若要使用已啟用 SLA 的實體來刪除受控解決方案,您必須先刪除先前匯入的受控解決方案,以建立實體專案。 此動作可確保刪除實體專案。 然後,您可以再次建立實體,或重新匯入受控解決方案。
若要刪除 Org2 中的 Delta Field 解決方案,請先刪除欄位解決方案。
可以刪除欄位解決方案 ,因為與其相關聯的實體 — 欄位工作 — 未啟用 SLA。 刪除 欄位解決方案 可確保同時刪除 SLA 組態和實體。
注意事項
此因應措施不適用於現成可用的實體,因為您無法刪除現成可用的實體或具有現成實體的受控解決方案。
意見反映
https://aka.ms/ContentUserFeedback。
即將推出:我們會在 2024 年淘汰 GitHub 問題,並以全新的意見反應系統取代並作為內容意見反應的渠道。 如需更多資訊,請參閱:提交及檢視以下的意見反映: