分享方式:


當您在 Microsoft Dynamics 365 for Outlook 中追蹤電子郵件時,字典中未出現指定的密鑰錯誤

本文提供在 Microsoft Dynamics 365 for Outlook 中追蹤電子郵件時所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 4010462

徵狀

當您嘗試在 Outlook Dynamics 365 中追蹤電子郵件時,您會收到下列錯誤:

「指定的索引鍵不存在於字典中。」

如果您選取詳細資料,您會看到下列其他詳細資料:

「指定的索引鍵不存在於字典中。
System.Collections.Generic.Dictionary2.get_item (键)
在 Microsoft.Crm.AppIication.SMWrappers.AttachmentForOutIook.Get...clientOrganizationContext、IDynamicEntityCoIIectionForOutIook dynamicEntityCoIIectionAttachments)
atMicrosoft.Crm.AppIicationSMWrappers.EmaiIForOutIook.Microsoft....messageld、字串主旨、 String from, String to, String cc, String bcc, Double receivedon, String submitted8y, String importance, String body, IDynamicEntityCoIIectionForOutIook attachments, Int32 attachmentCount, IDynamicEntityForOutIook extraProperties, String entityXmI, String regardingld, Int64 regardingObjectType, String crmld, Int32& notification) ”

原因

下列其中一種情況可能會發生此錯誤:

  1. 電子郵件包含大於 Dynamics 365 中所允許大小的附件。
  2. 電子郵件包含擴展名為 的附件,該擴展名遭到 Dynamics 365 封鎖。

解決方案

解決方案 1
如果電子郵件包含超過大小限制的附件,請移除附件或增加 Dynamics 365 中允許的附件大小。 默認大小上限為 5 MB。

如果您在 Dynamics 365 中具有系統管理員角色,您可以流覽至 [設定]、[系統管理],然後選取 [系統設定] 來檢視和修改此設定。 選取 [Email] 索引標籤,然後找出 [設定附件的檔案大小限制] 標題下的 [檔案大小上限] (以 KB 為單位) 設定。

解決方案 2
如果電子郵件包含 Dynamics 365 封鎖之擴展名的附件,請移除附件或修改 Dynamics 365 封鎖的擴展名。

如果您在 Dynamics 365 中具有系統管理員角色,您可以流覽至 [設定]、[系統管理],然後選取 [系統設定] 來檢視和修改此設定。 在 [ 一般] 索引標籤上,找出 [ 設定已封鎖的附件擴展名] 設定。