分享方式:


匯入檔案太大,無法在 Microsoft 中匯入解決方案時發生上傳錯誤 Dynamics 365

本文提供在 Microsoft Dynamics 365 中嘗試匯入解決方案時所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 4462491

徵狀

當您嘗試在 Dynamics 365 中匯入解決方案時,匯入會失敗,而且您會看到下列訊息:

「匯入檔案太大而無法上傳。
錯誤碼80040375」

原因

雖然錯誤訊息指出要匯入 的解決方案大小上限有問題,但可能會造成另一個問題,例如 SQL 錯誤。

解決方案

選取 [ 下載記錄檔] 按鈕,以查看更詳細的訊息。 您可能會看到詳細資料,例如下列訊息:

匯入失敗。 如需詳細資訊,請參閱相關的錯誤訊息。 :System.Data.SqlClient.SqlException (0x80131904) 每個數據表中的數據行名稱必須是唯一的。 數據表 '<entity/table name' 中的數據行名稱 '<column name>>' 已指定一次以上。

上述範例訊息是如果您嘗試匯入已存在於該實體中的欄位,可能會發生 SQL 錯誤。

範例:如果您已在組織中建立自定義欄位,並在 Account 實體上建立名為 new_field1 的架構名稱。 現在您正嘗試匯入方案,其中包含 Account 實體上具有相同架構名稱的欄位。 SQL 不允許在相同數據表中使用相同名稱的多個數據行,因此會導致匯入失敗。 您可能會發現,在目標環境中,您已經有一個具有相同架構名稱的欄位,但大小寫不同,例如new_Field1以及您要匯入之解決方案中的欄位new_field1。 如果目標環境中不需要具有相同名稱的欄位,請將其刪除,然後再試一次匯入。

如果錯誤持續發生,且您無法使用記錄檔中的詳細數據來解決問題,請連絡 Microsoft 支援服務 以尋求協助。 您也可以使用記錄檔中的資訊來搜尋 Dynamics 365 社群中的潛在解決方案。