分享方式:


針對應用程式內營銷的問題進行疑難解答

本文可協助您針對應用程式內行銷的相關問題進行疑難解答並加以解決。

問題 1 - 當您開啟 [行銷清單] 表單時,無法使用 [成員] 檢視

原因

發生此問題的原因是行銷清單窗體中每個子格的檢視自定義,導致成員清單顯示為空白。

[行銷清單] 表單中的成員清單是空的。

解決方案

  1. 移至 [進階>設定設定>] [自定義>系統]

  2. 從網站地圖中,開啟 [實體>行銷清單>表單]

  3. 從表單清單中,選取 [行銷清單 ] 表單。

    從表單清單中選取 [行銷清單] 表單。

  4. 在 [ 行銷清單] 表單上,從 [ 行銷清單 ] 網站地圖中,選取 [ 成員]

    從 [營銷清單] 網站地圖中選取 [成員]。

  5. 選取 [聯繫人],然後選取 [ 變更屬性]。 [ 設定屬性] 視窗隨即開啟。

    [設定 屬性視窗 會在您選取 [聯繫人] 和 [變更屬性] 之後開啟。

  6. 在 [ 其他選項] 區段的 [ 檢視選取器 ] 下拉式清單中,選取 [ 顯示選取的檢視]

    其他選項清單隨即出現。

  7. 選取 [ 我的作用中聯繫人] 檢視 ,然後從 [ 檢視選取器 ] 下拉式清單中選取 [ 關閉]

    在 [檢視選取器] 下拉式清單中選取 [關閉]。

  8. 在 [ 名稱] 區段中,清除 [表 單] 複選框上的 [顯示卷標 ]。

    清除 [表單] 複選框上的 [顯示] 標籤。

  9. 選取 [確定]

  10. 針對 帳戶潛在客戶重複步驟 5 到 9。

  11. 儲存併發佈表單。

問題 2 - 無法將從行銷清單表單建立的活動與整合介面中的行銷清單記錄產生關聯

原因

發生此問題的原因是屬性 TmpRegardingObjectId 已從 [活動] 表單中移除。

整合介面中行銷清單窗體中的空白營銷活動清單。

解決方案

  1. 移至 [進階>設定設定>] [自定義>系統]

  2. 從網站地圖中,開啟 [實體>營銷活動>表單]

  3. 從表單清單中,選取 [營銷活動 ] 表單。

    從表單清單中選取 [營銷活動] 表單。

  4. 從頁面右側顯示的 [ 欄位總管 ] 窗格中,將 [TmpRegardingObjectId ] 字段新增至表單。

    將 TmpRegardingObjectId 新增至營銷活動表單。

  5. 選取 [TmpRegardingObjectId] 字 段,然後選取 [ 變更屬性]

    [設定 屬性視窗 隨即開啟。

  6. 在 [ 卷標] 區段中,清除 [ 表單] 複選框上的 [顯示卷標 ],然後在 [ 可見性 ] 區段中,清除 [預設可見 ] 複選框。

    清除表單上的 [顯示] 標籤和預設的 [可見度] 複選框。

  7. 儲存併發佈表單。

原因

發生此問題的原因是應用程式中的 [聯繫人] 或 [帳戶] 顯示名稱已變更,而 [公司名稱] (RELATED_TYPE) 從變更的顯示名稱中挑選相關類型。

解決方案

在整合介面中,公司名稱實體可作為 公司名稱 (帳戶) 。 例如,如果您將 帳戶 重新命名為 組織,則實體會重新命名為 公司名稱 (組織)

問題:無法使用電子郵件快速行銷活動通訊清單傳送電子郵件

原因

發生此問題的原因是下列其中一個原因:

  • 用戶沒有代表其他用戶傳送電子郵件的許可權。
  • 記錄 (行銷清單成員的擁有者) 不允許其他 Dynamics 365 使用者代表擁有者傳送電子郵件。

解決方案

若要解決此問題,請執行以下任一項:

  • 對於正在建立快速營銷活動的使用者,必須將 [傳送 Email 為另一個使用者] 許可權指派給至少一個指派給使用者的角色。 如需詳細資訊,請 參閱使用小組成員的許可權繼承建立安全性角色

    為使用者提供以另一個使用者許可權傳送電子郵件的許可權。

  • 對於記錄的擁有者,必須在 [設定個人選項] 對話方塊的 [選取其他使用者是否可以傳送電子郵件給您] 下選取 [允許其他 Microsoft Dynamics 365 使用者代表您傳送電子郵件] 複選框。

    允許其他使用者代表擁有者傳送電子郵件。

問題 4 - 無法在快速行銷活動精靈內變更電子郵件中的表單域

原因

此問題是因為您角色的 [傳送 Email 為另一個使用者] 選項的許可權不足所造成。

解決方案

為您其中一個角色的 [以另一個使用者身分傳送 Email] 選項提供足夠的許可權。

問題 5 - 在 [散發] 對話方塊中看不到電子郵件範本

原因

整合介面中的電子郵件範本選取器依賴不同實體的特定存取層級。

解決方案

若要解決此問題,使用者需要存取系統用戶記錄。 在您的 Dynamics 365 組織中指派安全性角色,以提供系統使用者的存取權。 如需詳細資訊, 請參閱設定環境中資源的使用者安全性。

問題 6 - 行銷活動發佈程式停滯,狀態為 [擱置中] 或 [失敗]

原因

營銷活動發佈程式需要在背景中執行工作流程。 停用工作流程時,行銷活動散發將不會完成,且會卡在 [擱置 中] 或 [ 失敗 ] 狀態。

解決方案

若要解決此問題,請啟用工作流程背景程式,然後啟用 ActivityPropagation 程式。

啟用工作流程背景程式

  1. 移至 [進階>設定設定>] [系統>系統作業]

  2. 移至 [活動 ][布建作業],然後在 [ 處理會話] 底下,選取符合或大約符合的作業、執行快速營銷活動的日期和時間。

  3. 確認 [詳細數據] 區段下顯示錯誤訊息,指出因為組織處於停 用背景處理 模式,所以已略過異步操作。 執行下列動作來更新環境的設定:

    1. 移至 Dynamics 365 系統管理中心,選取您的實例,然後選取 [管理員 設定]

      從系統管理中心選取 [管理員 設定]。

    2. 清除 [ 停用背景作業] 複選框。

      清除 [停用背景作業] 複選框。

  4. 儲存您的設定,然後結束。

啟用 ActivityPropagation 程式

  1. 移至 [進階>設定設定>] [自定義>系統]

  2. 從網站地圖,移至 [處理程式]

  3. 在檢視選取器中,選取 [ 全部]

    系統會顯示所有可用的進程。

    在檢視選取器中選取 [全部] 以查看所有可用的進程。

  4. 選取 ActivityPropagation 程式,然後選取 [ 啟用]

    選取 [啟用] 按鈕以啟動 ActivityPropagation 程式。

問題 7 - 我的快速行銷活動失敗,且已設定為中止

原因

此問題是因為與工作流程程式中的自定義外掛程式相關的堆疊追蹤失敗所造成。

解決方案

  1. 移至 [進階>設定設定>] [系統>系統作業]
  2. 移至 [活動 ][布建作業],然後在 [ 處理會話] 底下,選取符合或大約符合的作業、執行快速營銷活動的日期和時間。

系統作業包含的資訊包含發生失敗的堆疊追蹤。 解決堆疊追蹤失敗檔中所述的失敗。

問題 8 - 快速行銷活動正在執行無法復原的迴圈,併產生數千筆失敗記錄

原因

由於未知的條件,當工作流程無法建立行銷活動活動時,它會進入無法支持的迴圈,並持續建立活動活動,而所有活動都會失敗。 您會發現失敗數目持續增加,直到超過目標行銷清單中的成員數目為止。

解決方案

停用 ActivityPropagation 工作流程,然後再次啟用它。

  1. 移至 [進階>設定設定>] [自定義>系統]

  2. 從網站地圖,移至 [處理程式]

  3. 在檢視選取器中,選取 [ 全部]

    系統會顯示所有可用的進程。

    在檢視選取器中選取 [全部] 以查看所有可用的進程。

  4. 選取 ActivityPropagation 工作流程,然後選取 [ 停用]

    停用 ActivityPropagation 工作流程。

  5. 等候 24 小時,然後重新啟用 ActivityPropagation 工作流程。

問題 9 - 行銷活動散發不會在目標實體上建立活動

目標記錄 (帳戶、聯繫人和潛在客戶) 可以識別其透過行銷活動散發接收營銷數據的喜好設定:包括電子郵件、電話、傳真和大量郵件。

只有當行銷清單的成員喜好設定設為 [ 允許 ] 或 [ 傳送] 時,才會建立營銷活動。

設定連絡人喜好設定以允許或傳送。

問題 10 - 某些成員的行銷活動散發失敗

原因

營銷活動散發是以行銷清單中的成員為基礎。 成員可以是帳戶、聯繫人或主管。 成員的營銷活動散發可能會因為下列其中一個原因而失敗:

  • 沒有與成員相關聯的電子郵件位址。
  • 與成員相關聯的電子郵件地址無效。
  • 成員已將成員記錄中的 [ 傳送行銷材料 ] 字段設定為 [不要傳送]

解決方案

在 [ 排除的成員 ] 方格中檢閱失敗的詳細原因,並採取任何必要的動作。

問題 11 - 整合介面中的帳戶、聯繫人或潛在客戶表單中無法使用 [營銷活動] 索引標籤

原因

由於營銷活動數據表與帳戶、聯繫人或潛在客戶之間沒有直接關聯性,因此這些窗體中無法使用 [ 營銷活動 ] 索引標籤。 檢視營銷活動清單的唯一方式是透過分散式行銷活動,因為分散式營銷活動是目標實體正在營銷活動中使用的實際指示。

解決方案

若要解決此問題,請將 [ 營銷活動] 索引卷標新增至窗體。

注意事項

在此範例中,我們會使用 Account 實體。

  1. 移至 [進階>設定設定>] [自定義>系統]

  2. [元件] 中,選取 [實體>帳戶>窗體]

  3. 開啟您要加入子格的表單。

  4. 在窗體頁面上,選取 [ 插入] 索 引卷標,然後選取 [ 一個數據行]

    新的數據行會新增為索引標籤。

  5. 選取索引標籤,然後選取 [變更屬性]。 [ 索引標籤屬性] 對話框隨即開啟。

  6. 輸入 [名稱 ] 和 [卷標營銷活動] 的值,然後選取 [ 確定]。 然後,索引標籤會重新命名為 活動活動

  7. 選取 [ 活動活動] 索引標籤,移至 [ 插入] 索 引卷標,然後選取 [子網格線]

    子格的 [ 設定屬性 ] 對話框隨即開啟。

  8. 在 [ 顯示] 索引 標籤上,輸入下列資訊:

    • 在 [ 名稱] 區段中,針對唯一名稱輸入 Campaign_Activities
    • 在 [ 名稱] 區段中,針對 [ 卷標] 輸入 活動活動
    • 在 [ 數據源] 區 段中,執行下列動作:
      • 針對 [實體],選 取 [活動活動]
      • 針對 [默認檢視],選取 [ 所有營銷活動活動]

    在子格的 [顯示] 索引標籤上輸入值。

  9. 儲存變更併發佈表單。

若要確認問題已解決,請開啟已在營銷活動中使用的帳戶,並具有一些分散式營銷活動活動。 選取 [ 營銷活動] 索 引卷標,確認相關的營銷活動是否出現。

[活動活動] 索引卷標和新增至帳戶窗體的活動子格。

問題 12 - 使用者在嘗試刪除靜態行銷清單時逾時

原因

刪除具有大量成員的靜態行銷清單 (超過 50,000 個) 花費很多時間,並導致逾時。

解決方案

建議先 使用 [使用進階尋找移除] 從行銷清單中移除所有成員,然後刪除營銷清單。 為了提升應用程式效能並避免逾時,請移除行銷清單中一次 10,000 個群組中的成員。 例如,如果行銷清單中有 20,000 個成員,而您想要移除成員。 先移除 10,000 個成員,然後移除其他 10,000 個成員。