透過 ExpressRoute 設定 BFD

ExpressRoute 支援透過私用對等互連進行雙向轉送偵測 (BFD)。 當您透過 ExpressRoute 啟用 BFD 時,可以加速 Microsoft Enterprise Edge (MSEE) 裝置與您 ExpressRoute 線路 (CE/PE) 設定的路由器之間的連結失敗偵測。 您可以透過邊緣路由裝置或協力廠商邊緣路由裝置來設定 ExpressRoute (前提是您已使用受控的第 3 層連線服務)。 本文件將逐步引導您了解 BFD 的需求,以及如何透過 ExpressRoute 啟用 BFD。

需要 BFD

下圖顯示透過 ExpressRoute 線路啟用 BFD 的優勢:1

您可以透過第 2 層連線或受控的第 3 層連線啟用 ExpressRoute 線路。 在這兩種情況下,如果 ExpressRoute 連線路徑中有多部第 2 層裝置,都會是上層的 BGP 工作階段要負責偵測路徑中的任何連結失敗。

在 MSEE 裝置上,BGP 保持運作時間和保留時間通常會分別設定為 60 和 180 秒。 因此,在發生連結失敗之後,最多需要三分鐘的時間才能偵測到任何連結失敗,並將流量切換至其他連線。

您可以控制 BGP 計時器,方法是在邊緣對等互連裝置上設定較低的 BGP 保持運作時間和保留時間。 如果 BGP 計時器在兩個對等互連裝置之間不相同,則 BGP 工作階段將確定使用較低的時間值。 BGP 保持運作時間最低可設定為三秒,而保留時間最低可設定為 10 秒。 不過,不建議設定非常積極的 BGP 計時器,因為通訊協定需要進行大量處理。

在此案例中,BFD 可以提供協助。 BFD 會以次秒時間間隔提供低額外負荷的連結失敗偵測。

注意

BFD 會在偵測到連結失敗時提供更快的容錯移轉時間,但整體連線聚合最多需要一分鐘的時間,以在 ExpressRoute 虛擬網路閘道和 MSEE 之間進行容錯移轉。

啟用 BFD

BFD 預設會設定於 MSEE 上所有新建立的 ExpressRoute 私人和 Microsoft 對等互連介面上。 因此,若要啟用 BFD,您只需要在主要和次要裝置上都設定 BFD 即可。 設定 BFD 需要兩個步驟。 在介面上設定 BFD,然後將其連結至 BGP 工作階段。

範例 CE/PE (使用 Cisco IOS XE) 設定如下所示。

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

注意

若要在已經存在的私人或 Microsoft 對等互連下方啟用 BFD,您需要重設該對等互連。 這必須在 2018 年 8 月之前使用私人對等互連設定的線路上完成,以及在 2020 年 1 月之前使用 Microsoft 對等互連設定的線路上完成。 請參閱重設 ExpressRoute 對等互連

BFD 計時器交涉

在 BFD 對等之間,這兩個對等中速度較慢者會決定傳輸速率。 MSEE BFD 傳輸/接收間隔會設定為 300 毫秒。 在某些情況下,間隔可能會設定為高於 750 毫秒的值。 藉由設定較高的值,您可以強制這些間隔更長,但無法使其較短。

注意

如果您已設定異地備援 ExpressRoute 線路,或使用站對站 IPSec VPN 連線作為備份。 啟用 BFD 將協助您在 ExpressRoute 連線失敗之後更快進行容錯移轉。

後續步驟

如需詳細資訊或協助,請看看下列連結: