Microsoft Quantum Development Kit(QDK)使用標準的 Visual Studio Code 功能(VS Code),以及當你處理 .qs 或 .qasm 檔案時,具備語言專屬的功能。 本參考指南說明了你可以在 VS Code 指令面板中存取的主要 QDK 指令,以及其他功能和連結到更多內容。 如需一般 VS Code 指引,請參閱 VS Code 檔。
QDK 延伸模組中的大多數指令都可以從 「檢視 > 指令選項板 」功能表存取。 打開指令面板並輸入 QDK:,即可在 、 .qasm或 .qsc 檔案中查看篩選過的指令.qs清單。
Tip
您可以使用 鍵盤快速鍵或 Ctrl + K + S 為 VS Code 命令建立自訂鍵盤快速鍵。如需詳細資訊,請參閱 VS Code 的索引鍵繫結。
指令
許多 QDK 指令與撰寫與執行 Q# 及 OpenQASM 程式相關,且僅在 .qs、 .qasm或 .qsc 檔案活躍時可用。 其他指令通常可用。
一般命令
| Command | Action | Notes | 替代使用者操作 |
|---|---|---|---|
| QDK:創建 Q# 專案 | 在作用中資料夾中建立 Q# 專案,包括 qsharp.json 資訊清單檔案和 src 具有預設 main.qs 檔案的子資料夾。 |
如需 Q# 專案的詳細資訊,請參閱 使用 Q# 專案。 | 在 檔案總管 中,以滑鼠右鍵按兩下目標資料夾,然後選取 [建立 Q# 專案]。 |
| QDK:打造一款 Microsoft Quantum 筆記型電腦 | 開啟執行 Q# + Python 程式的範例 Jupyter Notebook,並將作業提交至 Azure Quantum。 | 欲了解更多關於 Jupyter Notebook 中 QDK 的資訊,請參閱「使用 QDK Python 套件提交工作至Azure Quantum」。 | N/A |
| QDK:連線到 Azure Quantum 工作區 | 使用 Azure 帳戶或 連接字串 連線到 Azure Quantum 工作區。 認證完成後,選擇 Microsoft Quantum 面板圖示(左下角)。 | 如需 Azure Quantum 連線的詳細資訊,請參閱 連線到您的 Azure Quantum 工作區。 | 將滑鼠移到 量子工作區 上,選擇 + 圖示。 |
| QDK:開啟 QDK 遊樂場 | 在檔案總管中開啟一個包含 Q# 與 OpenQASM 範例程式的線上資料夾。 您可以在本機量子模擬器中編輯和執行程式,以及使用內建調試程式設定斷點並逐步執行程序代碼。 | 如需詳細資訊,請參閱 範例資料夾中的自述檔 。 | N/A |
| QDK:重新整理 Azure Quantum 工作區 | 同步連線量子工作區的最新變更。 | 如果發生連線問題,工作區名稱旁邊會出現警示圖示。 | 將滑鼠移到 「Quantum Workspaces 」上,選擇重新整理圖示。 |
| QDK:建立一個 Microsoft Quantum Python 虛擬環境 | 建立一個資料夾,並安裝包含所選套件的 Python 虛擬環境。 | 桌面版 VS Code 有,但網頁版 VS Code 則沒有。 | N/A |
| QDK:布洛赫球 | 開啟布洛赫球視覺化器。 | 欲了解更多資訊,請參閱 《如何在QDK中使用布洛赫球視覺化器》。 | N/A |
| QDK:顯示變更日誌 | 在新選項卡中打開一個變更日誌,其中顯示當前和所有以前版本的 QDK 更新。 | 變更日誌也可在開源 QDK GitHub 儲存庫中找到。 | N/A |
| 瀏覽器:聚焦於量子工作區視圖 | 開啟 檔案總管,並在設定時將焦點放在連線的量子工作區上。 如果未設定任何工作區,系統會提示您新增現有的工作區。 | 如需 Azure Quantum 連線的詳細資訊,請參閱 連線到您的 Azure Quantum 工作區。 | N/A |
根據目前使用中的檔案類型可用的指令
| Command | 程式檔案類型 | Action | Notes | 替代使用者操作 |
|---|---|---|---|---|
| QDK:顯示電路 |
.qs、.qasm |
在程式執行前會顯示電路圖。 | 如需詳細資訊,請參閱 可視化量子電路圖。 | 從進入點作業旁的選單選取程式代碼鏡頭選項 [線路 ],或在程式中的每個使用者定義作業上方選取 。 |
| QDK:執行檔案並顯示直方圖 |
.qs、.qasm |
執行目前的程式,並在新窗格中顯示結果的直方圖。 | 要進入排序與篩選選項,請在直方圖面板中選擇篩選圖示。 | 從入口作業旁的功能表中選取程式碼鏡片選項直方圖。 |
| QDK:取得目前 QDK 程式的 QIR |
.qs、.qasm |
在新的編輯視窗中開啟目前 Q# 或 OpenQASM 程式碼的 QIR 原始碼。 您的程式必須使用「基本」、「調適型 RI」或「調適型 RIF」目標設定檔來匯出 QIR 來源。 | 欲了解更多QIR資訊,請參閱 量子中間表示 及 QDK開發者部落格。 | N/A |
| QDK:計算資源估算 |
.qs、.qasm |
調用內建的資源估計器版本。 | 欲了解更多資訊,請參閱《 Microsoft Quantum 資源估計器簡介》。 | N/A |
| QDK:說明 | .qs |
開啟 VS Code 中 QDK 擴充功能的簡要概述。 | N/A | N/A |
| QDK:運行文件並顯示電路圖 |
.qs、.qasm |
執行目前的程式,並顯示程式的電路及輸出。 | 如需詳細資訊,請參閱 可視化量子電路圖。 | N/A |
| QDK:顯示 API 文件 | .qs |
在新窗格中開啟 API 檔。 若要搜尋此窗格,請按 Ctrl + F。 | 欲了解更多資訊,請參閱 Q# API 參考文獻。 | N/A |
| 偵錯:開始偵錯 |
.qs、.qasm、.qsc |
在除錯器中開啟目前的程式。 | 如需詳細資訊,請參閱 偵錯和測試量子程序代碼。 | 按 F5,選擇進入點操作旁的程式碼鏡頭選項 「除錯 」,或選擇右上角的 執行 圖示,然後選擇 開始除錯。 |
| QDK:運行程式 |
.qs、.qasm、.qsc |
在預設的量子模擬器中執行目前的程式。 | 如需詳細資訊,請參閱 開始使用 Q# 程式。 | 按 Ctrl + F5,選擇進入點操作旁的程式碼鏡頭選項 「執行 」,或選擇右上角的 「執行 」圖示,然後選擇 執行。 |
面板視角
Q# 與 OpenQASM 程式在 VS Code 面板中使用以下檢視:
| View | Action |
|---|---|
| 偵錯主控台 | 顯示執行輸出或偵錯輸出 |
| 問題 | 顯示編譯前的錯誤檢查 |
編輯 Q# 與 OpenQASM 程式碼
VS Code 中大多數常見的程式碼編輯功能,在使用 Q# 和 OpenQASM 程式時也能使用:
- 預編譯錯誤檢查
- 跳至定義
- References
- 函式簽名
- 參數資訊
- 補全建議,包括上下文感知、命名空間成員及型別成員補全。
- Linting - 在 Q# 檔案中,您會在指令清單檔案中設定每個專案的 Linting。 如需詳細資訊,請參閱 使用 Q# 專案。
更多資訊請參閱 VS Code 文件中的 IntelliSense 。
常見工作
以下表格列出了使用 QDK 擴充功能時常見任務的指令。
使用 Q# 檔案和專案
| 任務 | Action | Notes |
|---|---|---|
| 建立新的 Q# 檔案 | 選取 檔案 > 新檔案 > 文字檔案。 以 .qs 副檔名儲存檔案。 |
如果您設定 Files: Default Language = qsharp,新檔案會自動預設為 Q# 格式。 |
| 建立一個 Q# 專案 | 從檔案總管開啟的資料夾中,從指令面板選擇 QDK: Create Q# 專案 ,或在檔案總管中右鍵點擊該資料夾並選擇 Create Q# 專案。 | 如需 Q# 專案的詳細資訊,請參閱 使用 Q# 專案。 |
| 建立範例檔案 | 在空白 .qs 或 .qasm 檔案中輸入 範例,然後從選項列表中選擇範例程式。 |
你也可以在指令面板中選擇「 QDK:開啟 QDK playground 」,在檔案總管中開啟包含 Q# 和 OpenQASM 範例程式的線上資料夾。 |
連線到 Azure Quantum
| 任務 | Action | Notes | 替代使用者操作 |
|---|---|---|---|
| 聯機到 Azure Quantum 工作區 | 選擇 Microsoft Quantum 面板圖示(左下角)。 在 Quantum Workspaces 中選擇 新增現有工作區。 依照提示選取訂用帳戶和工作區。 | 您可以連線到多個工作區。 選取 Quantum 工作區旁的 + 以連線另一個工作區。 您的 VS Code 工作階段之間的工作區連線會持續存在。 | 從 [命令面板] 中,選取 [QDK:連線到 Azure Quantum 工作區]。 |
| 以程序設計方式與 Python 程式連線 | 以滑鼠右鍵按兩下現有的工作區連線,然後選取 [ 複製 Python 程式代碼] 以連線到工作區。 將產生的程式代碼貼到 Python 程式中。 | 欲了解更多資訊,請參閱「使用 QDK Python 套件提交工作至 Azure Quantum」。 | N/A |
執行程式
| 任務 | Action | Notes | 替代使用者操作 |
|---|---|---|---|
| 在本地量子模擬器上執行 Q# 或 OpenQASM 程式 | 在 a .qs 或 .qasm 檔案中,選擇右上角的 執行 圖示,然後選擇 執行。 |
如需量子模擬器的詳細資訊,請參閱 疏鬆量子模擬器。 | 按 Ctrl + F5,或選擇 [QDK:執行檔案並顯示直方圖 ] 或 [QDK:執行檔案並顯示電路圖 ] 在命令面板中,或選擇進入點作業上方的 [執行 程式碼透鏡] 選項。 |
| 偵錯程式 | 在 Q# 或 OpenQASM 程式中,選擇右上角的 執行 圖示,然後選擇 開始除錯。 | 如需 VS Code 中 Q# 調試程式的詳細資訊,請參閱 偵錯和測試量子程式代碼。 | 按 F5,或從進入點作業上方的功能表中選擇 Debug 程式碼透鏡。 |
| 在工作區中檢視提供者和目標 | 選擇 Microsoft Quantum 面板圖示(左下角)。 從 Quantum Workspaces 展開工作區, 然後展開提供者 ,即可查看工作空間中可用的提供者。 展開個別提供者以檢視可用的目標。 | 將滑鼠停留在目標名稱上,以檢視其 狀態 和 佇列時間 ,然後再提交工作。 | N/A |
| 將作業提交至 Azure Quantum | 在 Q# 或 OpenQASM 程式中,選擇工作空間、提供者和目標。 要提交當前程式,請選擇目標旁的箭頭。 | 欲了解更多資訊,請參閱 VS Code 的 QDK 擴充功能「向 Azure Quantum 提交工作」。 | N/A |
| 檢視作業結果 | 展開工作區,然後展開 [ 作業]。 若要從 Azure 儲存體 開啟作業輸出,請選取作業名稱旁的雲端圖示。 | 工作會從最新到最舊列出。 | N/A |