若要建立您可以與其他人共用或重複使用於多個專案中的自定義設定群組,請使用 屬性管理員 建立 屬性表 (檔案 .props )來儲存您想要重複使用或與其他人共用之每一種項目的設定。 使用屬性表比起其他建立「全域」設定的方式,出錯率低得多。
重要
檔案的問題*.user
舊版 Visual Studio 使用擴展名 .user 為 的全域屬性表,且位於 \<userprofile>\AppData\Local\Microsoft\MSBuild\v4.0\ 資料夾中。
Microsoft 不再建議採用此方法。 這些檔案會以每位使用者、每台電腦為基礎,為專案組態設定屬性。 這種 全域 設定可能會干擾建置,尤其是當你在建置電腦上同時針對多個平台時。 舉例來說,如果你同時有 MFC 專案和 Windows Phone 專案,.user那麼其中一項的屬性是無效的。 可重複使用的屬性表更具彈性,也更穩健。
雖然 Visual Studio 仍然安裝.user檔案並參與屬性繼承,但預設是空的。 最佳做法是在 Property Manager 中刪除任何對它們的參照,以確保您的專案不受任何依使用者或電腦而定的設定影響。 此做法對於確保原始碼控制環境中的正確行為非常重要。
若要顯示 屬性管理員,請在功能表列上,根據您的設定,選擇 檢視>屬性管理員 或 檢視>其他視窗>屬性管理員。
如果你想將一組常見且常用的屬性套用到多個專案,可以使用 Property Manager 將它們擷取到一個可重複使用的 屬性表 檔案中,依慣例會有 .props 副檔名。 您可以將工作表(或工作表)套用至新專案,因此您不需要從頭開始設定這些屬性。
在每個組態節點下,您會看到套用至該組態之各個屬性工作表的節點。 系統會新增屬性表,根據您在應用程式精靈中建立專案時選擇的選項來設定通用值。 右鍵點擊任一節點,選擇 屬性 ,就能看到該節點適用的屬性。
所有物業圖會自動匯入專案的主要物業圖(ms.cpp.props),並依照在 物業管理員中出現的順序進行評估。 您可以移動它們以變更評估順序。 稍後評估的屬性表會覆寫先前評估之屬性表中的值。
如需了解 .vcxproj 檔案、.props 與 .targets 檔案、環境變數及命令列中的評估順序詳細資訊,請參閱 專案屬性繼承。
如果您選擇 [新增專案屬性工作表],然後選擇 (例如) MyProps.props 屬性工作表,就會出現屬性頁對話方塊。 請注意,這會套用至 MyProps 屬性工作表。您所做的任何變更都將寫入至工作表,而非專案檔 (.vcxproj)。
如果在 .vcxproj 檔案中直接設定了相同的屬性,則屬性工作表中的屬性會被覆寫。
您可以依需要多次匯入屬性表。 方案中的多個專案可以繼承同一個屬性工作表中的設定,而且專案可以有多個工作表。 屬性工作表本身可以繼承另一個屬性工作表中的設定。
您也可以為多個組態建立通用屬性表。 若要為每個組態建立屬性表,請開啟其中一個組態的快捷選單,選擇 加入現有屬性表,然後再加入其他屬性表。 不過,如果你使用共用屬性工作表,你設定的屬性會套用到該工作表所適用的所有配置。 IDE 不會顯示哪些專案或其他屬性表繼承自指定的屬性表。
在具有許多專案的大型方案中,為方案中的所有專案建立通用屬性表會很有用。 像往常一樣建立屬性表。 使用 屬性管理員 ,將該屬性表新增至方案中的每個專案。 如有必要,您可以在專案層級新增另一個屬性表來設定專案特定值。
重要
.props檔案預設不會參與原始碼控制,因為它不是作為專案項目建立的。 如果要在原始檔控制中包含這個檔案,可以手動將其加入做為方案項目。
建立屬性表
在功能表列上,選擇 檢視>屬性管理員,或 檢視>其他視窗>屬性管理員。 屬性管理員 會開啟。
選擇要套用屬性表的項目。 此項目可以是特定組態,或另一個屬性表。
右鍵點擊該項目,然後選擇新增 Project 屬性表。
在 「新增項目 」對話框中,指定屬性工作表的名稱和位置。 Visual Studio 會
.props將檔案儲存在指定的位置。展開專案下的項目以查看你的物業清單。
在 [屬性管理員] 中,開啟新的屬性工作表,然後設定您要包含的屬性。