共用方式為


DeviceTvmInfoGatheringKB

重要事項

部分資訊與發行前版本產品有關,在正式發行之前可能會實質上進行修改。 Microsoft 對此處提供的資訊,不提供任何明確或隱含的瑕疵擔保。

DeviceTvmInfoGatheringKB階搜捕架構中的數據表包含數據表中所收集 Microsoft Defender 弱點管理 評估事件數據的DeviceTvmInfoGathering元數據。 此DeviceTvmInfoGatheringKB數據表包含 Defender 弱點管理 資訊收集來評估裝置所使用的各種組態和受攻擊面區域評估清單。 使用這個參考來建立從表格取回之資訊的查詢。

此進階搜捕數據表是由來自 適用於端點的 Microsoft Defender 的記錄填入。 如果您的組織尚未在 Microsoft Defender 全面偵測回應 中部署服務,則使用數據表的查詢將無法運作或傳回任何結果。 如需如何在 Defender 全面偵測回應 中部署適用於端點的 Defender 的詳細資訊,請參閱部署支持的服務

如需進階搜捕結構描述中其他表格的資訊,請參閱 進階搜捕參考 (部分內容為機器翻譯)。

資料行名稱 資料類型 描述
IgId string 所收集資訊片段的唯一標識符
FieldName string 在 DeviceTvmInfoGathering 數據表的 AdditionalFields 數據行中顯示此資訊的功能變數名稱
Description string 所收集資訊的描述
Categories dynamic 資訊所屬的類別清單,格式為 JSON 陣列
DataStructure string 所收集信息的數據結構

您可以使用此資料表來探索 中 DeviceTvmInfoGathering 可用的資訊類型,以便稍後微調搜捕查詢。

例如,若要查看所收集的資訊清單,您可以嘗試下列查詢:

// Check out what is being collected 
DeviceTvmInfoGatheringKB  

從結果中,假設您對可用的類別感興趣,您可以使用下列查詢:

// Return all available categories 
DeviceTvmInfoGatheringKB 
| mv-expand Categories to typeof(string) 
| distinct Categories 

然後,假設您想要查看涉及 TLS 通訊協定的評量類別:

// Return all findings for a specified category 
DeviceTvmInfoGatheringKB 
| where Categories contains "tls" 

接著,您可以使用產生的欄位,使用 DeviceTvmInfoGathering 資料表來取得使用 TLS 用戶端 1.0 版的裝置清單。

// Return all devices on which the TLS version 1.0 is enabled 
DeviceTvmInfoGathering 
| where AdditionalFields.TlsClient10 == "Enabled" or AdditionalFields.TlsServer10 == "Enabled" 

提示

想要深入了解? 請到我們的技術社群中與 Microsoft 安全性社群互動: Microsoft Defender 全面偵測回應技術社群