儘管 ActiveSync 組織設定,Windows Mail 應用程式並未遭到封鎖
徵狀
貴組織的 Exchange ActiveSync 設定會設定為封鎖對所有裝置的存取。 不過,您仍然可以使用 Windows Mail 應用程式來存取信箱。 即使行動裝置詳細數據指出使用 Windows Mail 所建立的信箱連線將會遭到封鎖,還是會發生這種情況。
使用下列方法來確認 Exchange ActiveSync 已正確設定。
若要檢查組織的 ActiveSync 設定:
Get-ActiveSyncOrganizationSettings | ft DefaultAccessLevel
如果 ActiveSync 設定為封鎖裝置,此命令會傳回下列輸出:
DefaultAccessLevel : Block
若要檢查已設定為與特定信箱同步的裝置:
Get-MobileDeviceStatistics -Mailbox <MailboxID> | fl DeviceUserAgent,DeviceType,deviceos,deviceaccessstate
這個指令會傳回下列輸出:
DeviceType : UniversalOutlook DeviceOS : WINDOWS DeviceAccessState : Unknown
若要檢查與特定信箱相關聯的裝置:
Get-MobileDevice -Mailbox <MailboxID> | fl DeviceUserAgent,DeviceType,deviceos,deviceaccessstate
這個指令會傳回下列輸出:
DeviceUserAgent : microsoft.windowscommunicationsapps DeviceType : UniversalOutlook DeviceOS : WINDOWS DeviceAccessState : Blocked
原因
Windows Mail 應用程式使用原生 Microsoft 同步處理技術,不會遭到 ActiveSync 裝置存取規則封鎖。 貴組織的 ActiveSync 設定和裝置存取規則僅用於管理行動和 ActiveSync 連線的 Microsoft Outlook。
解決方案
若要封鎖 Windows Mail 應用程式存取信箱,請使用 Set-CASMailbox Cmdlet 的用戶端存取規則或 UniversalOutlookEnabled 參數。
意見反應
https://aka.ms/ContentUserFeedback。
即將登場:在 2024 年,我們將逐步淘汰 GitHub 問題作為內容的意見反應機制,並將它取代為新的意見反應系統。 如需詳細資訊,請參閱:提交並檢視相關的意見反應