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當 iOS 版 Outlook 或 Android 連線到 Exchange Server 時發生錯誤:不安全的連線或安全連線無法使用

原始 KB 編號: 4056392

徵狀

當您使用適用於 iOS 的 Microsoft Outlook 或 Android 版 Outlook 登入使用 SSL 憑證進行安全連線的 Exchange Server 實例時,您會收到下列其中一個錯誤訊息:

不安全的連線。 您還是要登入嗎?

無法使用安全連線。 您還是要登入嗎?

原因

發生此問題的原因是 SSL 憑證因為下列其中一個原因而被視為不受支援:

  • SSL 憑證無效或已過期。
  • SSL 憑證不受信任。

注意事項

iOS 版 Outlook 和 Android 版 Outlook 使用標準 Java 受信任證書頒發機構單位 (CA) 。 如果您組織的憑證不是由屬於標準 Java 受信任證書頒發機構單位的證書頒發機構單位所簽署,就會發生此錯誤。

解決方案

您可以放心地忽略此錯誤訊息,並登入 Exchange Server。 此錯誤訊息應該只會顯示一次。

建議您使用 Java CA 證書存儲正式支援的 SSL 憑證。

如何確認 Java CA 信任憑證

  1. 取得憑證的 CA。

  2. 下載最新的 Java SE 開發工具組 (JDK) 。 此套件包含 Java 信任的 CA。

  3. 在以 Windows 為基礎的電腦上開啟命令提示字元視窗,或在 macOS 型電腦上開啟 [終端機] 視窗。

  4. 執行下列命令,使用keytool公用程式來列出信任的CA:

     keytool -keystore "<keystore location>" -storepass changeit -list -v
    

    注意事項

    在以macOS為基礎的電腦上, <金鑰存放區位置> 參數可以是 “$JAVA_HOME/jre/lib/security/cacerts”。

  5. 確認憑證的 CA 位於清單中。

如需keytool公用程式的詳細資訊,請參閱下列文章: