Outlook 無法透過防火牆或在公用和專用網之間執行網路位址轉換 (NAT) 的 Proxy 伺服器連線

原始 KB 編號: 291615

徵狀

Outlook 用戶端無法透過在公用和專用網之間執行 NAT 的防火牆或 Proxy 伺服器連線。

原因

在轉譯期間編輯包含遠端過程調用 (RPC) 資訊的 IP 封包時,IP 封包會遺失 RPC 連線資訊。 這會導致客戶端無法連線到伺服器。 此外,Outlook 在解決防火牆或 Proxy 伺服器後方 Microsoft Exchange Server 計算機名稱時可能會發生問題。

因應措施

防火牆或 Proxy 伺服器的因應措施不是以 Microsoft Windows NT 為基礎,就是在兩個網路之間執行一對一轉譯。 這也稱為在公用和專用網之間 開啟管道或通道 。 這會接受公用網路上特定位址的所有要求,並將其直接傳遞至專用網。 如需有關如何設定一對一翻譯的其他資訊,請參閱製造商的檔。

一對一轉譯或管道不適用於以 Windows NT 為基礎的防火牆和 Proxy 伺服器,因為 Outlook 用戶端會嘗試系結至防火牆上 EPM) 埠 135 (端點對應程式埠。 此伺服器不會將正確的 Exchange Server 連線資訊傳回 Outlook 用戶端。

另一個可能的因應措施是使用 Outlook Web App。 這只需要允許 HTTP 流量通過防火牆或 Proxy 伺服器。

其他相關資訊

如需詳細資訊,請參閱下列 RFC (批注要求) :

  • RFC 1631 - IP 網路位址翻譯工具 (NAT)
  • RFC 1918 - 私人因特網的位址配置

您可以 在這裡找到這些 RFC。