徵兆
當您嘗試使用 Microsoft Outlook 中的新增帳戶精靈為 Microsoft 365 設定新郵件帳戶時,系統不會自動設定您的 Outlook 設定檔。 此外,當 Outlook 嘗試針對您的設定檔設定伺服器設定時,您會收到下列錯誤訊息:
無法對您的郵件服務使用加密連線
當您使用 Microsoft Remote Connectivity Analyzer 進行測試時,可能會傳回下列錯誤訊息:
自動探索無法處理指定的電子郵件地址。 只允許搜索信箱和連絡人。
原因
這個問題是下列其中一個原因所造成:
- 在 Outlook 新增帳戶精靈的「自動帳戶設定」頁面中輸入錯誤的電子郵件地址。
- 未針對您執行的 Outlook 版本安裝 Outlook 自動連線至 Exchange Online 所需的更新。
- 您網域的 Autodiscover CNAME 記錄不存在或未正確設定。
- 在使用 Active Directory 同步處理的組織中,郵件、mailNickname、displayName 和 proxyAddresses 屬性並未針對 內部部署的 Active Directory 中同步的使用者正確設定。
注意
本文討論 Outlook 2016、Outlook 2013 及 Exchange Online。 如需從行動裝置連線到 Exchange Online 的說明,請參閱 在手機或平板電腦上設定及使用 Microsoft 365。 如需將 Outlook 連線到第三方服務的說明,請連絡您的第三方郵件提供者。
解決方法
建議的方法
方法 1:執行 Microsoft 365 支援及復原小幫手
注意
Microsoft 支援服務 和復原小幫手案例不適用於新的 Windows 版 Outlook。
在取得說明應用程式中使用 傳統 Outlook 設定檔設定疑難解答員 。
此疑難解答員會執行自動化檢查,並傳回可能的解決方案來修正任何偵測到的問題。
其他方法
使用自訂網域
若方法 1 無法解決該問題,而且正在使用與 Microsoft 365 搭配的自動網域,請按照清單順序使用下列方法。 若第一個方法無法解決您的問題,請移至下一個方法。
方法 2:升級為新版的 Outlook
首先,請確定您在 Outlook 中新增帳戶精靈的 [自動帳戶設定] 頁面中輸入正確的電子郵件地址與密碼。
若您使用的是 Outlook 2010 或舊版,請升級為最新版本的 Outlook。 如需詳細資訊,請參閱在電腦上使用 Microsoft 365 商務版下載並安裝 Office。
如需有關如何設定 Microsoft 365 Outlook 的詳細資訊,請參閱下列建議:
如果這個方法無法解決該問題,請執行方法 3。
方法 3:確認正確設定自動探索 CNAME 記錄
必須存在並正確設定自動探索 CNAME 記錄。 強烈建議您在使用 Outlook 連線到 Exchange Online 信箱時設定 Exchange 自動探索。 Exchange Online 中的 Outlook 連線需要設定自動探索及其他相關 DNS 記錄。 系統管理員可以使用 Microsoft 365 中的網域疑難排解精靈或 Microsoft 遠端連線分析程式,確認是否已正確設定記錄。
使用 Microsoft 365 的網域疑難排解精靈
若要使用 Microsoft 365 的網域疑難排解精靈,請依照下列步驟執行。
- 使用系統管理員帳戶登入 Microsoft 365 入口網站 (https://portal.office.com)。
- 選取 [系統管理員] 以開啟 Microsoft 365 系統管理中心。
- 在左側瀏覽窗格中,選取 [網域],然後選取受影響使用者所使用的功能變數名稱,然後選取 [疑難解答] 以啟動精靈。
使用 Microsoft 遠端連線分析程式
要使用 Microsoft 遠程連接分析器測試 Exchange Autodiscover 自動探索是否正常運作,請依照下列步驟執行:
在網頁瀏覽器中,瀏覽至下列網站的 Microsoft Remote Connectivity Analyzer 工具:
完成表單上所有必要的欄位,然後選取 [ 執行測試]。
測試完成後,請確認是否成功。
如果測試成功,Autodiscover 便會正常運作。
若測試失敗,請確認已正確設定。自動探索服務 如需詳細資訊,請參閱以下資源:
若組織中的所有信箱均為 Exchange Online 信箱,請新增指向 "autodiscover.outlook.com" 的自動探索 CNAME 記錄。 如需詳細資訊,請參閱為所有 DNS 主機服務提供者的 Microsoft 365 建立 DNS 記錄和 Microsoft 365 的外部網域名稱系統記錄。
若您有 Exchange 混合部署,請為現有的 SMTP 網域設定自動探索公用 DNS 記錄,指向內部部署Exchange 伺服器。 如需詳細資訊,請參閱《混合部署預設條件》。
方法 4:確定已正確設定 Active Directory 中的使用者屬性
如果您有 Exchange 混合式部署,您可以使用 Get-RemoteMailbox Cmdlet 來判斷是否已為受影響的使用者設定正確的屬性。 未針對一或多個這類屬性設定值時,便會發生常見問題。 下列範例會顯示為用戶設定的正確屬性。
屬性 | 範例 |
---|---|
primarySMTPAddress | ted@contoso.com |
別名 | ted |
displayName | Ted Bremer |
emailAddresses | SMTP: ted@contoso.com X400:c=us;a= ;p=First Organization;o=Exchange;s=Bremer;g=Ted |
remoteRoutingAddress | ted@contoso.mail.onmicrosoft.com |
您可以使用 Set-RemoteMailbox cmdlet 更新這些屬性,
在設定這些屬性的正確值後, 會開始強制執行目錄同步 作業,然後嘗試在 Outlook 中設定使用者的電子郵件帳戶。
若不使用自訂網域
方法 2:在 Outlook 中使用新增帳戶精靈
如果方法 1 無法解決問題,而且您未將自定義網域與 Microsoft 365 搭配使用,您可以使用 Outlook 中的 [新增帳戶精靈],使用預設的「onmicrosoft.com」型電子郵件位址,在註冊 Microsoft 365 時,為使用者設定 Outlook 配置檔。 當您使用 [新增帳戶精靈] 來設定新的郵件設置檔時,您會以 user>@<domain.onmicrosoft.com> 的形式<指定您的Microsoft 365 密碼和預設Microsoft 365 電子郵件位址。onmicrosoft.com 。 kim@contoso.onmicrosoft.com
這個方法受到支援,而且適用於可能不打算有自己的虛名或自定義網域的客戶。 此方法也支援 Autodiscover。 若您的信箱伺服器位置變更,Outlook 會根據信箱伺服器的新位置做相應的更新。
其他相關資訊
Microsoft 不支援手動設定 Outlook 設定檔,用來連線至 Microsoft 365 中的 Exchange Online 信箱。 不過,我們可以協助您完成其他工作,例如設定 DNS 和自動探索記錄,如方法 2 中所述。 這個方法可讓您透過支援的方法設定您的帳戶。
是否仍需要協助? 前往 Microsoft Community。