公用資料夾信箱移轉要求中的 「DestinationADNotUpToDatePermanentException」 錯誤

徵狀

在公用資料夾移轉批次中,您會看到失敗的公用資料夾信箱移轉要求,其失敗類型為 “DestinationADNotUpToDatePermanentException”。

詳細失敗的螢幕快照。

當您嘗試移除失敗的公用資料夾信箱移轉要求時,您會收到下列錯誤訊息:

找不到具有所提供資訊的唯一要求。

原因

如果公用資料夾信箱移轉要求是孤立或重複的,就會發生此問題。

解決方案

若要解決此問題,請執行 此腳本,以識別並移除孤立或重複的公用資料夾信箱移轉要求。 如果文稿無法運作,請遵循下列步驟:

  1. 連線至 Exchange Online PowerShell

  2. 執行下列 Cmdlet 來識別重複的公用資料夾信箱移轉要求:

    Get-PublicFolderMailboxMigrationRequest|Sort-Object targetmailbox|ft targetmailbox,requestguid,name,status
    

    注意: 如需此 Cmdlet 的詳細資訊,請參閱 Get-PublicFolderMailboxMigrationRequest

    以下是輸出的範例:

    重複移轉要求的螢幕快照。

  3. 執行下列 Cmdlet,以移除失敗的公用資料夾信箱移轉要求:

    Remove-PublicFolderMailboxMigrationRequest -Identity "<RequestGuid>" -Force
    

    注意:將 RequestGuid> 取代<為您在步驟 2 中從 Cmdlet 取得的實際結果。 如需 Cmdlet 的詳細資訊,請參閱 Remove-PublicFolderMailboxMigrationRequest

其他相關資訊

狀況良好和重複的作業具有包含目標信箱 GUID 的相同名稱。 名稱的格式為 PublicFolderMailboxMigration<TargetMailboxGuid>。 例如, PublicFolderMailboxMigration058553ac-200f-4fba-91c4-300e4fa0e8e5。 狀況良好和重複的作業都指向相同的目標信箱,而且其身分識別相同。

不過,完成移轉批次與重複作業無關,因為批次不會將重複作業視為移轉的一部分。 只有具有對應作用中移轉使用者的工作才會被視為屬於移轉。 作用中的移轉使用者和移轉要求都會透過 RequestGuid 參數連線。 因此,重複的作業沒有屬於移轉的對應作用中移轉使用者。

在此情況下,最好使用 RequestGuid 參數來移除 Orpahned 或重複的工作。

以下是說明這一點的範例。 在 Get-PublicFolderMailboxMigrationRequest Cmdlet (的輸出中,如螢幕快照 1) 所示,您會在公用資料夾移轉批次中檢視個別作業的狀態,而且您會看到重複的工作指向與狀況良好工作相同的目標信箱。 在 Get-MigrationUser Cmdlet (的輸出中,如螢幕快照 2) 所示,您會看到移轉使用者的資訊,但不會看到重複作業所指向的目標信箱有任何失敗狀態。

螢幕快照 1:

重複移轉作業的螢幕快照。

螢幕快照 2:

移轉用戶狀態的螢幕快照。