Share via


月臺和月台系統 Configuration Manager

適用於:Configuration Manager (目前的分支)

以 Windows 為基礎的電腦需要特定設定,以支援其作為站台系統伺服器 Configuration Manager 用。

針對某些產品,例如軟體更新點 Windows Server Update Services (WSUS) ,您需要參閱產品檔,以識別其他使用必要條件和限制。 這裡只會包含直接套用以搭配 Configuration Manager 使用的組態。

一般需求和限制

下列需求適用於所有月台系統伺服器:

  • 每個站台系統伺服器都必須使用64位作業系統。 唯一的例外是發佈點站台系統角色,您可以在某些 32 位操作系統上安裝該角色。

  • 任何 OS 的 Server Core 安裝都不支援站台系統。 例外狀況是發佈點支援 Server Core 安裝。 如需詳細資訊,請參閱 Configuration Manager 月台系統伺服器支援的作業系統

  • 安裝站臺系統伺服器之後,不支援變更:

    • 月臺系統計算機所在的網域功能變數名稱 (也稱為網 域重新命名) 。

    • 計算機的網域成員資格。

    • 計算機的名稱。

      如果您必須變更這些專案,請先從計算機移除月臺系統角色。 然後在變更完成後重新安裝角色。 對於影響月臺伺服器的變更,請先卸載月臺。 然後在變更完成後重新安裝網站。

  • Windows Server 叢集實例不支援月台系統角色。 唯一的例外是月臺資料庫伺服器。 如需詳細資訊,請參閱針對月臺資料庫使用 SQL Server Always On 故障轉移叢集實例

    Configuration Manager 安裝程式不會封鎖在具有故障轉移叢集 Windows 角色的電腦上安裝月台伺服器角色。 SQL Server Always On 可用性群組需要此角色,因此您先前無法在月臺伺服器上共置月臺資料庫。 透過這項變更,您可以使用可用性群組和被動模式的月臺伺服器,建立具有較少伺服器的高可用性網站。 如需詳細資訊,請 參閱高可用性選項

  • 不支援變更任何 Configuration Manager 服務的啟動類型或「以身分登入」設定。 如果您這樣做,您可能會防止金鑰服務正確執行。

.NET 版本需求

從 2107 版開始,站臺伺服器和特定站台系統需要 Microsoft .NET Framework 4.6.2 版。 在您執行安裝程式來安裝或更新月臺之前,請先更新 .NET 並重新啟動系統。 如果可能,請在您的環境中安裝最新版的 .NET 4.8 版。

注意事項

.NET Framework 4.6.2 版已預安裝 Windows Server 2016。 更新版本的 Windows 會預安裝更新版本的 .NET Framework。

某些操作系統版本不支援 .NET Framework 4.8 版。

如需詳細資訊,請參閱 .NET Framework 系統需求

月臺伺服器

如果站臺伺服器沒有任何需要 .NET 的共置角色,它仍然需要 .NET,但安裝程式不會自動安裝它。 請確定站台伺服器本身至少有 .NET 4.6.2 版。 可能的話,請安裝 .NET 4.8。

月臺系統

重要事項

如果您要從 System Center 2012 Configuration Manager R2 Service Pack 1 升級,則必須手動確認遠端月台系統至少有 .NET 4.6.2 版。 Configuration Manager 目前分支安裝程式會略過此案例中的檢查。

在 Configuration Manager 設定期間,如果站台系統具有早於 4.6.2 的版本,您會看到必要條件檢查警告。 這項檢查是警告,而不是錯誤,因為安裝程式將會安裝 4.6.2 版。 當 .NET 更新時,通常需要 Windows 重新啟動。 需要重新啟動時,站台系統會傳送狀態消息 4979。 Configuration Manager 隱藏重新啟動;系統不會自動重新啟動。

對於需要 .NET 的不同網站角色類型,其行為會有所不同:

  • 下列月臺系統角色支援 .NET 的就地升級。 升級 .NET 之後,如果需要重新啟動,它會傳送狀態消息 4979。 角色會繼續與舊版 .NET 一起執行。 Windows 重新啟動之後,角色會開始使用新的 .NET 版本。

    • Asset Intelligence 同步處理點
    • 管理點
    • 服務連接點
    • 數據倉儲服務點
  • 升級 .NET 時,下列月臺系統角色會卸載並重新安裝。 在月臺更新期間,月臺元件管理員會移除角色,然後更新 .NET。 如果需要重新啟動,它會傳送狀態消息 4979。 重新啟動之後,月臺元件管理員會使用新的 .NET 版本重新安裝角色。 角色在等候您重新啟動伺服器時可能無法使用。

    • 系統管理服務的SMS提供者
    • 憑證登錄點
    • 註冊點
    • 註冊 Proxy 點
    • Reporting Services 點
    • 軟體更新點

注意事項

目前,您仍然需要在需要的月臺系統上啟用適用於 .NET Framework 3.5 的 Windows 功能。

如果站臺系統至少有 4.6.2 版,但早於 4.8 版,您也會看到必要條件檢查警告。 建議您安裝最新版的 .NET 4.8 版,以取得最新的效能和安全性改善。 Configuration Manager 安裝程式不會自動安裝 .NET 4.8 版。 更新版本的 Configuration Manager 需要 .NET 4.8 版。

另外還有新的 管理見解 ,可建議尚未有 .NET 4.8 版或更新版本的月台系統。

管理 .NET 更新的系統重新啟動

不論您是在更新月臺之前更新 .NET,還是設定更新月臺,.NET 都可能需要重新啟動才能完成安裝。 安裝 .NET Framework 之後,可能需要其他更新。 這些更新也可能需要伺服器重新啟動。

如果您需要在更新月臺之前管理裝置重新啟動,請使用下列建議程式:

  1. 安裝最新的基準 .NET 版本。 例如,安裝 .NET 4.8 版。
  2. 重新啟動伺服器。
  3. 掃描軟體更新並安裝最新的 .NET 累積更新。
  4. 重新啟動伺服器。
  5. 將月臺更新為最新的最新分支版本。

管理中心網站和主要站台伺服器

如需所有必要條件的詳細資訊,包括許可權,請參閱 安裝主要月臺或 CAS 的必要條件。 下列各節詳細說明您需要安裝或啟用的必要元件。

月臺伺服器的 Windows Server 角色和功能

  • .NET Framework 3.5

  • 遠端差異壓縮

  • 當您在月台伺服器以外的伺服器上使用軟體更新點時,請在月臺伺服器上安裝 WSUS 管理控制台。

月臺伺服器的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

月臺伺服器的 Windows ADK

  • 安裝或升級管理中心網站或主要月臺之前,請先安裝安裝您要安裝或升級 Configuration Manager 版本所需的 Windows 評定及部署套件 (ADK) 版本。 如需詳細資訊,請參閱 Windows ADK 的支援

  • 如需這項需求的詳細資訊,請參閱 OS部署的基礎結構需求

月臺伺服器的 C++ 可轉散發套件

  • 從 2107 版開始,Configuration Manager 會在每部安裝月臺伺服器的計算機上安裝 Microsoft Visual C++ 2015-2019 可轉散發套件 (14.28.29914.0) 。 在 2103 版和更早版本中,它會安裝 Visual C++ 2013 版本 (12.0.40660.0) 。

  • CAS 和主要月臺都需要適用可轉散發檔案的 x86 和 x64 版本。

月台伺服器的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

月臺伺服器的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

重要事項

請勿卸載 SQL Server 原生用戶端,我們仍需要特定角色。

次要月台伺服器

次要月臺伺服器的 Windows Server 角色和功能

  • .NET Framework 3.5

  • 遠端差異壓縮

次要月臺伺服器的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

次要月臺伺服器的 C++ 可轉散發套件

  • 從 2107 版開始,Configuration Manager 會在每部安裝次要月臺伺服器的計算機上安裝 Microsoft Visual C++ 2015-2019 可轉散發套件 (14.28.29914.0) 。 在 2103 版和更早版本中,它會安裝 Visual C++ 2013 版本 (12.0.40660.0) 。

  • 次要月臺只需要 x64 版本。

次要月臺伺服器的預設站台系統角色

根據預設,次要月臺會安裝 管理點發佈點。 請確定次要月臺伺服器符合這些站台系統角色的必要條件。

次要月台伺服器的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

次要月臺伺服器的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

資料庫伺服器

月臺資料庫伺服器的遠端登錄服務

在安裝 Configuration Manager 月臺期間,請在裝載月臺資料庫的計算機上啟用遠端登錄服務。

月臺資料庫伺服器的 SQL Server

  • 安裝 CAS 或主要月臺之前,請先安裝支援的 SQL Server 版本來裝載月臺資料庫。 如需詳細資訊,請參閱支援的 SQL Server 版本

  • 安裝次要月臺之前:

    • 您可以安裝支援的 SQL Server 版本。

    • 您可以選擇讓 Configuration Manager 安裝 SQL Server Express。 請確定伺服器符合執行 SQL Server Express的需求。

資料庫伺服器的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

月臺資料庫伺服器的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

SMS 提供者伺服器

適用於SMS提供者的 Windows ADK

SMS 提供者的 Windows Server 角色和功能

Web Server (IIS) :每個提供者都會嘗試安裝 管理服務。 此服務相依於 IIS,可將憑證系結至 HTTPS 埠 443。 Configuration Manager 使用 IIS API 來檢查此憑證設定。 如果您設定增強 HTTP 的月臺,Configuration Manager 會使用 IIS API 來系結月臺產生的憑證。 除非伺服器已經有 PKI 型憑證,否則月臺會自動使用網站的自我簽署憑證。

SMS 提供者的 .NET Framework

如果您使用 系統管理服務,裝載SMS提供者角色的伺服器需要 .NET 4.5 或更新版本。 從 2107 版開始,此角色需要 .NET 4.6.2 版,建議使用 4.8 版。 如需詳細資訊, 請參閱 .NET 版本需求

SMS 提供者的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

SMS 提供者的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

Asset Intelligence 同步處理點

重要事項

從 2021 年 11 月開始,Configuration Manager 的這項功能已被取代。 如需詳細資訊,請參閱 Asset Intelligence 取代

AISP 的 .NET Framework

安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

適用於 AISP 的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

AISP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

憑證登錄點

警告

從2203版開始,不再支持憑證登錄點。 如需詳細資訊,請 參閱資源存取淘汰的常見問題。

CRP 的 Windows Server 角色和功能

  • .NET Framework

    • HTTP 啟用

CRP 的 IIS 組態

  • 應用程式開發:

    • ASP.NET 3.5 (並自動選取選項)

    • ASP.NET 4.5 (並自動選取選項)

  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

    • IIS 6 WMI 相容性

CRP 的 .NET Framework

安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

適用於CRP的SQL ODBC驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

CRP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

數據倉儲服務點

如需此角色必要條件的詳細資訊,請 參閱數據倉儲服務點

DWSP 的 .NET Framework

安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

DWSP 的 SQL Server

數據倉儲資料庫需要 SQL Server 2012 或更新版本。 版本可以是 Standard、Enterprise 或 Datacenter。 數據倉儲的 SQL Server 版本不需要與月台資料庫伺服器或 Reporting Services 點相同。

發佈點

DP 的 Windows Server 角色和功能

  • 遠端差異壓縮

注意事項

發佈點傳輸內容時,會使用 Windows 內建的 背景智慧型手機傳送服務 (BITS) 傳輸。 發佈點角色不需要安裝選用的 BITS IIS 伺服器擴充功能,因為用戶端不會將資訊上傳至該功能。

DP 的 IIS 組態

  • 應用程式開發:

    • ISAPI 擴充性
  • 安全性:

    • Windows 驗證
  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

    • IIS 6 WMI 相容性

根據預設,IIS 會使用要求篩選來封鎖 HTTP 或 HTTPS 通訊存取數個擴展名和資料夾位置。 在發佈點上,此設定可防止用戶端下載已封鎖延伸模組或資料夾位置的套件。 如需詳細資訊,請參閱 發佈點的 IIS 要求篩選

發佈點要求 IIS 允許下列 HTTP 動詞命令:

  • GET
  • PROPFIND

DP 的 C++ 可轉散發套件

  • 從 2107 版開始,Configuration Manager 會在每部裝載發佈點的計算機上安裝 Microsoft Visual C++ 2015-2019 可轉散發套件 (14.28.29914.0) 。 在 2103 版和更早版本中,它會安裝 Visual C++ 2013 版本 (12.0.40660.0) 。

  • 安裝的版本取決於計算機的平臺 (x86 或 x64) 。

新增 DP 的 PXE 支援

有兩個選項可支持發佈點上的 PXE:

  • 啟用 Configuration Manager PXE 回應程式,而不需要 Windows 部署服務。

  • 安裝和設定 Windows 部署服務 (WDS) Windows Server 角色。

    注意事項

    當您啟用發佈點以支援 PXE 時,WDS 會自動安裝和設定。

如需詳細資訊,請 參閱安裝和設定發佈點

新增 DP 的多播支援

  • 安裝和設定 Windows 部署服務 (WDS) Windows Server 角色。

    注意事項

    當您啟用發佈點以支援多播時,WDS 會自動安裝和設定。

  • 請確定 SQL Server Native Client 已安裝且為最新狀態。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

Endpoint Protection 點

端點保護點的 Windows Server 角色和功能

  • .NET Framework 3.5

  • Windows Defender 功能 (Windows Server 2016 或更新版本)

端點保護點的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

端點保護點的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

註冊點

重要事項

由於內部部署 MDM 和 macOS Configuration Manager 用戶端已被取代,此站台系統角色也會被取代。 如需詳細資訊,請參閱已移除和已淘汰的 Configuration Manager 功能

註冊點的 Windows Server 角色和功能

  • .NET Framework 3.5

    • HTTP 啟用 (和自動選取的選項)

    • ASP.NET 4.5

    • Windows Communication Foundation (WCF) Services

註冊點的 IIS 組態

  • 常見的 HTTP 功能:

    • 預設文件
  • 應用程式開發:

    • ASP.NET 3.5 (並自動選取選項)

    • .NET 擴充性 3.5

    • ASP.NET 4.5 (並自動選取選項)

    • .NET 擴充性 4.5

  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

註冊點的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

註冊點的計算機記憶體

  • 裝載此月台系統角色的計算機至少必須有 5% 的電腦可用記憶體,才能讓站台系統角色處理要求。

  • 當此月台系統角色與具有相同需求的另一個月台系統角色共置時,計算機的此記憶體需求不會增加,但至少會維持 5%。

SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

註冊 Proxy 點

重要事項

由於內部部署 MDM 和 macOS Configuration Manager 用戶端已被取代,此站台系統角色也會被取代。 如需詳細資訊,請參閱已移除和已淘汰的 Configuration Manager 功能

註冊 Proxy 點的 Windows Server 角色和功能

  • .NET Framework 3.5

註冊 Proxy 點的 IIS 組態

  • 常見的 HTTP 功能:

    • 預設文件

    • 靜態內容

  • 應用程式開發:

    • ASP.NET 3.5 (並自動選取選項)

    • ASP.NET 4.5 (並自動選取選項)

    • .NET 擴充性 3.5

    • .NET 擴充性 4.5

  • 安全性:

    • Windows 驗證
  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

註冊 Proxy 點的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

註冊 Proxy 點的計算機記憶體

  • 裝載此月台系統角色的計算機至少必須有 5% 的電腦可用記憶體,才能讓站台系統角色處理要求。

  • 當此月台系統角色與具有此相同需求的另一個月台系統角色共置時,計算機的記憶體需求不會增加,但至少會維持 5%。

後援狀態點

適用於 FSP 的 Windows Server 角色和功能

根據 Windows Server 的版本,啟用下列其中一項功能:

  • BITS 伺服器擴充功能和自動選取的選項
  • 背景智慧型手機傳送服務 (BITS) 和自動選取的選項

IIS 設定

下列新增專案需要預設 IIS 組態:

  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

管理點

MP 的 Windows Server 角色和功能

根據 Windows Server 的版本,啟用下列其中一項功能:

  • BITS 伺服器擴充功能和自動選取的選項
  • 背景智慧型手機傳送服務 (BITS) 和自動選取的選項

MP 的 IIS 組態

  • 應用程式開發:

    • ISAPI 擴充性
  • 安全性:

    • Windows 驗證
  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

    • IIS 6 WMI 相容性

若要確定用戶端可以成功與管理點通訊,請確定 IIS 允許下列 HTTP 動詞命令:

  • GET
  • POST
  • CCM_POST
  • PROPFIND

MP 的 .NET Framework

安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

適用於 MP 的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

MP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

Reporting Services 點

RSP 的 .NET Framework

安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

適用於 RSP 的 SQL Server Reporting Services

  • 安裝並設定至少一個 SQL Server 實例,以支援 SQL Server Reporting Services。

  • 您用於 SQL Server Reporting Services 的實體可以是您用於月臺資料庫的相同實例。

  • 您使用的實例可以與 System Center 產品共用。 System Center 產品不能有共用 SQL Server 實例的限制。

適用於 RSP 的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

RSP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

服務連接點

SCP 的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

SCP 的 C++ 可轉散發套件

  • 從 2107 版開始,Configuration Manager 會在服務連接點上安裝 Microsoft Visual C++ 2015-2019 可轉散發套件 (14.28.29914.0) 。 在 2103 版和更早版本中,它會安裝 Visual C++ 2013 版本 (12.0.40660.0) 。

適用於 SCP 的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

SCP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

軟體更新點

SUP 的 Windows Server 角色和功能

  • .NET Framework 3.5

  • 需要預設的 IIS 組態。

SUP 的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

Windows Server Update Services (SUP 的 WSUS)

安裝 WSUS 伺服器角色。 如需詳細資訊,請 參閱規劃軟體更新

注意事項

當您在遠端月台系統上使用軟體更新點時,請在月臺伺服器上安裝 WSUS 管理主控台。

適用於 SUP 的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

SUP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client

狀態移轉點

SMP 的 Windows Server 角色和功能

  • .NET Framework 3.5

    • HTTP 啟用 (和自動選取的選項)

    • ASP.NET 4.5

SMP 的 IIS 組態

  • 常見的 HTTP 功能:

    • 預設文件
  • 應用程式開發:

    • ASP.NET 3.5 (並自動選取選項)

    • .NET 擴充性 3.5

    • ASP.NET 4.5 (並自動選取選項)

    • .NET 擴充性 4.5

  • IIS 6 管理兼容性:

    • IIS 6 Metabase 相容性

SMP 的 .NET Framework

  • 啟用適用於 .NET Framework 3.5 的 Windows 功能。

  • 安裝支援的 .NET Framework 版本。 如需詳細資訊, 請參閱 .NET 版本需求

適用於 SMP 的 SQL ODBC 驅動程式

從 2309 版開始,Configuration Manager 需要安裝 ODBC driver for SQL Server 作為必要條件。 當您建立 新網站更新 現有的網站時,需要此必要條件。 Configuration Manager 不會管理 ODBC 驅動程式的更新。 請確定此元件是最新的。

如需詳細資訊,請參閱必要條件檢查 - 適用於 SQL Server 的 SQL ODBC 驅動程式

SMP 的 SQL Server Native Client

當您安裝新月臺時,Configuration Manager 會自動將 SQL Server Native Client 安裝為可轉散發元件。 安裝月臺之後,Configuration Manager 不會升級 SQL Server Native Client。 請確定此元件是最新的。 如需詳細資訊,請參閱必要條件檢查 - SQL Server Native Client