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當您嘗試開啟 Office 文件時,收到錯誤訊息

徵兆

當您嘗試在 [適用於] 區段中所列的任何 Microsoft Office 程式中開啟檔案時,您會收到下列其中一則錯誤訊息:

檔案名稱無效。

檔案無法存取。

您輸入的路徑 'filename' 太長。 輸入較短的路徑。

找不到 filename。 請檢查檔案名稱的拼寫,並確認位置是否正確。

發生 DDE 錯誤,而且因太長而無法顯示錯誤描述。 如果檔案名稱或路徑很長,請嘗試重新命名檔案或將它複製到不同的資料夾。

錯誤訊息的螢幕擷取畫面。

注意

當您從對應的磁片磁碟機、UNC 路徑或 URL (網址) 開啟檔案時,就會發生此問題。

原因

發生此問題的原因是 Office 產品中存在建立和儲存檔案的字元限制。 如果您開啟或儲存的檔案路徑符合下列條件,就會發生此問題:

  • Microsoft Word、Microsoft PowerPoint 和 Microsoft Access:路徑和檔案名稱的總長度,包括副檔名,超過 259 個字元。

  • Microsoft Excel:路徑和檔案名稱的總長度,包括副檔名,超過 218 個字元。

注意

此限制包含代表磁碟機的三個字元、資料夾名稱中的字元、資料夾名稱之間的反斜線字元,以及檔案名稱本身中的字元。

因應措施

若要解決這個問題,請嘗試下列任一因應措施。

因應措施 1:減少字元數目

  • 重新命名檔案,使其名稱較短。
  • 重新命名包含檔案的一或多個資料夾,使其名稱較短。
  • 將檔案移至路徑名稱較短的資料夾。

因應措施 2:手動存取、開啟和修復

  1. 啟動 Word、Excel 或 PowerPoint。

  2. 在 [檔案] 索引標籤上,選取 [開啟]> [瀏覽] 以找出損毀的檔案。

    開啟對話方塊的螢幕擷取畫面。

  3. 選取檔案,選取視窗底部的 [開啟] 功能表,然後選取 [開啟並修復]

    [開啟並修復] 選項的螢幕擷取畫面。

此選項會修復檔案的損壞,然後開啟檔案。 修復檔、活頁簿或簡報之後,請務必確認問題已成功解決。 若要這樣做,請開始處理檔案,並確保一切都如預期般運作。

因應措施 3:變更檔案格式並重新儲存

您可以使用不同的檔案格式將損毀的檔案還原,然後還原成原始格式,以此修復損毀的檔案。 此範例使用了 Word。

步驟 1:將檔案儲存為另一種格式

  1. 啟動 Word。

  2. 在 [檔案] 功能表上,選取 [開啟],然後找出並開啟損毀的檔案。

  3. 在 [檔案] 功能表中,選取 [另存新檔]> [瀏覽]

  4. 導覽至您要儲存的檔案位置。

  5. 在 [另存新檔類型]清單中選取所需檔案格式。 例如,選 取 [RTF 格式 (*rtf)]

    [另存新檔] 選項的螢幕擷取畫面。

  6. 選取 [儲存],然後選取 [檔案]> [關閉]

步驟 2:將檔案重新儲存為 Word 文件

  1. 請選取檔案>開啟

  2. 選取儲存為 RTF 檔案的新檔案,然後選取 [ 開啟]。

  3. 選取檔案>另存新檔

  4. 在 [另存新檔類型] 清單中,選取 [Word 文件]

  5. 重新命名檔案,然後選取 [儲存]

    [儲存副本] 選項的螢幕擷取畫面。

您只需要執行此動作一次,以確保文件現在可在您的裝置上正常運作。 不過,請記住,藉由將檔案儲存為新檔,您會建立不同的檔案。 若要避免混淆,請將新檔案命名為特別的名稱,並封存或刪除損毀的版本。 如此一來,您就不會不小心重新開啟尚未重新格式化的源檔。

因應措施 4:開啟無法辨識的檔案格式

如果您可以排除檔案損毀原因,請檢查檔案關聯和無法辨識的檔案格式。 有時候,您的裝置上不會開啟檔案,因為該檔案是在裝置沒有的已使用軟體上建立的裝置。

例如,在 Word 中,您想要檢視附加至電子郵件訊息的 PDF 檔案。 不過,您尚未安裝 PDF 檢視器。 因此,您的裝置不知道要開啟哪些程式來檢視檔案。 在此情況下,您可以變更檔案格式,以符合您已安裝的程式。

  1. 附件將儲存在您的電腦。 若要這樣做,請選取訊息中附件旁邊的向下箭號,選取 [另存新檔],導覽至所需的位置,然後選取 [儲存]

  2. 在 [檔案] 功能表上,選取 [開啟]> [瀏覽],找到該檔案。

  3. 以滑鼠右鍵按一下檔案,指向 [開啟],然後選取不同的程式來開啟檔案。

  4. 如果所需的程式不在清單中,請選取 [選擇其他應用程式] 以找出不同的程式。

    注意

    若此舉可行,而且您希望選取一律以該程式開啟這種類型的檔案,請選取 [一律使用此應用程式開啟 .docx 檔案] (例如) 核取方塊。 [一律使用此應用程式開啟 .docx 檔案] 核取方塊的螢幕擷取畫面。

如需檔案格式及其管理方法的詳細資訊,請參閱 瞭解檔案格式

因應措施 5:清除部分磁碟空間

如果您在硬碟上用盡空間,可能無法開啟新的檔案或將檔案儲存到裝置。 在整個磁碟上,暫存資料、重複資料和不必要的項目會用盡大部分的空間。 在硬碟上釋放空間最快的最簡單方法是使用 Windows 中包含的磁碟清除應用程式。

  1. 選取 [搜尋],然後輸入 [磁碟清理]

  2. 在結果清單中,選取 [磁碟清理]

    磁碟清理的螢幕擷取畫面。

  3. 對話方塊隨即開啟,並提供刪除不必要檔案的選項。 選取您要從裝置中刪除之每個項目類別旁邊的核取方塊,然後選取 [確定]。 此清單中的所有項目都可以安全地刪除。

    本機磁碟 (C:) 的磁碟清理螢幕擷取畫面。

  4. 當系統提示您時,請確認您想要永久刪除不必要的檔案。

    [刪除檔案] 選項的螢幕擷取畫面。

下列檔案類型是您可能會在 [磁碟清理] 清單中看到的可卸除項目範例:

  • Windows Update:從 Windows Update 下載的最新檔案 (選擇這些檔案不會刪除目前安裝的更新版本)
  • 下載的程式檔:不必要的程式檔,通常與程式安裝相關
  • 暫存網際網路檔案:當您瀏覽網站時,網頁瀏覽器會自動儲存的檔案
  • Windows 錯誤報告:系統所建立的錯誤報告檔案
  • 資源回收筒:您尚未手動刪除的儲存在資源回收筒中的所有檔案
  • 暫存檔案:程式或網頁瀏覽器所建立的其他暫存檔案
  • 使用者檔案歷程記錄:記錄瀏覽歷程記錄的檔案 (您存取的網站、搜尋結果等等)

其他相關資訊

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