開啟檔案或傳送郵件時,Outlook 無回應錯誤或 Outlook 凍結

原始 KB 編號:2652320

徵狀

在 Microsoft Outlook 2010 或更新版本中開啟檔案或傳送電子郵件訊息時,Outlook 會凍結,或收到下列錯誤訊息:

Outlook 無回應

原因

這個問題可能是由下列一個或多個原因所造成:

  • 尚未安裝最新更新。
  • 其他程序正在使用 Outlook。
  • Outlook 正在載入外部內容,例如電子郵件訊息中的影像。
  • 先前安裝的增益集與 Outlook 衝突。
  • 您的信箱太大。
  • 您的 AppData 資料夾會重新導向至網路位置。
  • 請嘗試修復您的 Office 程式。
  • Outlook 資料檔案遭到損毀或損壞。
  • 您安裝的防毒軟體已過期,或與 Outlook 發生衝突。
  • 您的使用者設定檔遭到損毀。
  • 其他程式與 Outlook 衝突。

注意事項

  • 這個問題可能是由下列一或多個本節中的原因造成: 若要修正此問題,您可能需要依照解決方案一節中的步驟進行。
  • 許多項目都可以由 Microsoft 支援及修復小幫手 (SaRA) 自動檢查。 若要啟動自動檢查,請依照下列步驟執行:
    1. 安裝 Outlook 進階診斷工具。
    2. 當瀏覽器提示您時,請按一下 [執行]
    3. 在產生的報告中,請檢查 [找到的問題] 索引標籤上的項目。如需關於 Outlook、Windows 和電腦的設定詳細資料,請檢查 [詳細檢視]索引標籤上的設定。

解決方案

若要解決此問題,請確定您的電腦符合 Outlook 2016 系統需求Outlook 2013 系統需求Outlook 2010 系統需求

注意事項

根據通用性和複雜性,以特定順序提供這些步驟。 請依照指定順序執行這些步驟。

步驟 1 - 安裝最新的更新

電腦上的 Office 安裝可能不是最新版本。 這可能是因為您的電腦上未設定 Windows 更新,因此會自動下載並安裝建議的更新。 安裝重要、建議和選用的更新,可以取代過期的檔案並修正漏洞,藉此經常修正問題。 若要安裝最新的 Office 更新,請按一下您 Windows 版本的連結,然後遵循下列文章中的步驟:

請確定已安裝最新的 Outlook 更新。 如需詳細資訊,請參閱如何為 Microsoft Outlook 安裝最新的適用更新 (僅提供美式英文)

步驟 2 - 確定其他程序未使用 Outlook

如果您使用 Outlook 自動封存功能或與行動裝置同步處理 Outlook,則可能會降低效能。 這是因為這些程序可能會佔用大量的資源。

如果另一個程序正在使用 Outlook,這項資訊會顯示在螢幕底部的狀態列中。 如果您嘗試在使用 Outlook 時執行其他動作,Outlook 可能不會回應。 請讓正在進行的工作完成其作業,再嘗試另一個動作。

步驟 3 - 檢查外部內容所造成的問題

若要解決此問題,請使用下列其中一個方法:

  • 禁止 Outlook 下載外部內容。 若要執行此動作,請移至 [檔案選項] [ >>信任中心] [ >自動下載],選取下列兩個選項:
    • 不要在 HTML 電子郵件選項中自動下載圖片或其他內容。
    • 編輯、轉寄或回復電子郵件時,在下載內容之前提醒我。
  • 避免傳送這樣的電子郵件與外部來源。

步驟 4-調查可能的增益集問題

雖然增益集可以增強您的使用者體驗,但有時會干擾或與 Outlook 衝突。 嘗試開始 Outlook,但沒有任何增益集正在執行。

如何開始沒有增益集的 Outlook

  1. 請依照您的情況執行下列動作:
    • 如果在 Windows 8 中,請從螢幕右側邊緣向中央滑動,然後點選 [搜尋]。 (如果您是使用滑鼠,請指向螢幕右上角並將滑鼠游標往下移,然後選取 [搜尋]),在搜尋框中輸入 Run,然後點一下或選取[執行]
    • 如果您執行的是 Windows 10、Windows 7 或 Windows Vista,,請選取[開始]
    • 如果在 Windows XP 中,請選取 [開始],然後 [執行]
  2. 輸入 [Outlook.exe /safe],然後選取 [確定]
  3. 若已修正問題,請選取 [檔案]功能表上的 [選項],然後選取 [增益集]
  4. 選取「COM 增益集」,然後選取「執行」
  5. 清除清單中的所有核取方塊,然後按一下 [確定]
  6. 重新啟動 Outlook。

如果重新開機 Outlook 後沒有發生問題,其中一個增益集可能是問題的原因。 一次還原一個增益集,直到發生問題為止,以判斷哪個增益集導致問題。

步驟 5-檢查您的信箱是否太大

當您的信箱大小增加時,開啟每一個資料夾需要更多的資源。 如果您有多個單一資料夾中的專案,則在某些作業期間可能會出現效能問題。 如需詳細資訊,請參閱快取模式 .ost 或 .pst 檔案中的項目或資料夾過多時的 Outlook 效能問題

建議您將較大的資料夾中的數個專案移至不同的資料夾,或是使用自動封存功能封存這些專案。

如何建立資料夾

  1. 「檔案」索引標籤上,選取「新群組」中的「新資料夾」

  2. 在 [名稱框],輸入公告的名稱。

  3. 在 [ 選取放置資料夾的位置 ] 清單中,選取新資料夾的位置。

    注意事項

    新的資料夾將會變成您所選取之資料夾的子資料夾。

  4. 選取 [確定]

若要減少 Outlook 資料檔的大小,以管理您的信箱,請參閱減少 Outlook 資料檔案的大小 (.pst 及 .ost)

若要使用自動封存功能來管理信箱,請參閱 自動封存設定說明

步驟 6-檢查您的 AppData 資料夾是否重新導向至網路位置

Outlook 會將特定資料(例如電子郵件簽名及拼寫檢查字典)儲存在 AppData 資料夾中。 如果網路執行緩慢,Outlook 必須等待 AppData 目錄的讀取和寫入作業完成。

如何停用 AppData 目錄的重新導向

  1. 結束 Outlook。

  2. 啟動 [登錄編輯程式]。 若要執行這項操作,請根據您的 Windows 版本使用下列其中一個方法:

    • Windows 8 或 Windows 10:按 Windows 鍵+R,開啟 [執行] 對話方塊。 輸入 regedit.exe,然後按 [確定]。
    • Windows 7:選取 [開始],在搜尋方塊中輸入 regedit.exe,然後按下 Enter。
  3. 在 [登錄編輯程式] 中,找出並選取下列子機碼:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

  4. 請找出並按兩下 AppData 的值:

  5. [數值資料]框中,輸入以下路徑,然後選取 [確定]:
    %USERPROFILE%\AppData\Roaming

    可以輸入數值資料之 [編輯字串] 對話方塊的螢幕擷取畫面。

  6. 結束 [登錄編輯程式]。

步驟 7 - 修復 Office 程式

您可以自動修復 Office 的程式檔案,以解決 Outlook 凍結或沒有回應等問題。

如何自動修復 Office

  1. 結束所有執行中的 Microsoft Office 程式。
  2. 開啟 [控制台],然後開啟 [新增或移除程式] 項目 (如果您使用的是 Windows XP) 或 [程式和功能] (如果您使用的是 Windows 10、Windows 8、Windows 7 或 Windows Vista)。
  3. 在已安裝程式的清單中,以滑鼠右鍵按一下 [Microsoft Office 2016], [Microsoft Office 2013] 或 [Microsoft Office 2010],然後選取 [修復]

步驟 8 - 修復 Outlook 資料檔案

安裝 Outlook 時,也會在您的電腦上安裝收件匣修復工具 (scanpst.exe)。 收件匣修復工具可以掃描 Outlook 資料檔案,並修復錯誤,以解決問題。 若要使用收件匣修復工具,請結束 Outlook,然後依照修復 Outlook 資料檔案 (.pst 及 .ost) 中的步驟進行。

步驟 9 - 檢查防毒軟體是否為最新版本,或是否與 Outlook 衝突

如果防毒軟體不是最新的,Outlook 可能無法正常運作。

如何檢查防毒軟體是否為最新版本

為了跟上最新的病毒,防毒軟體廠商會定期更新版本。您可以在網際網路下載這些更新檔案。 請造訪防毒軟體廠商的網站下載最新的更新。

如需防毒軟體廠商的清單,請參閱 Windows 消費者防毒軟體提供者

如何檢查防毒軟體是否與 Outlook 衝突

若防毒軟體內有 Outlook 整合,則可能會遇到效能問題。 您可以在防毒軟體中停用所有 Outlook 整合。 或者,您可以停用 Outlook 中安裝的任何防毒軟體增益集。

重要事項

變更防毒軟體設定可能會使您的電腦容易遭受病毒、詐騙或惡意攻擊。 我們不建議您嘗試變更防毒設定。 採用此因應措施需自行承擔風險。

您可能需要連絡防毒軟體廠商,以便確定如何設定軟體以排除任何 Outlook 的整合或排除 Outlook 中的掃描。

注意事項

如果您也想要在使用 Outlook 時,執行離線通訊錄 (.oab) 或其他 Outlook 檔案的檔案層級病毒掃描,請參閱規劃 Outlook 2010 的防毒掃描,或部署 Windows 的 Outlook 2016 之規劃考慮

步驟 10 - 在 Outlook 中建立使用者設定檔

要建立使用者設定檔,請依照下列步驟執行:

  1. 在 [控制台] 中,選取 [程式],選取 [使用者帳戶],然後選取 [郵件] 以開啟 [郵件項目]。

  2. 選取 [顯示設定檔]

  3. 選取您想要移除設定檔,再按一下 [移除]

  4. 選取 新增

  5. 在 [設定檔名稱] 對話方塊中輸入設定檔的新名稱。

  6. 指定使用者名稱、主 SMTP 位址及密碼。 然後,選取 [下一步]

  7. 您可能會收到下列提示:
    允許此網站設定 <alias@domain server> 設定值嗎?

    在此提示中選取 [不要再詢問我此問題] 核取方塊,然後按一下 [允許]

步驟 11 - 執行選擇性啟動 (進階使用者)

正常啟動 Windows 時,系統會自動啟動一些應用程式和服務,並其在背景中執行。 這些應用程式和服務可能會與 Outlook 衝突。 選擇性啟動或「初始狀態開機」流程可協助您識別應用程式衝突所造成的問題。

如果您在 [系統設定] 中使用 [選擇性啟動] 選項,您可以單獨開啟或關閉 [服務] 和 [啟動程式],檢查下一次啟動電腦時是否發生該問題。 在 [系統設定] 中,如果您選取了核取方塊,則會在您重新啟動電腦時執行相關的服務或啟動程式。 如果清除此核取方塊,則當您重新啟動電腦時,不會執行服務或啟動程式。

請依循此程序,以使用消去法流程識別 Windows 10、Windows 8、Windows 7 或 Windows Vista 中的問題。

注意事項

如需有關執行初始狀態開機的詳細資訊,請參閱如何在 Windows 中執行初始狀態開機

如何執行選擇性啟動

  1. 在 [控制台] 中,選取 [系統及安全性],選取 [系統管理工具],然後按兩下 [系統設定]

    注意事項

    如果出現要求您輸入系統管理員密碼或確認的提示,請輸入密碼或提供確認。

  2. 選取 [一般] 索引標籤,再選取 [選擇啟動項目],然後清除 [載入系統服務] 和 [載入啟動項目]的核取方塊。

  3. 選取 [載入系統服務] 核取方塊,選取 [確定],然後再選取 [重新啟動]

  4. 如果重新啟動電腦後問題再次出現,請視需要執行下列其中一或兩項任務。

    確定造成問題的系統服務

    1. 在 [系統設定] 中,選取 [服務]索引標籤,再選取 [全部停用],接著選取列於首位服務的核取方塊,然後重新啟動電腦。

      注意事項

      如果問題不再出現,可以將第一個服務當作問題的原因而消除。

    2. 選取第一個服務後,再選取第二個服務的核取方塊,然後重新啟動電腦。

    3. 重複此過程,直到重現問題為止。

      注意事項

      如果無法重現問題,可以將系統服務當作問題的原因而消除。

    決定導致問題的啟動項目

    1. 在「系統設定」中,選取一般索引標籤,然後選取載入啟動項目核取方塊。

    2. 選取啟動索引標籤,再選取 [ 全部停用,接著選取列於首位的啟動項目核取方塊,然後重新啟動電腦。

      注意事項

      如果問題不再出現,可以將第一個啟動項目'當作問題的原因而消除。

    3. 選取第一個啟動項目後,請再選取第二個啟動項目核取方塊,然後重新啟動電腦。 重複此過程,直到重現問題為止。

步驟 12 - 建立 Windows 使用者設定檔(進階使用者)

使用者設定檔是設定的集合,可讓您自訂電腦的外觀和效能。 它包含桌面背景、螢幕保護裝置、音效設定及其他功能的設定。 使用者設定檔可協助確保您登入 Windows 時使用您的個人喜好設定。

若要判斷問題是否是由損毀的使用者設定檔所引起,請建立使用者設定檔,以查看當您使用新的設定檔時,是否仍會發生問題。

如何修正損毀的使用者設定檔 (Windows 8)

步驟 1:建立使用者帳戶

若要建立使用者設定檔,您必須先建立使用者帳戶。 建立新帳戶時,也會建立設定檔。

  1. 從螢幕右邊邊緣向內撥動,然後點選 [搜尋]。 (如果使用滑鼠,請指向螢幕的右上角,將滑鼠指標移向下,然後選取搜尋。)輸入 命令提示字元在搜尋方塊中,滑鼠右鍵按一下 命令提示字元,然後選取以系統管理員身分執行

    注意事項

    如果出現要求您鍵入系統管理員密碼或確認的提示,請鍵入密碼或提供確認。

  2. 輸入 net user UsernamePassword/add,然後按下 Enter。

步驟 2 - 將舊檔案複製到新的使用者設定檔** 建立設定檔之後,可以從現有的設定檔中複製檔案

注意事項

必須在電腦上至少有三個使用者帳戶,才可完成這些步驟。 這包括剛才建立的新帳戶。

  1. 以剛建立的使用者以外的使用者身分登入,或是想要從中複製檔案的使用者。

  2. 在「控制台」中,選取外觀與個人化,然後選取資料夾選項

  3. 選取檢視索引標籤,然後選取顯示隱藏的檔案、資料夾和磁碟機

  4. 清除隱藏受保護的作業系統檔案核取方塊,選取 以確認,然後選取 確定

  5. 開啟檔案總管。 要完成此作業,請從螢幕右邊邊緣向內撥動,然後點選 搜尋。 (如果使用滑鼠,請指向螢幕的右上角,將滑鼠指標移向下,然後選取 搜尋。) 在搜尋方塊中輸入 檔案總管 ,請點選或選取 應用程式,然後點選或選取 檔案總管。 在搜尋方塊中輸入「命令提示字元」,在「命令提示字元」上按右鍵,然後按一下 以系統管理員身分執行

  6. 找到 C:\Users\ Old_Username 資料夾,其中C是安裝 Windows 的磁碟機,而Old_Username是要從中複製檔案的設定檔名稱。

  7. 選取此資料夾中的所有檔案和資料夾,但下列檔案除外:

    • Ntuser.dat
    • Ntuser.dat.log
    • Ntuser.ini
  8. 編輯功能表上,選取複製

    注意事項

    如果看不到編輯功能表,請按下 Alt。

  9. 找出 C:\Users\ New_Username 資料夾,其中C是安裝 Windows 的磁碟機,而New_Username是先前在此方法中建立的使用者設定檔名稱。

  10. 編輯功能表上,選取貼上

  11. 先登出,再以新使用者登入電腦。

注意事項

如果有電子郵件程式中的電子郵件訊息,必須先將電子郵件和位址匯入新的使用者設定檔,再刪除舊的設定檔。 如果一切運作正常,則現在可以刪除舊的設定檔。

下一步

如果本文中的資訊無法協助您解決使用 Outlook 2016、Outlook 2013 或 Outlook 2010 的問題,請參閱下列資源以取得詳細資訊:

參考