同步處理問題發生在 Outlook 和 Outlook Web App

徵狀

當同步處理問題發生在 Microsoft Outlook 或 Microsoft Outlook Web App (先前 Outlook Web 存取) 時,您可能會遇到下列徵兆。

  • 徵兆 1

    相較于 Microsoft Outlook Web App,您會在 Microsoft Outlook 中看到訊息之間的差異或不相符。

  • 徵兆 2

    您遇到 Outlook 的問題,但停用快取模式時不會發生問題。

  • 徵兆 3

    當您將離線資料夾檔案 (.ost) 與執行 Microsoft Exchange Server 之伺服器上的信箱同步處理 Outlook 時,有時候會收到錯誤訊息。 錯誤訊息可能類似於以下內容:

    無法啟動 Microsoft Outlook。 無法開啟 Outlook 視窗。 無法開啟這組資料夾。 檔案 c:\Users\<username>\AppData\Local\Microsoft\Outlook<username@domain.com.ost> 不是 outlook 數據檔, (ost) 。

  • 徵兆 4

    您注意到在同步處理 .ost 檔案和信箱之後,.ost 檔案或信箱中遺漏某些項目,例如電子郵件訊息、約會、連絡人、工作、記錄項目、附注、張貼的項目和文件。

原因

當這些徵兆發生,或您有其他問題正在同步處理時,問題可能是由損毀的 .ost 檔案引起。

解決方案

針對 Outlook 2003 和 Outlook 2007:

使用 OST 完整性檢查工具 (Scanost.exe) 來檢查您的 .ost 檔案是否不一致。

若為 Outlook 2010 和更新版本:

OST 完整性檢查工具 (scanost.exe) 不包含在 Outlook 2010 及更新版本中。 在舊版中建議使用此工具來修正 Outlook 資料檔案 (.ost) 中的錯誤。 如果特定資料夾發生問題,您可以重新同步處理 Outlook 中的資料夾。 如果要執行這項操作,請依照下列步驟執行:

  1. 用滑鼠右鍵按一下資料夾,然後按一下 [屬性]
  2. 請選取 [清理離線項目],然後按一下 [確定]
  3. 在 [Outlook 2010] 功能區上,選取 [傳送/接收] 索引標籤。
  4. 選取 [更新資料夾]

如果這些方法無法解決問題,建議您重建 .ost 檔案。 為此,請刪除 .ost 檔案,然後讓 Outlook 從 Exchange Server 下載資訊。 如需詳細資訊,請參閱本文的「詳細資訊」一節。

但是也有當您的本機資料不存在於伺服器上的例外情況。 在此情況下,建議您遵循下列步驟:

  1. 將資料匯出至 Outlook Data File (.pst) ,然後刪除 .ost 檔案。
  2. 讓伺服器資料再次下載,然後使用 [不要匯入重複項目] 選項匯入 .pst 檔案資料。 若要存取此選項,請選取 [檔案] 索引標籤,然後選取 [開啟] 選項。

其他資訊

OST 完整性檢查工具只會在 .ost 檔案上執行,並可用來診斷和修復同步處理問題。 它會掃描 .ost 檔案的本機複本,以及 Exchange Server 上的信箱。 此工具會比較檔案和信箱中的項目和資料夾,並嘗試協調檔案與信箱之間的同步處理差異。 OST 完整性檢查工具不會變更您在 Exchange Server 上的信箱。 此工具會記錄掃描記錄檔中的任何差異,讓您可以查看工具找到並解決的差異。 掃描記錄也會識別工具無法解決且您必須手動修正的任何情況。 掃描記錄檔位於 [已刪除的項目] 資料夾中。

當您在下列位置安裝 Outlook 時,會安裝 OST 完整性檢查工具 (Scanost.exe) ,適用于您執行的 Outlook版本。

針對 Outlook 2003: 磁碟驅動器:\Program Files\Common Files\System\MSMAPI\LocaleID 資料夾。 請注意,在此範例中,LocaleID 是安裝 Microsoft Office (LCID) 的地區設定識別碼。 英文版 LCID - 美國為 1033。

針對 Outlook 2007:drive:\Program Files\Microsoft Office\OFFICE12

如何使用 Scanost.exe 修復錯誤

  1. 若 Outlook 2003 或 Outlook 2007 正在執行,請結束。

  2. 按兩下 [Scanost.exe]

  3. 如果您已設定 Outlook 提示您輸入設定檔,此工具也會提示您輸入設定檔。 在 [設定檔名稱] 清單中,選取包含您要檢查之 .ost 檔案的設定檔。 如果系統提示您連線離線工作,請選取 [連線]

  4. 選取您想要的選項。 若要讓工具自動解決掃描期間所找到的差異,請選取 [修復錯誤] 核取方塊。 如果清除此核取方塊,工具會記錄問題。 不過,此工具不會進行必要的修正。

  5. 選取 [開始掃描]

注意事項

若要檢視掃描記錄檔,請啟動 Outlook,然後開啟 [刪除的項目] 資料夾。 此工具不會掃描 [刪除的項目] 資料夾。 任何問題都會在以「OST 完整性檢查」做為其主旨的訊息中記下。

如果您在嘗試開啟 .ost 檔案時遇到問題,您可以使用收件匣修復工具 (Scanpst.exe) 來診斷和修復 .ost 檔案中的錯誤。 收件匣修復工具可用於 .ost 檔案和個人資料夾 (.pst) 檔案。 收件匣修復工具會掃描 .ost 或 .pst 檔案,並確定檔案結構完整。 必要時,此工具也會嘗試修復內部資料結構。 此工具不會在 Exchange Server 上與您的信箱互動。

如何重建 .ost 檔

  1. 依據您執行的系統,找出下列資料夾:

    Windows XP:C:\Documents and Settings\<alias>\Local Settings\Application Data\Microsoft\Outlook
    Windows Vista 和更新版本:C:\Users\<alias>\AppData\Local\Microsoft\Outlook

  2. 如果未顯示資料夾,請取消隱藏資料夾。 如果要執行這項操作,請依照下列步驟執行:

    Windows 8 和 Windows 10:

    在 [檢視]索引標籤上,選取 [隱藏專案] 核取方塊和 [副檔名] 核取方塊。

    Windows 7:

    • 在 [組織] 功能表上,選取 [資料夾和搜尋] 選項。
    • 選取 [檢視] 索引標籤,然後選取 [顯示隱藏的檔案、資料夾和磁碟機] 選項,然後清除 [隱藏已知檔案類型的副檔名] 核取方塊。

    Windows XP:

    • 在 [工具] 功能表上,選取 [資料夾選項]
    • 選取 [檢視] 索引標籤,然後選取 [顯示隱藏的檔案和資料夾] 核取方塊,然後清除 [隱藏已知檔案類型的副檔名] 核取方塊。
  3. 預設情況下,Outlook 會為使用者的本機快取建立 Outlook.ost。 如果 Outlook.ost 檔案已經存在,Outlook 會在檔案名結尾插入數位 (例如 Outlook0.ost 或 Outlook1.ost) 。 重新命名每一個 .ost 檔案。 為此,請將 .ost 副檔名重新命名為 .old。 如果未顯示 .ost 副檔名,請務必如步驟 2A 和 2B 中所述,清除 [隱藏已知檔案類型的副檔名] 核取方塊。

  4. 如果您收到「檔案正在使用中」錯誤訊息,請按 CTRL+ALT+DELETE,然後選取 [工作管理員]。 選取 [處理程序] 索引標籤,並確認 Outlook.exe 和 Winword.exe 未顯示在處理程序清單中。 如果這些處理程序出現在清單中,請選取每個檔案,然後選取 [結束處理程序]

  5. 重新命名 .ost 檔案之後,請重新啟動 Outlook。 您會收到「準備第一次使用」訊息。 請稍候信箱進行同步。 視使用者的信箱大小而定,此過程會有所不同。

  6. 同步處理信箱之後,請進行測試以查看問題是否仍存在。 如果問題仍然存在,則表示 .ost 檔案不是問題的原因。

如需因不同問題所造成的類似錯誤,請參閱 如果 legacyExchangeDN 中的最後一個字元是空格,則會在狀態列中顯示 Outlook 中斷連線