本文說明當您想要建立數據流時,可能會遇到的一些最常見的錯誤和問題,以及如何修正它們。
我無法在我的工作區中建立數據流
當您嘗試在Power BI中建立 [我的工作區] 數據流時,就會發生此問題。
原因:
不支援在 [我的工作區] 中建立數據流。
解決方式:
在 組織工作區中建立資料流。 若要瞭解如何建立組織工作區,請移至 在 Power BI 中建立新的工作區。
我無法在具有唯讀許可權的組織工作區中建立數據流
如果您是組織工作區的成員,但仍無法建立數據流,可能是因為該工作區中的訪問許可權。
原因:
您沒有工作區中的編輯許可權。
解決方式:
要求工作空間管理員或成員將您設為管理員、成員或貢獻者 角色。
我無法在擁有編輯許可權的工作區中建立數據流
這個問題發生在由你或其他人建立的組織工作空間中,且你擁有管理員、成員或貢獻者的權限時。 您想要在此案例中建立數據流,但無法。
原因:
Power BI 系統管理員已停用數據流建立的存取權。
解決方式:
請遵循下列步驟,要求 Power BI 租用戶系統管理員為您啟用存取權:
在 Power BI 服務的 [設定] 功能表上,選取 [管理入口網站]。
在左窗格中,選取 [租戶設定],然後在 [數據流設定] 區段中,啟用 [已啟用 ]的切換。 然後選取 套用。
當我建立數據流時,我只會看到有限的選項
建立數據流時,有時候您看不到所有可用的選項。 例如,您可能只會看到下圖中顯示的選項。
不過,實際可以使用更多選項,如下圖所示。
原因:
您要在舊版 Power BI 工作區中建立數據流,稱為 V1。
解決方式:
將 Power BI 工作區升級至新版本 (v2)。 欲了解更多資訊,請參考 Power BI 中的「將經典工作區升級至新工作區」。
數據流名稱已經存在,但我刪除了舊的數據流名稱
當您嘗試建立已存在名稱的數據流,或使用最近刪除數據流的名稱時,就會發生此問題。
原因:
後端系統最多可能需要 48 小時的時間,才能刪除所有檔案和已刪除資料流的參考。
解決方式:
您可以在發佈數據流之前等候 48 小時,或立即以不同的名稱建立數據流,並在稍後重新命名。
啟用 Private Link 時,我無法發佈數據流
當您嘗試在一個具有指定容量的工作區中發佈資料流程,但該容量與連接器依賴的虛擬網路資料閘道器不在同一區域,且已啟用私有連結並阻止公共存取時,這個問題就會發生。
原因:
資料流無法完成發佈流程,因為它無法連接到資料來源。
解決方式:
在與您的虛擬網路資料閘道位於相同區域且分配有容量的工作區內建立資料流,或如果您想發佈至其他區域,則在該區域建立新的虛擬網路資料閘道。