本文提供當您啟動 Outlook Microsoft Dynamics CRM 用戶端時可能發生之問題的解決方案。
適用於: Microsoft Office Outlook 的 Microsoft CRM 用戶端
原始 KB 編號: 911384
徵兆
徵兆 1
當您開啟 Microsoft Office Outlook Microsoft Dynamics CRM 用戶端時,您會收到下列錯誤訊息:
載入 MICROSOFT CRM 功能時發生錯誤,請嘗試重新啟動 Outlook。
在事件記錄檔中,會記錄類似下列的錯誤訊息。
錯誤訊息 1
找不到來源 (Microsoft CRM) 中事件識別碼 (2) 的描述。 本機電腦可能缺少從遠端電腦顯示訊息所需的登錄檔案或訊息 DLL 檔案。 您可以使用 /AUXSOURCE= 旗標來擷取此描述;如需詳細資訊,請參閱說明及支援。
下列資訊是事件的一部分。 MSCRM 平台錯誤報告:
錯誤:HRESULT 的例外狀況:0x80040220。 錯誤訊息:HRESULT 的例外狀況:0x80040220。 錯誤詳細數據:平臺尚未提供此錯誤的詳細數據。 來源檔案:無法使用行號:在 System.Web.UI.Page.HandleError(例外狀況 e) 於 System.Web.UI.Page.ProcessRequestMain() 於 System.Web.UI.Page.ProcessRequest() at System.Web.UI.Page.ProcessRequest() System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() 的 System.Web.ProcessRequest(HttpContext 內容) 在 System.Web.HttpApplication.ExecuteStep(IExecutionStep 步驟, Boolean& completedSynchronously)。
錯誤訊息 2
找不到 Source (MSCRMAddin) 中事件識別碼 (16930) 的描述。 本機電腦可能缺少從遠端電腦顯示訊息所需的登錄檔案或訊息 DLL 檔案。 您可以使用 /AUXSOURCE= 旗標來擷取此描述;如需詳細資訊,請參閱說明及支援。 下列資訊是事件的一部分:80004005、、CAddin::HrActivateAddin、472。
錯誤訊息 3
找不到 Source (MSCRMAddin) 中事件識別碼 (5944) 的描述。 本機電腦可能缺少從遠端電腦顯示訊息所需的登錄檔案或訊息 DLL 檔案。 您可以使用 /AUXSOURCE= 旗標來擷取此描述;如需詳細資訊,請參閱說明及支援。 下列資訊是事件的一部分:80004005、、CAddin::HrInitializeUI、137。
徵兆 2
當您搭配使用 Windows Vista 搭配適用於 Outlook 的 Microsoft Dynamics CRM,以及啟用平台追蹤時,您會收到類似下列的錯誤訊息:
用戶端設定:[錯誤] COM 登錄機碼似乎已損毀。 重新執行CRM設定精靈,或連絡您的 Microsoft Dynamics CRM 系統管理員。 >--- System.TypeLoadException:檢索 CLSID {<ID>} 元件的 COM 類別工廠失敗,因為發生下列錯誤:80131522。 在
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) at
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) at
System.Activator.CreateInstance(Type type, Boolean nonPublic) at
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker)---內部例外狀況堆棧追蹤---結束
Microsoft.Crm.Outlook.Diagnostics.ComponentObjectModelDiagnosticCheck.Execute(BackgroundWorker backgroundWorker) at Microsoft.Crm.Outlook.Diagnostics.DiagnosticCheck.DeepExecute(BackgroundWorker backgroundWorker)
徵兆 3
當您嘗試執行 Outlook Microsoft Dynamics CRM 用戶端時,您無法檢視 dynamics CRM 資料夾結構Microsoft。 此外,您收到下列錯誤訊息:
載入 MICROSOFT CRM 功能時發生錯誤,請嘗試重新啟動 Outlook。
下列錯誤訊息會記錄在事件記錄檔中:
事件類型:錯誤 事件來源:MSCRMAddin 事件類別:無 事件 ID:16930 日期:日期 時間:時間 使用者:N/A 電腦:ComputerName 描述:Microsoft CRM UI 初始化失敗。 請嘗試重新啟動 outlook Microsoft。 HR=0x80004005。 Context=。 Function=CAddin::HrActivateAddin。 Line=521。 此外,您會在追蹤記錄檔OUTLOOK-YYDDMM.log收到下列錯誤訊息:[日期和時間] 進程: OUTLOOK |Thread:0832 |類別:Unmanaged.Platform |使用者:PlatformUser |層級:錯誤 |HrGetXmlDOM 檔案:c:\bt\643\src\application\outlook\v3caddin\xmlutil.cpp 行: 179 >hr = 0x80004005
注意
在此錯誤訊息中,日期和時間佔位符代表實際日期和時間。 例如,實際日期和時間可以是 “2007-10-19 17:53:26.138”。
徵兆 4
當您啟動適用於 Outlook 的 Dynamics CRM 用戶端Microsoft時,您會收到下列錯誤訊息:
載入 MICROSOFT CRM 功能時發生錯誤,請嘗試重新啟動 Outlook。 此外,錯誤事件 80072f19 在應用程式記錄檔中被參考:事件:16941 在初始化初始化進度工具列時出現問題。 重新啟動 Microsoft CRM,然後再試一次。 HR=0x80072f19。 Context=。 Function=CAddin::HrActivateAddin。 第322行。
徵兆 5
當您嘗試在已安裝 Microsoft Dynamics CRM 用戶端的計算機上安裝 Microsoft Office Outlook 時,您會收到下列錯誤訊息:
Microsoft Dynamics CRM 功能載入時發生錯誤。
請嘗試重新啟動 outlook Microsoft。
如果錯誤持續發生,請連絡系統管理員。
此外,下列錯誤訊息會記錄在應用程式事件記錄檔中:
事件類型:錯誤
事件來源:MSCRMAddin
事件類別:無
事件標識碼:16931
描述:Microsoft CRM COM Interop 初始化時發生問題。 重新啟動 Microsoft CRM,然後再試一次。 HR=0x80131700。 Context=。 Function=CAddin::HrActivateAddin。 Line=274。
事件類型:錯誤
事件來源:MSCRMAddin
事件類別:無
事件標識碼:5903
描述:Microsoft CRM Outlook 外掛程式無法正確初始化。 重新啟動Microsoft Outlook,然後再試一次。 HR=0x80070057。 Context=。 Function=CAddin::OnConnection。 Line=196。
原因
原因 1
發生此問題的原因是指派給用戶帳戶的角色沒有 Microsoft Dynamics CRM 中已儲存檢視實體的讀取許可權。 請參閱決議案 1。
原因 2
禁用資料夾首頁設定是透過群組原則啟用。 [停用資料夾首頁] 設定是 Microsoft Office 2003 系統管理範本(OUTLK11.adm)的一項設定。 如果啟用此設定,Office 2003 就無法載入 Microsoft Dynamics CRM 資料夾結構。 請參閱解決方案 2。
原因 3
如果 IIS 缺少 .srf 延伸檔案名指向 CRMisapi.dll 文件的映射,就會發生此問題。 請參閱決議 3。
原因 4
發生此問題的原因是已啟用伺服器證書撤銷檢查。 請參閱解決方案 4。
原因 5
發生此問題的原因是 Outlook.exe.config 檔案存在於 Microsoft Office 安裝資料夾中。 此檔案用於針對 Outlook Microsoft Outlook CRM 用戶端的實例進行疑難解答,讓 Outlook 可以使用特定版本的 Microsoft .NET Framework。 請參閱決議5。
決議
決議 1
若要正確啟動 Microsoft Dynamics CRM for Outlook 用戶端,指派給用戶帳戶的角色必須具有儲存檢視實體的讀取權限。 若要變更使用者的存取權,請遵循下列步驟:
- 開啟 Microsoft Dynamics CRM。
- 依序選取設定、設定、業務單位設定、使用者,然後按兩下使用者以開啟該使用者。
- 選取 [角色],按兩下角色以開啟角色、選取 [核心記錄] 索引標籤,然後選取 [已儲存檢視] 實體的 [讀取存取權]。
決議 2
若要解決此問題,請將 [停用資料夾首頁] 組態的設定變更為 停用 狀態。 若要這樣做,請遵循 Outlook 2003 的下列步驟:
- 若要編輯包含 Office 2003 系統管理範本的組策略,請開啟 組策略物件編輯器。
- 展開 用戶設定,展開 原則,展開 系統管理範本,然後展開 Microsoft Office Outlook 2003。
- 選取 [Outlook 特殊資料夾的資料夾首頁],然後按兩下 [ 停用資料夾首頁]。
- 在 [ 停用資料夾首頁內容 ] 頁面上,選取 [ 已停用 ] 複選框,然後選取 [ 確定]。
- 結束 組策略物件編輯器。
- 重新啟動受影響的用戶端電腦。
請遵循 Outlook 2007 的下列步驟:
- 若要編輯包含 Office 2007 系統管理範本的組策略,請開啟組策略物件編輯器。
- 依 序展開 [用戶設定]、[ 原則]、 [系統管理範本 ] 和 [Microsoft Office Outlook 2007]。
[注意]Microsoft Office Outlook 2007 資料夾可能包含在傳統系統管理範本 (ADM) 底下。
- 選取 Outlook 特殊資料夾的資料夾首頁,然後按兩下 不允許在資料夾內容中設定首頁 URL。
- 在 [不允許在文件夾屬性 ] 頁面中設定首頁 URL,選取 [ 已停用 ] 複選框,然後選取 [ 確定]。
- 結束 組策略物件編輯器。
- 重新啟動受影響的用戶端電腦。
解決方法 3
若要解決此問題,請將 .srf 對應新增至 Microsoft Dynamics CRM 網站。 若要這樣做,請遵循下列步驟:
- 在 IIS 中展開 Microsoft Dynamics CRM 網站。
- 以 滑鼠右鍵按下 MSCRMServices 應用程式虛擬目錄,然後選取 [ 屬性]。
- 在 [ 虛擬目錄] 索引標籤 上,選取 [ 組態]。
- 在 [ 應用程式延伸模組] 區段中,選取 [ 新增]。
-
找出CRMIsapi.dll檔案,然後將路徑放在引號中,如下所示:
C:\Program Files\Microsoft CRM\Server\bin\CrmIsapi.dll - 在 [ 延伸模組] 方塊中,輸入 .srf。
- 在「限制為」方塊中,輸入「GET、POST、HEAD」。
- 選取 [ 腳本引擎 ] 複選框和 [ 確認檔案存在] 複選框,然後選取 [ 確定]。
- 重設 IIS。 若要這樣做,請選取 [開始],選取 [執行],在 [開啟] 方塊中輸入 iisreset,然後選取 [確定]。
決議 4
若要解決此問題,請遵循下列步驟:
- 在 Internet Explorer 中,選取 [ 工具] 功能表,然後選取 [ 因特網選項]。
- 選取 [進階] 標籤,然後取消選取 [檢查伺服器證書吊銷] (需要重新啟動)複選框。
- 重新啟動 Outlook。
決議5
若要解決此問題,請移除或重新命名 Outlook.exe.config 檔案,然後重新啟動 Outlook。