共用方式為


使用伺服器端同步處理時發生「信箱沒有有效的電子郵件地址」錯誤

本文可協助您修正在 Microsoft Dynamics 365 中使用伺服器端同步處理時,收到「信箱沒有有效電子郵件地址」錯誤的問題。

適用於: Microsoft Dynamics CRM 2016
原始 KB 編號: 3214684

徵兆

當您在 Dynamics 365 中測試並啟用信箱時,您會在 [警示] 區域中遇到下列其中一個錯誤:

無法同步處理約會、聯繫人和工作,因為信箱 <信箱名稱> 沒有有效的電子郵件位址。 在信箱記錄中指定有效的電子郵件地址,然後啟用約會、聯繫人和工作同步處理的信箱。

電子郵件伺服器錯誤碼:Exchange.server 傳回 ErrorNonExistentMailbox 錯誤。

傳送電子郵件訊息「您的信箱現在已連線到 Dynamics 365」時發生一般信箱存取錯誤。 信箱 [信箱名稱] 未同步處理。 Exchange Online Microsoft相關聯的電子郵件伺服器配置檔擁有者已收到通知。

電子郵件伺服器錯誤碼:Exchange Server 傳回 ErrorInvalidOperation 例外狀況。

信箱 [信箱名稱] 無法收到電子郵件,因為信箱記錄沒有有效的電子郵件位址。 信箱未同步處理。 關於此情況的通知會張貼在電子郵件伺服器配置檔的擁有者Microsoft Exchange Online 的警示牆上。

電子郵件伺服器錯誤碼:Exchange.server 傳回 ErrorNonExistentMailbox 錯誤。

原因

此錯誤可能會因為下列其中一個原因而發生:

  • 找不到使用者的信箱,因為電子郵件地址不正確。
  • 電子郵件地址適用於通訊群組,而不是信箱。
  • 信箱已設定為使用 Exchange Online 配置檔,但使用者的信箱位於 Exchange 內部部署

解決方法

若要修正此問題,請使用下列步驟:

  1. 確認 Dynamics 365 中信箱記錄的電子郵件位址符合 Exchange 中的電子郵件位址。 此錯誤包含 Dynamics 365 中信箱記錄的連結。 您可以使用此連結快速驗證 [電子郵件位址] 欄位。
  2. 確認電子郵件地址適用於實際的信箱,而不是通訊群組。 通訊群組不是儲存電子郵件的信箱。 通訊群組可用來將電子郵件散發至屬於群組成員的信箱。
  3. 如果使用者的信箱位於 Exchange 內部部署環境中,請確定您在 Dynamics 365 中使用 Exchange Server (Hybrid) 配置檔 ,而不是 Exchange Online 配置檔。

其他相關資訊

當您按下 [ 檢視詳細資料] 時,您會看到錯誤詳細數據,如下所示:

>錯誤:<ResponseMessageType xmlns:q1=“https://schemas.microsoft.com/exchange/services/2006/messages” p2:type=“q1:FindItemResponseMessageType” ResponseClass=“Error” xmlns:p2=“”https://www.w3.org/2001/XMLSchema-instance><q1:MessageText>Mailbox 不存在。</q1:MessageText><q1:ResponseCode ErrorNonExistentMailbox</q1:ResponseCode><>q1:DescriptiveLinkKey 0</q1:DescriptiveLinkKey>></ResponseMessageType>

>錯誤:<ResponseMessageType xmlns:q1=“https://schemas.microsoft.com/exchange/services/2006/messages” p2:type=“q1:ItemInfoResponseMessageType” ResponseClass=“Error” xmlns:p2=“https://www.w3.org/2001/XMLSchema-instance”><q1:MessageText>SendOnly 不能由沒有信箱的使用者使用。使用 SendAndSaveCopy 並指定信箱中的資料夾識別碼,從沒有信箱的帳戶傳送專案。</q1:MessageText><q1:ResponseCode ErrorInvalidOperation</q1:ResponseCode><>q1:DescriptiveLinkKey 0</q1:DescriptiveLinkKey>><q1:Items /></ResponseMessageType>