共用方式為


當您在 Microsoft Dynamics 365 for Outlook 中追蹤電子郵件時,發生字典錯誤在於找不到指定的索引鍵。

本文提供解決在 Microsoft Dynamics 365 for Outlook 中追蹤電子郵件時發生的錯誤的方法。

適用於: Microsoft Dynamics 365
原始 KB 編號: 4010462

癥狀

當您嘗試在 Dynamics 365 for Outlook 中追蹤電子郵件時,您會收到下列錯誤:

「指定的索引鍵不存在於字典中。」

如果您選取詳細資料,您會看到下列其他詳細資料:

「指定的索引鍵不存在於字典中。
at System.Collections.Generic.Dictionary2.get_item(Tkey 鍵)
at Microsoft.Crm.AppIication.SMWrappers.AttachmentForOutIook.Get...clientOrganizationContext、 IDynamicEntityCoIIectionForOutIook dynamicEntityCoIIectionAttachments)
atMicrosoft.Crm.ApplicationsMWrappers.EmailForOutlook.Microsoft...。messageld, String subject, String from, String to, String cc, String bcc, Double receivedon, String submitted8y, String importance, String body, IDynamicEntityCollectionForOutlook attachments, Int32 attachmentCount, IDynamicEntityForOutlook extraProperties, String entityXml, String regardingId, Int64 regardingObjectType, String crmId, Int32& notification)”

原因

下列其中一個情況可能會發生此錯誤:

  1. 電子郵件包含大於 Dynamics 365 中允許大小的附件。
  2. 電子郵件包含一個附件,其文件擴展名被 Dynamics 365 封鎖。

決議

解決方法 1
如果電子郵件包含超過大小限制的附件,請移除附件,或增加 Dynamics 365 中允許的附件大小。 默認大小上限為 5 MB。

如果您在 Dynamics 365 中具有系統管理員角色,您可以流覽至 [設定]、 [系統管理],然後選取 [系統設定] 來檢視和修改此設定。 選取 [ 電子郵件 ] 索引標籤,然後在 [設定附件的檔案大小限制] 標題下,找出 [ 檔案大小上限] 設定。

解決方法 2
如果電子郵件包含 Dynamics 365 封鎖擴展名的附件,請移除附件或修改 Dynamics 365 封鎖的擴展名。

如果您在 Dynamics 365 中具有系統管理員角色,您可以流覽至 [設定]、 [系統管理],然後選取 [系統設定] 來檢視和修改此設定。 在 [一般] 索引標籤上,找出 [設定封鎖附件副檔名] 的設定。