徵狀
您可以在 Microsoft 365 應用程式中開啟和編輯 Microsoft OneDrive 同步處理的檔案,例如 Microsoft Word、Microsoft PowerPoint 或 Microsoft Excel。 當您試著儲存盤案時,您會收到下列錯誤訊息:
上傳已封鎖:我們無法確認您具有上傳檔案的必要許可權。
原因
如果您使用沒有許可權將檔案上傳至 OneDrive 的帳戶登入 Microsoft 365 應用程式,就會發生此問題。
例如,您可以使用 user@fabrikam.onmicrosoft.com 帳戶將檔案同步至 OneDrive。 不過,您可以使用 user@contoso.onmicrosoft.com 帳戶登入 Microsoft 365 應用程式,而且此帳戶沒有將檔案上傳至 OneDrive 的許可權。 在此情況下,您會在嘗試將檔案儲存至 OneDrive 時收到錯誤訊息。
解決方案
若要修正此問題,請依指定順序嘗試下列方法。 如果某個方法無法修正問題,請嘗試下一個方法。
方法 1:使用相同的帳戶登入 Microsoft 365 應用程式和 OneDrive
選取任務列通知區域中 (
) 的 OneDrive 圖示。
選 取 [說明 & 設定 ( )
>設定]。
在 [ 帳戶] 索引 標籤上,記下已登入的帳戶。
開啟受影響的 Microsoft 365 應用程式,然後選取 [檔案>帳戶]。
在 [ 已連線的服務] 底下,選 取 [移除 ] 以移除您在步驟 3 中記下的帳戶以外的所有帳戶。
選取 OneDrive 圖示,選 取 [說明 & 設定 ] (
) >[暫停同步處理],然後選取您要暫停的時間: 2 小時、 8 小時或 24 小時。
選 取 [說明 & 設定 ] (
) >[結束 OneDrive]。
關閉所有 Microsoft 365 應用程式。
重新啟動 OneDrive 和受影響的 Microsoft 365 應用程式。
請再試一次,將檔案儲存至 OneDrive。
方法 2:移除與 OneDrive 和 Microsoft 365 應用程式相關的認證
開啟受影響的 Microsoft 365 應用程式,然後選取 [檔案>帳戶]。
在 [ 使用者資訊] 底下,選取 [註 銷 所有帳戶]。
關閉所有 Microsoft 365 應用程式。
選取 [開始 (
) ],輸入 認證,然後選取 [ 認證管理員]。
選取 Windows 認證。
在 [ 一般認證] 下,選取與 OneDrive、MicrosoftOffice16 和 MicrosoftOffice15 相關的認證,然後選取 [ 移除]。
重新啟動 OneDrive 和受影響的 Microsoft 365 應用程式,然後使用相同的帳戶再次登入。
請再試一次,將檔案儲存至 OneDrive。
方法 3:取消連結並重新連結 OneDrive
這個方法可以修正 OneDrive 設定問題。 如需詳細步驟,請參閱 取消連結並重新連結 OneDrive。 然後,再試一次,將檔案儲存至 OneDrive。
方法 4:安裝可用的 Windows 更新
若要檢查並安裝所有可用的更新,請參閱 更新 Windows。 安裝所有更新之後,請重新啟動受影響的 Microsoft 365 應用程式,然後再試一次,將檔案儲存至 OneDrive。