錯誤AADSTS70001 - 在目錄中找不到具有識別符的應用程式

本文說明當您嘗試登入已與 Microsoft Entra ID 整合的 SAML 型單一登錄 (SSO) 設定的應用程式時,您會收到錯誤訊息「錯誤AADSTS70001 - 目錄中找不到標識符的應用程式」。

徵狀

嘗試登入已設定為使用 samL 型 SSO 進行身分識別管理 Microsoft Entra ID 的應用程式時,您會收到錯誤AADSTS70001

原因

Issuer從應用程式傳送至 SAML 要求中 Microsoft Entra ID 的屬性不符合在 Microsoft Entra ID 中為應用程式設定的識別碼值。

解決方案

請確定 Issuer SAML 要求中的 屬性符合在 Microsoft Entra ID 中設定的識別碼值。

在 [SAML 型 SSO 組態] 頁面的 [ 基本 SAML 組態] 區段中,確認 [標識符] 文本框中的值符合錯誤中顯示之標識符值的值。 如果 URL 結尾有尾端斜線,也應該包含它。

在 Microsoft Entra 系統管理中心 中使用測試 SSO 函式

此 Microsoft Entra 系統管理中心 可協助您針對 SAML 設定錯誤進行疑難解答。

在 Microsoft Entra 系統管理中心 中測試 SSO 功能的螢幕快照。

  1. 在 Microsoft Entra 系統管理中心 中,移至 [企業應用程式],然後按兩下需要疑難解答的應用程式。
  2. 使用左側導覽功能表流覽至 [單一登錄 ] 頁面
  3. 按兩下 [測試此應用程式 ] 以使用測試 SSO 功能。
  4. 將收到的錯誤複製並貼到 [ 解決錯誤 ] 區段中,然後按兩下 [取得解決指引]
  5. 檢視找到的簽發者與標識符之間的差異。
  6. 更正簽發者或標識碼。

其他相關資訊

如需 Active Directory 驗證和授權錯誤碼的完整清單,請參閱 Microsoft Entra 驗證和授權錯誤碼

與我們連絡,以取得說明

如果您有問題或需要相關協助,請建立支援要求,或詢問 Azure community 支援。 您也可以將產品意見反應提交給 Azure 意應見反社群