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針對 AksCapacityHeavyUsage 錯誤碼進行疑難解答

本文討論如何識別並解決 AksCapacityHeavyUsage 當您建立 Microsoft azure Kubernetes Service (AKS) 叢集時可能發生的錯誤。

癥狀

當您嘗試建立 AKS 叢集時,您會收到下列錯誤訊息:

代碼: AksCapacityHeavyUsage

消息: AKS 在 <區域>面臨使用量過大。 我們正努力新增容量。 同時,請考慮在不同的區域中建立新的 AKS 叢集。 如需所有 Azure 區域的清單,請瀏覽 https://aka.ms/aks/regions。 如需了解此錯誤的詳細資訊,請瀏覽 https://aka.ms/akscapacityheavyusage

原因

您嘗試在容量有限的區域中建立叢集。

當您建立 AKS 叢集時,Microsoft Azure 會將計算資源配置給您的訂用帳戶。 您偶爾可能會因為特定區域中 Azure Kubernetes Service 的需求大幅成長而遇到 AksCapacityHeavyUsage 錯誤。

決議

解決方案 1:選取不同的區域

最簡單的和最快速的解決方案是嘗試部署到不同的區域(例如 NorthEurope,而不是 WestEurope 或 UAENorth,而不是卡達Central)。 若要尋找附近的區域,請流覽 Azure 地理位置頁面

如果您已在要求區域中已有現有資源,但這是開發/測試案例中慣用的解決方案,則這種方法可能不可行。

解決方案2:部署具有不同設定的叢集

承載 AKS 受控叢集的基礎設施具有不同的分配預留。 因此,AKS 的公用叢集容量可能比私人叢集的容量還多。 如果您在嘗試建立私人叢集時遇到 AksCapacityHeavyUsage 錯誤,請嘗試改為建立公用叢集(反之亦然)。

解決方案3:使用 Azure 企業版訂用帳戶

當容量不足時,非 Enterprise 協議 (EA) 訂用帳戶在 AKS 叢集建立中會先受到限制,以保留資源給實際生產場景。 如果您有 EA 訂用帳戶,請確定您使用 EA 訂用帳戶來建立 AKS 叢集。

解決方案4:重試作業

當其他使用者停止或刪除其 AKS 叢集時,通常會回收容量。 因此,如果您稍後再重試作業,作業可能會成功。

詳細資訊

與我們連絡,以取得說明

如果您有疑問,可以詢問 Azure 社群支援。 您也可以向 Azure 意見反應社群提交產品意見反應。