共用方式為


即使已啟用 Microsoft 365 存取,還是會發生許可權錯誤

本文說明如何解決用戶嘗試從 Microsoft Teams 存取 Business Central 記錄時可能會遇到的許可權相關問題,即使商務中心系統管理中心已正確啟用使用 Microsoft 365 授權的存取。

徵狀

當使用者在 Microsoft Teams 交談中選取 Business Central 記錄的連結或卡片時,會收到類似「很抱歉,目前的許可權阻止動作」的錯誤訊息。

原因

產生此錯誤是系統刻意為之。 系統管理員必須先設定哪些數據可以在 Microsoft Teams 中存取。 如果系統管理員在 Business Central 系統管理中心啟用存取權,但未在 [ 授權 組態] 頁面上指派許可權,則嘗試存取 Microsoft Teams 中 Business Central 記錄的使用者,將會在沒有任何物件許可權的情況下布建其用戶記錄。

解決方案

注意事項

若要解決此問題,您需要 Business Central 中的租用戶系統管理員許可權。

除了在 Dynamics 365 Business Central 系統管理中心啟用 Microsoft 365 存取之外,也請在 [授權組態] 頁面上指派許可權。 不過,在 [ 授權 組態] 頁面上指派的許可權只會套用至新建立的使用者。 對於已建立的使用者,您也必須透過 [ 使用者] 列表 頁面指派遺失的許可權。

其他相關資訊

根據授權 Create使用者