共用方式為


Business Central 雲端移轉中的活動逾時

本文提供 商務中心雲端移轉期間活動逾時問題的疑難解答步驟。

徵狀

活動在 Business Central 雲端移轉期間逾時。

原因

如果活動在雲端移轉設定期間逾時,可能是因為 Integration Runtime 無法建立與 SQL Server 的連線,或是因為大型內部部署資料庫中的索引重組。 如果在移轉執行期間逾時,原因很可能是內部部署 SQL Server 弱或忙碌。

解決方案

  • 如果 SQL 連線永久中斷,請檢查 .NET 4.72 或更新版本是否正在 整合運行時間的主機上執行。

  • 檢查 Azure Data Factory 頁面上的其他 Integration Runtime 需求。

  • 針對資料庫效能問題,建議您在設定雲端移轉之前,先更新統計數據並重新組織內部部署資料庫中的索引。

    • 若要更新統計數據,請執行下列查詢 (例如,在聯機到內部部署資料庫的 Microsoft SQL Management Studio 中) :

      EXEC sp_updatestats;
      
    • 若要重新組織索引,請執行下列查詢:

      EXEC sys.sp_MSforeachtable 'ALTER INDEX ALL ON ? REORGANIZE'
      

其他相關資訊