在OS部署期間,使用可開機或預先設置的媒體,以 winHTTP 傳送失敗 80072f8f 錯誤Smsts.log
本文可協助您修正工作順序精靈傳回錯誤80004005的問題,Smsts.log記錄 使用 winHTTP 傳送失敗;在 使用可開機或預先設置媒體的 OS 部署期間發生 80072f8f 錯誤。
原始產品版本:Configuration Manager (最新分支) 、Microsoft System Center 2012 R2 Configuration Manager、Microsoft System Center 2012 Configuration Manager
原始 KB 編號: 4551033
徵狀
您可以在 Configuration Manager 中建立可開機媒體或預先設置的媒體。 當媒體用來啟動目的地計算機時,[工作順序精靈] 會停滯 在此計算機 步驟的擷取原則約 90 秒,然後傳回下列錯誤訊息:
無法執行工作順序
擷取此電腦 (0x80004005) 的原則時發生錯誤。 如需詳細資訊,請連絡您的系統管理員或技術服務人員操作員。
當工作順序引擎第一次嘗試連絡管理點以同步處理時間資訊時,下列錯誤訊息會記錄在計算機上的 X:\Windows\Temp\SMSTSLog\smsts.log 中:
TSMBootstrap 目前時間資訊:
TSMBootstrap 取得 MP 時間資訊
TSMBootstrap 要求用戶端身分識別
TSMBootstrap 設定驗證器。
TSMBootstrap CLibSMSMessageWinHttpTransport::Send: WinHttpOpenRequest - URL: <MP>:443 CCM_POST /ccm_system_AltAuth/request
TSMBootstrap SSL,在要求中使用驗證器。
TSMBootstrap 在 SSL 中,但沒有客戶端憑證。
TSMBootstrap [TSMESSAGING] AsyncCallback () :
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback () :發生WINHTTP_CALLBACK_STATUS_SECURE_FAILURE
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength 為 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation 0x8
TSMBootstrap [TSMESSAGING] :已設定WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA
TSMBootstrap [TSMESSAGING] AsyncCallback () :
-----------------------------------------------------------------
TSMBootstrap 錯誤。 從 WinHttpSendRequest 收到0x80072f8f。
使用 winHTTP 傳送 TSMBootstrap 失敗;80072f8f。 重試。
TSMBootstrap 重試和忽略日期安全性失敗。
TSMBootstrap [TSMESSAGING] AsyncCallback () :
-----------------------------------------------------------------
TSMBootstrap [TSMESSAGING] AsyncCallback () :發生WINHTTP_CALLBACK_STATUS_SECURE_FAILURE
TSMBootstrap [TSMESSAGING] : dwStatusInformationLength 為 4
TSMBootstrap [TSMESSAGING] : *lpvStatusInformation 0x8
TSMBootstrap [TSMESSAGING] :已設定WINHTTP_CALLBACK_STATUS_FLAG_INVALID_CA
TSMBootstrap [TSMESSAGING] AsyncCallback () :
-----------------------------------------------------------------
TSMBootstrap hr, HRESULT=80072f8f
使用 winHTTP 傳送 TSMBootstrap 失敗;80072f8f
在初始錯誤之後,工作順序引擎會嘗試額外的四次來連絡管理點,並在每次嘗試之間經歷愈來愈大的暫停。 不過,所有嘗試都會失敗,並在傳回一些最終錯誤訊息之前傳回相同的錯誤訊息,如下所示:
如果媒體設定為動態媒體,則會將下列最終錯誤訊息記錄在Smsts.log:
TSMBootstrap Send (pReply, nReplySize) , HRESULT=80072f8f
TSMBootstrap 無法傳送要求
TSMBootstrap DoRequest (sReply, true) , HRESULT=80072f8f
TSMBootstrap 無法取得用戶端身分識別 (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity () ,HRESULT=80072f8f
TSMBootstrap 無法要求用戶端
TSMBootstrap SyncTimeWithMP () 失敗。 80072f8f。
TSMBootstrap 無法從 MP 取得時間資訊:https://<MP>
。
TSMBootstrap MpCnt > 0, HRESULT=80004005
TSMBootstrap QueryMPLocator:未收到有效的 MP 位置
TSMBootstrap TSMBootstrapUtil::QueryMPLocator ( true、sSMSTSLocationMPs.c_str () 、sMediaPfx.c_str () 、sMediaGuid.c_str () 、sAuthenticator.c_str () 、sEnterpriseCert.c_str () 、sServerCerts.c_str () 、nHttpPort、nHttpsPort、bUseCRL、m_bWinPE、httpS、http、accessibleMpCnt) 、HRESULT=80004005
TSMBootstrap 無法查詢管理點定位器
TSMBootstrap 結束 TSMediaWizardControl::GetPolicy。
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>> () , HRESULT=80004005
TSMBootstrap 設定精靈錯誤:擷取此電腦的原則時發生錯誤 (0x80004005) 。 如需詳細資訊,請連絡您的系統管理員或技術服務人員操作員。如果媒體設定為月臺型,則會將下列最終錯誤訊息記錄在Smsts.log:
TSMBootstrap Send (pReply, nReplySize) , HRESULT=80072f8f
TSMBootstrap 無法傳送要求
TSMBootstrap DoRequest (sReply, true) , HRESULT=80072f8f
TSMBootstrap 無法取得用戶端身分識別 (80072f8f)
TSMBootstrap ClientIdentity.RequestClientIdentity () ,HRESULT=80072f8f
TSMBootstrap 無法要求用戶端
TSMBootstrap SyncTimeWithMP () 失敗。 80072f8f。
TSMBootstrap 無法從 MP 取得時間資訊:https://<MP>
。
TSMBootstrap sMP.length () > 0, HRESULT=80004005
TSMBootstrap TSMBootstrapUtil::SelectMP ( sSMSTSMP.c_str () , sMediaPfx.c_str () 、sMediaGuid.c_str () 、sAuthenticator.c_str () 、sEnterpriseCert.c_str () 、sServerCerts.c_str () 、nHttpPort、nHttpsPort、bUseCRL、m_bWinPE、sSiteCode、sAssignedSiteCode、sMP、sCertificates、sX86UnknownMachineGUID、sX64UnknownMachineGUID) 、HRESULT=80004005
TSMBootstrap 無法選取 MP
TSMBootstrap 結束 TSMediaWizardControl::GetPolicy。
TSMBootstrap pWelcomePage-m_pTSMediaWizardControl-GetPolicy>> () , HRESULT=80004005
TSMBootstrap 設定精靈錯誤:擷取此電腦的原則時發生錯誤 (0x80004005) 。 如需詳細資訊,請連絡您的系統管理員或技術服務人員操作員。
下列詳細資訊適用於錯誤 80072F8F:
錯誤碼:0x80072F8F (2147954575)
錯誤名稱:WININET_E_DECODING_FAILED
錯誤來源:Windows
錯誤訊息:內容譯碼失敗
原因
如果下列條件成立,就會發生此問題:
- 您會在 Configuration Manager 環境中使用 PKI。
- 您可以在管理中心網站建立可開機媒體或預先設置的媒體。
- 您可以將管理點設定為使用 HTTPS。
如果您在 Configuration Manager 環境中使用 PKI,則會在主要月臺指定證書頒發機構單位 (CA) ,而不是在管理中心網站上指定。 因為管理中心網站沒有根 CA 資訊,所以建立的媒體不包含根 CA 資訊。 因此,傳送至已啟用 HTTPS 之管理點的要求會在沒有根 CA 信息的情況下失敗。
解決方案
若要修正此問題,請在主要月臺建立可開機媒體或預先設置的媒體,而不是在管理中心網站建立。
其他相關資訊
對於將用於多個網站的媒體,請將媒體設定為動態媒體。 您可以在任何網站建立動態媒體。 您不限於在管理中心網站建立它。