本文可協助您修正當您開啟由 Microsoft Intune 應用程式保護原則 (APP) 所管理之 Outlook for Android 應用程式時,收到 貴組織已移除與此應用程式 錯誤訊息相關聯的數據的問題。
徵兆
當您開啟 Intune APP 所管理的 Android 版 Outlook 應用程式時,您會收到下列訊息:
您的組織已移除與此應用程式相關聯的數據,因為Microsoft Intune 公司入口網站 資料或應用程式已移除。 若要重新連線,您必須使用公司或學校帳戶登入。
原因
這個問題是因為下列其中一個原因所造成:
- Outlook 已離線很長一段時間。 因此,您已根據現有的應用程式保護原則註銷 Outlook。
- Outlook 無法偵測系統更新之後是否已安裝 公司入口網站 應用程式。 因為 Outlook 無法取得預期的存取令牌,所以它會脫機。 因此,您已根據現有的應用程式保護原則註銷 Outlook。
解決方案
若要避免未來發生此問題,請在Android裝置上完成下列步驟:
- 關閉 Outlook 和 公司入口網站 的電池優化。
- 將 Outlook 和 公司入口網站 的應用程式啟動設定從 [自動] 變更為 [手動管理]。 然後,啟用下列管理 手動 選項:
- 自動啟動
- 次要啟動
- 在背景中執行
- 如果您已啟用資料儲存器,請選取 [Outlook] 和 [公司入口網站],以取得不受限制的數據使用量。
- 啟用 Outlook 和 公司入口網站 的通知。
注意
建議您也針對 Intune 應用程式所管理的其他應用程式執行這些步驟。
如果問題持續發生,請遵循下列步驟來取得支援:
收集 Outlook 診斷記錄資訊:
- 在 Android 版 Outlook 設定中,點選 [說明與意見反應]。
- 點選 [ 收集診斷]。
- 點選 [開始使用]。
- 點選 [ 收集記錄]。
- 提供事件標識碼給 Microsoft 支援服務。
收集 Android 偵錯記錄資訊。
建立服務要求。 若要這樣做,請遵循如何取得 intune 系統管理中心Microsoft支援中的步驟。