本文可協助您修正裸機復原 (BMR) 備份因為Microsoft Azure 備份 伺服器或 System Center Data Protection Manager (DPM) 中的高輸入/輸出 (I/O) 延遲而失敗的問題。
原始產品版本: System Center 2016 Data Protection Manager
原始 KB 編號: 4512842
徵兆
當您使用 Azure 備份 Server 或 System Center Data Protection Manager 執行 BMR 備份時,備份會失敗。 您在 DPM 伺服器上收到下列其中一個錯誤訊息:
DPM 無法建立備份,因為受保護計算機上的 Windows Server Backup (WSB) 發生錯誤 (WSB 事件標識符:517、WSB 錯誤碼:0x6B48C3A0)。 (標識元 30229 詳細數據:內部錯誤碼:0x80990ED0)
記錄名稱:DPM 警示
來源:DPM-EM
日期: <日期><時間>
事件標識碼:3106
工作分類:無
層級: 錯誤
關鍵字:傳統
使用者: N/A
計算機: <servername>
描述:伺服器名稱>上的<非 VSS 數據源寫入器複本與受保護的數據源不一致。 數據源的所有保護活動都會失敗,直到複本與一致性檢查同步。 (標識元:3106)
無法讀取或寫入涉及目前作業的記憶體。 (標識碼:40003)
下列錯誤項目會記錄在受保護的伺服器上:
記錄檔名稱:Microsoft-Windows-Backup
來源:Microsoft-Windows-Backup
日期: <日期><時間>
事件標識碼:5
工作分類:無
層級: 錯誤
關鍵字:
使用者: SYSTEM
計算機: <Servername>
描述:
在 「<時間>」啟動的備份作業失敗,並出現下列錯誤碼 『0x8078015B』(Windows 備份 存取遠端共享資料夾時發生錯誤。請確認遠端共享資料夾可供使用且可存取之後,重試作業。 請檢閱解決方案的事件詳細數據,然後在問題解決後重新執行備份作業。
記錄檔名稱:Microsoft-Windows-SmbClient/Connectivity
來源:Microsoft-Windows-SMBClient
日期: <日期><時間>
事件標識碼:30809
工作分類:無
層級: 錯誤
關鍵字: (64)
使用者: N/A
計算機: <servername>
描述:
要求逾時,因為伺服器沒有回應。伺服器名稱: <Servername>
會話標識碼: <會話標識碼>
樹狀結構標識碼:0x1
訊息標識碼:0x4000015
命令:Flush
指導方針:
伺服器會透過 TCP 回應,但不會透過 SMB 回應。 請確定伺服器服務正在執行並回應,且磁碟沒有高每個 IO 延遲,這會使磁碟對 SMB 沒有回應。 此外,請確定伺服器整體回應且未暫停;例如,請確定您可以登入它。
記錄檔名稱:Microsoft-Windows-SMBServer/Operational
來源:Microsoft-Windows-SMBServer
日期: <日期><時間>
事件標識碼:1020
工作類別: (1020)
層級:警告
關鍵字:(8)
使用者: SYSTEM
計算機: <ServerName>
描述:
檔系統作業所花費的時間超過預期。
用戶端名稱: <IP>
用戶端位址: <IP:埠>
用戶名稱: <用戶名稱>
會話標識碼: <會話標識碼>
共享名稱: <sharename>
檔名:WINDOWSIMAGEBACKUP\<Servername>\<Backupdate>\<GUID>。VHDX
命令:7
持續時間(以毫秒為單位):353151
警告臨界值(以毫秒為單位):120000
指導方針:
基礎文件系統花費的時間太長,無法回應作業。 這通常表示記憶體的問題,而不是SMB。
原因
Windows 備份伺服器會在備份期間直接寫入 DPM 或 Azure 備份 Server 共用。 如果輸入/輸出 (I/O) 延遲大於標準 SMB 逾時(60 秒),就會發生此問題。
解決方法
重要
這個章節、方法或工作包含修改登錄的步驟。 然而,不當修改登錄可能會發生嚴重的問題。 因此,請務必小心執行下列步驟。 為增加保護起見,請先備份登錄,再進行修改。 然後,如果發生問題,您就可以還原登錄。 如需備份和還原登錄的詳細資訊,請參閱如何在 Windows 中備份及還原登錄。
若要修正問題,請依照下列步驟執行:
在受保護的伺服器上,開啟 [註冊表編輯器],然後新增
SessTimeout
登錄專案,如下列子機碼所示:子機碼 名稱 類型 資料 HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters
SessTimeout REG_DWORD 1200 注意
1,200 秒(20 分鐘)逾時是建議值。 視需要調整值。 您可以在 DPM 或 Azure 備份 伺服器伺服器上檢閱復原檔案系統 (ReFS) 事件記錄檔,以尋找任何可疑的 I/O 延遲。
重新啟動受保護的伺服器。
如果您無法重新啟動受保護的伺服器,請停止並重新啟動工作站 (Lanmanworkstation) 服務。
注意
請確定您檢查工作站 (Lanmanworkstation) 服務的相依性清單。 相依於此服務的服務也必須重新啟動。
其他相關資訊
當您使用 BMR 備份時,請確定符合下列必要條件:
已安裝 DPM 或 Azure 備份 Server 的最新更新。
復本大小已正確設定。 如需詳細資訊,請參閱 如何使用新式備份記憶體 (MBS) 增加 DPM 2016 複本。