本文提供當服務突然停止時發生「錯誤 1058」的問題的解決方案。
適用於: Windows 10 - 所有版本、Windows 7、Windows Vista、Windows XP
原始 KB 編號: 241584
徵兆
當服務突然停止時,您可能會收到下列錯誤訊息:
錯誤 1058:服務無法啟動,可能是因為服務已停用,或因為沒有與其相關聯的已啟用裝置。
當您嘗試啟動服務時,也可能會收到此錯誤訊息。
原因
如果服務已停用,或目前使用的硬體配置檔已停用服務,就可能發生此問題。
Windows 10、Windows 7 和 Windows Vista 的解決方案
按兩下 [開始],搜尋 [服務],然後按下搜尋結果中的 [ 服務 ]。
捲動直到您找到服務,然後按兩下服務。
如果服務已停用,請按兩下 [啟動類型] 列表,然後選取 [已停用] 以外的選項。
按一下 套用。
按兩下 [開始 ] 以嘗試啟動服務。
按一下 [確定]。
Windows XP 的解決方案
按兩下 [開始],指向 [ 所有程式],指向 [ 系統管理工具],然後按兩下 [ 服務]。
捲動直到您找到已停止或停用的服務為止。
按兩下未啟動的服務。
按一下[登入]索引標籤。
確認您所使用的硬體配置檔並未停用服務。 如果硬體配置檔已停用服務,請按兩下 [ 啟用]。
按兩下 [一般] 索引標籤,然後在 [啟動類型] 方塊中,確認服務未停用。 如果服務已停用,請按兩下 [ 自動 ] 以在啟動電腦時啟動它。
按一下 [確定]。
其他相關資訊
如果服務設定為自動啟動,但已針對您使用的硬體配置檔停用服務,則不會啟動服務,而且不會產生任何錯誤訊息。