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使用 Active Directory 使用者和電腦的密碼重設失敗,並出現錯誤「系統找不到指定的路徑」

本文提供在您重設用戶密碼時所發生的錯誤解決方案。

原始 KB 編號: 2001522

徵兆

您必須有工作來管理網域中的使用者,而且您必須重設用戶的密碼。 您可以以滑鼠右鍵按兩下使用者,然後選取 [重設密碼 ],然後輸入新的密碼。 按兩下 [ 確定] 之後,您會收到錯誤訊息:

Windows 無法完成使用者名稱>的密碼變更<,因為:
系統找不到指定的路徑

之後不會變更用戶的密碼。 相同的工作可以與其他系統管理員用戶帳戶搭配使用,也適用於其他工作站上的相同系統管理員帳戶。 重設用戶密碼也可以透過其他工具運作,例如使用 LDIFDE,如 如何使用 Ldifde 設定使用者的密碼中所述。

原因

對話框處理程式函式會在從編輯控制項提取新密碼字串時加密這些字串。 加密失敗,因為它在下列位置的使用者 AppData 資料夾中找不到支援檔案
%AppData%\Microsoft\Protect\<user sid>

如果 AppData 使用者殼層資料夾重新導向至不同的位置,而不需要移動或複製原始數據,就可能會發生這種情況。 資料夾位置是在下列登入位置的 AppData 登入值中指定:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

解決方法

若要解決此問題,請移動原始數據或將原始數據複製到重新導向的位置,或還原 AppData 資料夾的重新導向。

使用行程監視器工具,您可以看到LSASS.EXE程式在確認新密碼對話框之後,無法在 AppData 路徑中開啟檔案。 如需行程監視器工具的詳細資訊,請流覽下列Microsoft網站:
進程監視器 v3.60

其他相關資訊

Microsoft建議使用資料夾重新導向原則,將使用者配置檔的部分重新導向至不同的位置。 這些原則也允許自動移動資料夾的內容。