RADIUS_ATTRIBUTE_TYPE列舉 (authif.h)

注意

從 Windows Server 2008 開始,因特網驗證服務 (IAS) 已重新命名為 NPS (NPS) 。 本主題的內容適用於 IAS 和 NPS。 在整個文字中,NPS 會用來參考服務的所有版本,包括原本稱為 IAS 的版本。

RADIUS_ATTRIBUTE_TYPE類型會列舉RADIUS屬性的可能類型。

Syntax

typedef enum _RADIUS_ATTRIBUTE_TYPE {
  ratMinimum,
  ratUserName,
  ratUserPassword,
  ratCHAPPassword,
  ratNASIPAddress,
  ratNASPort,
  ratServiceType,
  ratFramedProtocol,
  ratFramedIPAddress,
  ratFramedIPNetmask,
  ratFramedRouting,
  ratFilterId,
  ratFramedMTU,
  ratFramedCompression,
  ratLoginIPHost,
  ratLoginService,
  ratLoginPort,
  ratReplyMessage,
  ratCallbackNumber,
  ratCallbackId,
  ratFramedRoute,
  ratFramedIPXNetwork,
  ratState,
  ratClass,
  ratVendorSpecific,
  ratSessionTimeout,
  ratIdleTimeout,
  ratTerminationAction,
  ratCalledStationId,
  ratCallingStationId,
  ratNASIdentifier,
  ratProxyState,
  ratLoginLATService,
  ratLoginLATNode,
  ratLoginLATGroup,
  ratFramedAppleTalkLink,
  ratFramedAppleTalkNetwork,
  ratFramedAppleTalkZone,
  ratAcctStatusType,
  ratAcctDelayTime,
  ratAcctInputOctets,
  ratAcctOutputOctets,
  ratAcctSessionId,
  ratAcctAuthentic,
  ratAcctSessionTime,
  ratAcctInputPackets,
  ratAcctOutputPackets,
  ratAcctTerminationCause,
  ratCHAPChallenge,
  ratNASPortType,
  ratPortLimit,
  ratTunnelType,
  ratMediumType,
  ratTunnelPassword,
  ratTunnelPrivateGroupID,
  ratNASIPv6Address,
  ratFramedInterfaceId,
  ratFramedIPv6Prefix,
  ratLoginIPv6Host,
  ratFramedIPv6Route,
  ratFramedIPv6Pool,
  ratCode,
  ratIdentifier,
  ratAuthenticator,
  ratSrcIPAddress,
  ratSrcPort,
  ratProvider,
  ratStrippedUserName,
  ratFQUserName,
  ratPolicyName,
  ratUniqueId,
  ratExtensionState,
  ratEAPTLV,
  ratRejectReasonCode,
  ratCRPPolicyName,
  ratProviderName,
  ratClearTextPassword,
  ratSrcIPv6Address,
  ratCertificateThumbprint
} RADIUS_ATTRIBUTE_TYPE;

常數

 
ratMinimum
這個值等於零,並做為 任何RADIUS_ATTRIBUTE 結構陣列中的 null 終止符。
ratUserName
指定要驗證的用戶名稱。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。 另請參閱 使用者識別屬性。
ratUserPassword
指定要驗證之用戶的密碼。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratCHAPPassword
指定使用者提供的密碼,以回應挑戰交握驗證通訊協定 (CHAP) 挑戰。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratNASIPAddress
指定 NAS IP 位址。 Access-Request 應該指定 NAS IP 位址或 NAS 識別碼。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratNASPort
識別用戶連線到 NAS 的實體或虛擬專用網 (VPN) 。 請注意,此值不是 TCP 或 UDP 的埠號碼。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratServiceType
指定使用者所要求的服務類型,或要提供的服務類型。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedProtocol
指定要用於框架式存取的框架通訊協定類型,例如 SLIP、PPP 或 ARAP (AppleTalk 遠端存取通訊協定) 。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedIPAddress
指定將針對要求驗證的使用者設定的IP位址。 這個屬性通常是由驗證提供者傳回。 不過,NAS 可以在驗證要求中使用它來指定慣用的IP位址。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedIPNetmask
指定屬於網路路由器之使用者的IP網路遮罩。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedRouting
指定屬於網路路由器之使用者的路由方法。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratFilterId
識別要求驗證之用戶的篩選清單。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedMTU
指定使用者的傳輸單位上限 (MTU) 。 如果 MTU 不是透過一些其他方式交涉,例如 PPP,則會使用這個屬性。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedCompression
指定要用於連接的壓縮通訊協定。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865
ratLoginIPHost
指定要用來連接用戶的系統。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratLoginService
指定要用來將用戶連線到 ratLoginIPHost 所指定的主機的服務。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratLoginPort
指定要連接使用者的埠。 只有當 ratLoginService 屬性存在時,才會存在這個屬性。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratReplyMessage
指定要向用戶顯示的訊息。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratCallbackNumber
指定回呼號碼。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratCallbackId
識別要回呼的位置。 NAS 會解譯此屬性的值。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedRoute
提供路由資訊,讓使用者在NAS上設定。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratFramedIPXNetwork
指定要為使用者設定的IPX網路號碼。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratState
此屬性包含在伺服器與客戶端之間的 Access-Challenge 和 Access-Accept 通訊中。 如需此值的詳細資訊,請參閱 RFC 2865 。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。
ratClass
指定驗證提供者提供給 NAS 的值。 NAS 與會計提供者通訊時,應該使用此值。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratVendorSpecific
可讓廠商提供自己的擴充屬性。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2865 。
ratSessionTimeout
指定要向使用者提供服務的最大秒數。 在這段時間之後,會話會終止。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865 。
ratIdleTimeout
指定工作階段可以閒置的連續秒數上限。 如果空閒時間超過此值,會話就會終止。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊 ,請參閱 RFC 2865 。
ratTerminationAction
指出 NAS 在指定的服務完成時應該採取的動作。 它只會用於 Access-Accept 封包。 此類型的值欄位 RADIUS_ATTRIBUTE 為32位整數值。 如需詳細資訊 ,請參閱 RFC 2865 。
ratCalledStationId
指定使用者撥打以連線到 NAS 的數位。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊 ,請參閱 RFC 2865 。
ratCallingStationId
指定使用者呼叫的來源號碼。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊 ,請參閱 RFC 2865 。
ratNASIdentifier
指定 NAS 識別碼。 Access-Request 應該指定 NAS 識別碼或 NAS IP 位址。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊 ,請參閱 RFC 2865 。
ratProxyState
指定 Proxy 伺服器在轉送驗證要求時所包含的值。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊 ,請參閱 RFC 2865 。
ratLoginLATService
此屬性目前不適用於 Windows 上的驗證。 如需詳細資訊 ,請參閱 RFC 2865 。
ratLoginLATNode
此屬性目前不適用於 Windows 上的驗證。 如需詳細資訊 ,請參閱 RFC 2865 。
ratLoginLATGroup
此屬性目前不適用於 Windows 上的驗證。 如需詳細資訊 ,請參閱 RFC 2865 。
ratFramedAppleTalkLink
為另一個路由器的使用者指定 AppleTalk 網路號碼。 此類型的值欄位 RADIUS_ATTRIBUTE 為32位整數值。 如需詳細資訊 ,請參閱 RFC 2865 。
ratFramedAppleTalkNetwork
指定 NAS 應該用來為使用者配置 AppleTalk 節點的 AppleTalk 網路號碼。 只有當使用者不是另一個路由器時,才會使用這個屬性。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊 ,請參閱 RFC 2865 。
ratFramedAppleTalkZone
指定使用者的 AppleTalk 預設區域。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊 ,請參閱 RFC 2865 。
ratAcctStatusType
指定會計提供者是否應該為用戶啟動或停止會計。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctDelayTime
指定客戶端嘗試傳送目前要求的時間長度。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctInputOctets
指定目前會計會話期間已收到的八進位數。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctOutputOctets
指定目前會計會話期間所傳送的八進位數。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctSessionId
指定值,以啟用記錄檔中相符的開始和停止記錄的識別。 開始和停止記錄會在 ratAcctStatusType 屬性中傳送。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctAuthentic
指定對會計提供者的驗證方式。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctSessionTime
指定目前會計會話中已耗用的秒數。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctInputPackets
指定目前會計會話期間已接收的封包數目。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctOutputPackets
指定目前會計會話期間已傳送的封包數目。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratAcctTerminationCause
指定目前會計會話的終止方式。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2866 。
ratCHAPChallenge
指定 NAS 傳送給 CHAP 使用者的 CHAP 挑戰。 此類型 RADIUS_ATTRIBUTE 中的值欄位是指針。 如需詳細資訊 ,請參閱 RFC 2865 。
ratNASPortType
指定使用者用來連線的埠類型,例如異步、ISDN、虛擬。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊 ,請參閱 RFC 2865 。
ratPortLimit
指定 NAS 應提供給使用者用於多連結工作階段的埠數目。 此類型 RADIUS_ATTRIBUTE 中的值欄位是32位整數值。 如需詳細資訊,請參閱 RFC 2865
ratTunnelType
指定要在通道啟動器) 的情況下 (使用的通道通訊協定或通訊協定,或在通道終止符) 的情況下指定使用 (的通道通訊協定。 如需詳細資訊,請參閱 RFC 2868 。
ratMediumType
指定建立可透過多個傳輸運作之通訊協定的通道時要使用的傳輸媒體,例如 L2TP。 如需詳細資訊,請參閱 RFC 2868 。
ratTunnelPassword
可能包含要用來向遠端伺服器驗證的密碼。 它只能包含在 Access-Accept 封包中。
ratTunnelPrivateGroupID
指定特定通道會話的群組標識碼。
ratNASIPv6Address
指定要求使用者驗證之 NAS 的 IPv6 位址。 在RADIUS伺服器的範圍內,NAS 應該是唯一的。 它只會用於 Access-Request 封包中。 如需詳細資訊,請參閱 RFC 3162 中的 NAS-IPv6-Address 一節。
ratFramedInterfaceId
指定要為用戶設定的 IPv6 介面識別碼。 它可用於 Access-Accept 封包。 如需詳細資訊,請參閱 RFC 3162 中的 Framed-Interface-Id 一節。
ratFramedIPv6Prefix
指定要為用戶設定的 IPv6 前置詞 (和對應的路由) 。 它可以用於 Access-Accept 封包中,而且可以多次出現。 如需詳細資訊,請參閱 RFC 3162 中的 Framed-IPv6-Prefix 一節。
ratLoginIPv6Host
指定包含 ratLoginService 屬性時,用來連接用戶的系統。 它可用於 Access-Accept 封包。 如需詳細資訊,請參閱 RFC 3162 中的 Login-IPv6-Host 一節。
ratFramedIPv6Route
指定要為 NAS 上的使用者設定的路由資訊。 它用於 Access-Accept 封包中,而且可以多次出現。 如需詳細資訊,請參閱 RFC 3162 中的 Framed-IPv6-Route 一節。
ratFramedIPv6Pool
指定指派的集區名稱,該集區應該用來指派使用者的IPv6 前置詞。 如果 NAS 不支援多個前置詞集區,NAS 必須忽略這個屬性。 如需詳細資訊,請參閱 RFC 3162 中的 Framed-IPv6-Pool 一節。
ratCode
指定要求類型代碼。 這是擴充的只讀屬性,僅適用於 RadiusExtensionProcess 和 RadiusExtensionProcessEx函 式。 其內容可以藉由與 RADIUS_CODE 列舉值進行比較來解譯。
ratIdentifier
指定要求識別碼。 這是擴充的唯讀屬性。
ratAuthenticator
指定要求驗證器。 這是擴充的唯讀屬性。
ratSrcIPAddress
指定來源IP位址。 這是擴充的唯讀屬性。
ratSrcPort
指定來源IP埠。 這是擴充的唯讀屬性。
ratProvider
指定驗證提供者。 此屬性的值取自 列舉型別RADIUS_AUTHENTICATION_PROVIDER 。 這是擴充的唯讀屬性。
ratStrippedUserName
指定已移除領域的用戶名稱。 如需詳細資訊 ,請參閱使用者識別屬性 。 這是擴充屬性。
ratFQUserName
指定完整用戶名稱。 如需詳細資訊 ,請參閱使用者識別屬性 。 這是擴充屬性。
ratPolicyName
指定遠端訪問原則名稱。 這是擴充屬性。
ratUniqueId
指定要求的唯一標識碼。 這是唯讀的屬性。
ratExtensionState
這個屬性是用來在延伸模組之間傳遞狀態資訊。
ratEAPTLV
指定 EAP-TLV 封包。 如需 EAP-TLV 封包格式的詳細資訊,請參閱 IETF EAP RFC 3748。
ratRejectReasonCode
指定 RADIUS 拒絕的原因碼。 如需詳細資訊,請參閱 RADIUS_REJECT_REASON_CODE。
ratCRPPolicyName
指定符合此RADIUS封包的連線要求原則名稱。
ratProviderName
指定要求轉送的遠端RADIUS伺服器組名。

如果 ratProvider 所指定的驗證是 Proxy,擴充 DLL 可以變更 ratProviderName ,以指出要求應該轉送至哪個遠端伺服器群組。
ratClearTextPassword
以純文字指定用戶密碼。

為了支援使用PEAP-MSChapv2的授權資料庫,延伸模組 DLL 會從資料庫擷取用戶密碼,並將其傳送至 NPS。
ratSrcIPv6Address
來源 IPv6 位址。 這不是標準RADIUS屬性。 它會對應至內部屬性 IAS_ATTRIBUTE_CLIENT_IPv6_ADDRESS。 這是唯讀的屬性。
ratCertificateThumbprint
指定憑證指紋。 這不是標準RADIUS屬性。 它會對應至內部屬性 IAS_ATTRIBUTE_CERTIFICATE_THUMBPRINT。 這是擴充屬性。

備註

下列屬性是唯讀的。 實作 RadiusExtensionProcess2的 擴充 DLL 無法在包含在 RADIUS_EXTENSION_CONTROL_BLOCK的要求或回應內新增/移除/修改這些屬性。

  • ratCode
  • ratIdentifier
  • ratAuthenticator
  • ratSrcIPAddress
  • ratSrcPort
  • ratProvider
  • ratUniqueId
  • ratSrcIPv6Address

規格需求

需求 值
最低支援的用戶端 都不支援
最低支援的伺服器 Windows Server 2008
標頭 authif.h

另請參閱

關於 NPS 擴充功能

NPS 擴充功能列舉

NPS 擴充功能參考

RADIUS_ATTRIBUTE

RADIUS_AUTHENTICATION_PROVIDER