HoloLens (第 1 代) Basics 100:開始使用 Unity

重要

Mixed Reality Academy 教學課程是設計HoloLens (第 1 代) 、Unity 2017 和Mixed Reality沉浸式頭戴式裝置。 因此,對於仍在尋找這些裝置開發指引的開發人員而言,我們覺得這些教學課程很重要。 這些教學課程不會使用用於HoloLens 2的最新工具組或互動進行更新,而且可能與較新版本的 Unity 不相容。 系統會保留這些資訊,以繼續在支援的裝置上運作。 已針對 HoloLens 2 公佈一系列新的教學課程

本教學課程將逐步引導您建立以 Unity 建置的基本混合實境應用程式。

裝置支援

課程 HoloLens 沉浸式頭戴裝置
MR Basics 100:開始使用 Unity ✔️ ✔️

必要條件

第 1 章 - 建立新的Project

若要使用 Unity 建置應用程式,您必須先建立專案。 此專案會組織成幾個資料夾,其中最重要的就是您的 Assets 資料夾。 這是一個資料夾,其中包含您從數位內容建立工具匯入的所有資產,例如 Maya、Max Animation 4D 或 Photoshop、您使用Visual Studio或您最愛的程式碼編輯器建立的所有程式碼,以及 Unity 在編輯器中撰寫場景、動畫和其他 Unity 資產類型時所建立的任何數量內容檔案。

若要建置和部署 UWP 應用程式,Unity 可以將專案匯出為Visual Studio解決方案,其中包含所有必要的資產和程式碼檔案。

  1. 啟動 Unity
  2. 選取 [新增]
  3. 輸入專案名稱 (例如 「MixedRealityIntroduction」)
  4. 輸入儲存專案的位置
  5. 確定已選取 3D 切換
  6. 選取 [建立專案]

恭喜,您全都是開始進行混合實境自訂的設定。

第 2 章 - 設定相機

Unity 主要相機會處理頭部追蹤和身歷聲轉譯。 對主要相機進行一些變更,以將其與混合實境搭配使用。

  1. 選取 [檔案新場景] >

首先,如果您想像使用者 (X: 0, Y: 0, Z: 0) ,則配置您的應用程式會比較容易。 由於主要相機正在追蹤使用者頭部的移動,因此可以藉由設定主相機的開始位置來設定使用者的開始位置。

  1. [階層]面板中選取[主要相機]
  2. 在 [ 偵測器 ] 面板中,尋找 [轉換 ] 元件,並將 [位置 ] 從 (X: 0, Y: 1, Z: -10) 變更為 (X: 0, Y: 0, Z: 0)

其次,預設的相機背景需要一些想法。

對於HoloLens應用程式,真實世界應該出現在相機呈現的所有專案後面,而不是 Skybox 紋理。

  1. 在 [階層]面板中選取[主要相機] 後,請在 [偵測器] 面板中尋找[相機] 元件,並將 [清除旗標]下拉式清單從[Skybox] 變更為[純色]。
  2. 選取 [背景 色彩選擇器],並將 RGBA 值變更為 (0、0、0、0)

針對以沉浸式頭戴式裝置為目標的混合實境應用程式,我們可以使用 Unity 提供的預設 Skybox 紋理。

  1. 在 [階層] 面板中仍選取[主要相機],在[偵測器] 面板中尋找[相機] 元件,並將[清除旗標]下拉式清單保留為Skybox

第三,讓我們考慮 Unity 中的近裁剪平面,並防止物件在使用者接近物件或物件接近使用者時呈現太接近使用者的眼睛。

對於HoloLens應用程式,可以將接近裁剪平面設定為HoloLens建議的 0.85 公尺。

  1. 在 [階層] 面板中選取[主要相機] 後,請在[偵測器] 面板中尋找[相機] 元件,並將 [近裁剪平面] 欄位從預設0.3變更為建議的 0.85 HoloLens

針對以沉浸式頭戴式裝置為目標的混合實境應用程式,我們可以使用 Unity 提供的預設設定。

  1. 在 [階層]面板中仍選取[主要相機] 後,在 [偵測器] 面板中尋找[相機] 元件,並將 [近裁剪平面] 欄位保留為預設的 0.3

最後,讓我們儲存到目前為止的進度。 若要儲存場景變更,請選取 [ 檔案 > 儲存場景為],將場景命名為 Main,然後選取 [ 儲存]。

第 3 章 - 設定Project 設定

在本章中,我們將設定一些 Unity 專案設定,以協助我們以Windows Holographic SDK 為目標進行開發。 我們也會為應用程式設定一些品質設定。 最後,我們將確保組建目標設定為通用 Windows 平臺。

Unity 效能和品質設定

HoloLens的 Unity 品質設定

Unity quality settings for HoloLens

由於在HoloLens上維持高畫面播放速率十分重要,因此我們想要針對最快效能調整品質設定。 如需更詳細的效能資訊, 請參閱 Unity 的效能建議

  1. 選取[編輯 > Project 設定 > 品質]
  2. 選取通用 Windows 平臺標誌底下的下拉式清單,然後選取[非常低]。 當 [通用 Windows 平臺] 資料行中的方塊和[非常低] 資料列為綠色時,您將知道設定已正確套用。

針對以遮蔽顯示器為目標的混合實境應用程式,您可以將品質設定保留為其預設值。

目標 Windows 10 SDK

目標Windows Holographic SDK

Target Windows Holographic SDK

我們需要讓 Unity 知道我們嘗試匯出的應用程式應該建立 沉浸式檢視 ,而不是 2D 檢視。 我們藉由在以 Windows 10 SDK 為目標的 Unity 上啟用虛擬實境支援來執行此動作。

  1. 移至[編輯 > Project 設定 > 播放機]。
  2. 在 Player 設定的偵測器面板中,選取通用 Windows 平臺圖示。
  3. 展開 [XR 設定] 群組。
  4. 在 [轉譯] 區段中核取 [支援虛擬實境] 核取方塊,以新增 [虛擬實境 SDK] 清單。
  5. 確認 Windows Mixed Reality 出現在清單中。 如果沒有,請選取 + 清單底部的按鈕,然後選擇[Windows Mixed Reality]。

注意

如果您沒有看到通用 Windows 平臺圖示,請仔細檢查以確定您已在安裝期間選取通用 Windows 平臺組建支援。 如果沒有,您可能需要以正確的 Windows 安裝重新安裝 Unity。

在套用所有專案設定時執行絕佳的工作。 接下來,讓我們新增全像投影!

第 4 章 - 建立 Cube

在 Unity 專案中建立 Cube 就像在 Unity 中建立任何其他物件一樣。 將 Cube 放在使用者前面很容易,因為 Unity 的座標系統會對應至真實世界,其中 Unity 中的一個計量大約是真實世界中的一個計量。

  1. 在 [ 階層] 面板的左上角,選取 [ 建立 ] 下拉式清單,然後選擇 [3D 物件 Cube >]。
  2. 在 [階層]面板中選取新建立的Cube
  3. 偵測器 中,尋找 [轉換 ] 元件,並將 [位置 ] 變更為 (X: 0、 Y: 0、 Z: 2) 。 這會將 Cube 2 公尺放在使用者開始位置前方。
  4. [轉換 ] 元件中,將 [旋轉] 變更為 (X: 45、 Y:45、 Z: 45) ,並將 [縮放比例 ] 變更為 [ (X: 0.25、 Y:0.25、 Z:0.25) 。 這會將 Cube 調整為 0.25 公尺。
  5. 若要儲存場景變更,請選取 [ 檔案 > 儲存場景]。

第 5 章 - 從 Unity 編輯器驗證裝置

既然我們已建立 Cube,現在可以在裝置中快速簽入。 您可以從 Unity 編輯器中直接執行這項操作。

初始設定

  1. 在您的開發電腦上,于 Unity 中,開啟 [檔案 > 建置設定] 視窗。
  2. [平臺] 變更為[通用 Windows 平臺],然後按一下 [切換平臺]

針對HoloLens使用 Unity 遠端處理

  1. 在您的HoloLens上安裝並執行全像攝影遠端播放程式,可從Windows市集取得。 在裝置上啟動應用程式,它會進入等候狀態,並顯示裝置的 IP 位址。 記下 IP。
  2. 開啟 視窗 > XR > 全像攝影模擬
  3. 模擬模式[無 ] 變更 為 [遠端] 變更為 [裝置]。
  4. [遠端電腦] 中,輸入您稍早記下HoloLens的 IP 位址。
  5. 按一下 [ 連接]。
  6. 確定 [ 線上狀態 ] 變更為綠色 [已連線]。
  7. 現在,您可以在 Unity 編輯器中按一下 [播放 ]。

您現在可以在裝置和編輯器中看到 Cube。 您可以暫停、檢查物件和偵錯,就像您在編輯器中執行應用程式一樣,因為這基本上是發生什麼事,但視訊、音訊和裝置輸入會在主機電腦與裝置之間的網路之間來回傳輸。

針對其他混合實境支援的頭戴式裝置

  1. 使用 USB 纜線和 HDMI 或顯示埠纜線,將頭戴式裝置連線到您的開發電腦。
  2. 啟動Mixed Reality入口網站,並確定您已完成第一次執行體驗。
  3. 您現在可以從 Unity 按 [播放] 按鈕。

您現在可以在混合實境頭戴式裝置和編輯器中看到 Cube 轉譯。

第 6 章 - 從 Visual Studio 建置並部署至裝置

我們現在已準備好編譯專案,以Visual Studio並部署至目標裝置。

匯出至Visual Studio解決方案

  1. 開啟[檔案 > 建置設定] 視窗。
  2. 按一下 [新增開啟場景 ] 以新增場景。
  3. [平臺] 變更為 [通用 Windows 平臺],然後按一下 [切換平臺]。
  4. 通用 Windows 平臺設定中,確定SDK通用 10
  5. 針對 [目標裝置],將 [任何裝置] 保留為 [遮蔽顯示] 或切換至[HoloLens]。
  6. UWP 組建類型 應該是 D3D
  7. UWP SDK 可以在 [最新] 安裝時保留。
  8. 按一下 [建置]
  9. 在檔案總管中,按一下 [新增資料夾],並將資料夾命名為「App」。
  10. 選取 [ 應用程式 ] 資料夾後,按一下 [ 選取資料夾 ] 按鈕。
  11. 當 Unity 建置完成時,會出現Windows 檔案總管視窗。
  12. 在檔案總管中開啟 [應用程式 ] 資料夾。
  13. 在此範例中開啟產生的Visual Studio解決方案 (MixedRealityIntroduction.sln)

編譯Visual Studio解決方案

最後,我們將編譯匯出的Visual Studio解決方案、部署解決方案,並在裝置上試用。

  1. 使用Visual Studio中的頂端工具列,將目標從 [錯] 變更為[發行],並將目標從ARM變更為X86

部署至裝置與模擬器的指示不同。 請遵循符合您設定的指示。

透過 Wi-Fi 部署至混合實境裝置

  1. 按一下 [ 本機電腦] 按鈕旁的箭號,並將部署目標變更為 [遠端電腦]。
  2. 輸入混合實境裝置的 IP 位址,並將驗證模式變更為通用 (未加密的通訊協定) ,以供其他裝置使用HoloLens和Windows
  3. 按一下 [ 偵錯 > 開始但不偵錯]。

針對HoloLens,如果這是第一次部署至您的裝置,您必須使用 Visual Studio 進行配對

透過 USB 部署至混合實境裝置

確定您裝置已透過 USB 纜線插入。

  1. 針對 HoloLens,按一下 [本機電腦] 按鈕旁的箭號,然後將部署目標變更為[裝置]。
  2. 若要將附加至電腦的遮蔽裝置設為目標,請將設定保留為 [本機電腦]。 請確定您有Mixed Reality入口網站正在執行。
  3. 按一下 [ 偵錯 > 開始但不偵錯]。

部署至 Emulator

  1. 按一下 [裝置] 按鈕旁的箭號,然後從下拉式清單中選取[HoloLens Emulator]。
  2. 按一下 [ 偵錯 > 開始但不偵錯]。

試用您的應用程式

現在已部署您的應用程式,請嘗試移動 Cube,並觀察它位於您前面的世界。

另請參閱