قم بتكوين BFD عبر ExpressRoute

تدعم ExpressRoute الكشف عن إعادة التوجيه ثنائي الاتجاه (BFD) عبر الإقران الخاص وإقران Microsoft. عند تمكين الكشف عن إعادة التوجيه ثنائي الاتجاه عبر ExpressRoute، يمكنك تسريع الكشف عن فشل الارتباط بين أجهزة Microsoft Enterprise edge (MSEE) وأجهزة التوجيه المكونة لدائرة ExpressRoute (CE/PE) الخاصة بك. يمكنك تكوين ExpressRoute عبر أجهزة توجيه الحافة أو أجهزة التوجيه Partner Edge (إذا اخترت خدمة الاتصال المُدارة من الطبقة 3). يرشدك هذا المستند إلى دواعي الحاجة إلى BFD وكيفية تمكين BFD عبر ExpressRoute.

الحاجة إلى BFD

يوضح الرسم البياني التالي فائدة تمكين BFD عبر دائرة ExpressRoute: 1

يمكنك تمكين دائرة ExpressRoute إما عن طريق اتصالات الطبقة 2 وإما الاتصالات المُدارة من الطبقة 3. في الحالتين كلتيهما، إذا كان هناك أكثر من جهاز واحد من الطبقة 2 في مسار اتصال ExpressRoute، فإن مسؤولية اكتشاف أي فشل في الارتباط داخل المسار تقع على عاتق جلسة BGP التي تغطيها.

في أجهزة MSEE، يتم عادةً تكوين وقت الاستمرار ووقت الانتظار لـ BGP لمدة 60 و180 ثانية على التوالي. لهذا السبب، عند حدوث فشل في الارتباط، قد يستغرق الأمر ما يصل إلى ثلاث دقائق لكشف أي فشل في الارتباط وتحويل نسبة استخدام الشبكة إلى اتصال بديل.

يمكنك التحكم في مؤقّتات BGP عن طريق تكوين وقت استمرار BGP ووقت انتظار أقل على جهاز إقران الحافة الخاص بك. إذا لم تكن مؤقتات BGP هي نفسها بين الجهازين النظيرين فسيتم إنشاء جلسة BGP باستخدام قيمة الوقت الأقل. يمكن ضبط وقت استمرار BGP بصورة منخفضة تصل إلى ثلاث ثوانٍ، ووقت انتظار منخفض بصل إلى 10 ثوانٍ. ومع ذلك، لا يوصى بتعيين مؤقت BGP دقيق لأن البروتوكول عملية مركزة.

في هذا السيناريو، يمكن للكشف عن إعادة التوجيه ثنائي الاتجاه أن يساعد. يوفر BFD كشف فشل الارتباط منخفض الحمل في فاصل زمني ثانوي.

ملاحظة

يوفر BFD وقتاً أسرع لتجاوز الفشل عند اكتشاف فشل الارتباط، ولكن التقارب العام للاتصال سيستغرق ما يصل إلى دقيقة لتجاوز الفشل بين بوابات شبكة ExpressRoute الظاهرية وMSEEs.

تمكين الكشف عن إعادة التوجيه ثنائي الاتجاه

يتم تكوين BFD افتراضيًا ضمن جميع واجهات ExpressRoute الخاصة وواجهات التناظر الخاصة بـ Microsoft التي تم إنشاؤها حديثًا على MSEEs. على هذا النحو، لتمكين الكشف عن إعادة التوجيه ثنائي الاتجاه، تحتاج فقط إلى تكوينه على كل من الأجهزة الأساسية والثانوية. يُعد تكوين الكشف عن إعادة التوجيه ثنائي الاتجاه عملية تتكون من خطوتين. قم بتكوين الكشف عن إعادة التوجيه ثنائي الاتجاه على الواجهة ثم ربطه بجلسة BGP.

موضح أدناه مثال لتكوين CE / PE (باستخدام Cisco IOS XE).

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

ملاحظة

لتمكين BFD ضمن نظير موجود بالفعل أو من Microsoft، ستحتاج إلى إعادة تعيين النظير. يجب القيام بذلك على الدوائر المكونة مع التناظر الخاص قبل أغسطس 2018 ونظير Microsoft قبل يناير 2020. راجع إعادة تعيين نظراء ExpressRoute

مفاوضة مؤقت BFD

بين نظراء BFD، يحدد الأبطأ من بين النظيرين معدل الإرسال. ويتم تعيين فترات الإرسال / الاستقبال لـ MSEEs BFD على 300 مللي ثانية. وفي سيناريوهات محددة، قد يتم تعيين الفاصل الزمني بقيمة أعلى تبلغ 750 مللي ثانية. من خلال تكوين قيمة أعلى، يمكنك إجبار هذه الفواصل الزمنية على أن تكون أطول ولكن لا يمكن جعلها أقصر.

ملاحظة

إذا قمت بتكوين دوائر ExpressRoute الزائدة عن الحاجة الجغرافية أو استخدمت اتصال Site-to-Site IPSec VPN كنسخة احتياطية. قد يساعد تمكين BFD في تجاوز الفشل بشكل أسرع بعد فشل اتصال ExpressRoute.

الخطوات التالية

لمزيد من المعلومات أو المساعدة، راجع الروابط التالية: