Comparteix a través de


Solución de problemas del código de error "PublicIPCountLimitReached"

En este artículo se describe cómo identificar y resolver el error "PublicIPCountLimitReached" que se produce al intentar actualizar un clúster de Azure Kubernetes Service (AKS).

Requisitos previos

Este artículo requiere la versión 2.0.65 de la CLI de Azure o una versión posterior. Para buscar el número de versión, ejecute az --version. Si tiene que instalar o actualizar la CLI de Azure, consulte Instalación de la CLI de Azure.

Para obtener información más detallada sobre el proceso de actualización, consulte la sección "Actualizar un clúster de AKS" en Actualización de un clúster de Azure Kubernetes Service (AKS).

Síntomas

Se produce un error en una actualización del clúster de AKS y recibe un mensaje de error "PublicIPCountLimitReached".

Causa

El error se produce si ha alcanzado el número máximo de direcciones IP públicas permitidas para la suscripción.

Solución

Para aumentar el límite o la cuota de la suscripción, vaya al Azure Portal, registre un vale de soporte técnico de límites de servicio y suscripción (cuotas) y establezca el tipo de cuota en Redes.

Una vez que el cambio de cuota surte efecto, intente actualizar el clúster a la misma versión a la que intentó actualizar anteriormente. Este proceso desencadenará una conciliación.

az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>

Ponte en contacto con nosotros para obtener ayuda

Si tiene preguntas o necesita ayuda, cree una solicitud de soporte o busque consejo en la comunidad de Azure. También puede enviar comentarios sobre el producto con los comentarios de la comunidad de Azure.