Poznámka:
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Do Reporting Services stránkovaných sestav můžete přidat parametry pomocí Report Builder v SQL Server Reporting Services (SSRS), aby čtenáři sestav mohli filtrovat data pro konkrétní hodnoty. Parametry sestavy se vytvoří automaticky pro každý parametr dotazu, který zahrnete v dotazu datové sady. Datový typ parametru určuje, jak bude vypadat na panelu nástrojů zobrazení sestavy.
Následující obrázek znázorňuje stránkovanou sestavu s daty filtrovanými podle vybraných parametrů:
V tomto kurzu se naučíte:
- Vytvoření stránkovaného reportu s vloženým zdrojem dat a dotazem
- Použití parametrů dotazu k vytvoření parametrů sestavy a konfiguraci vlastností
- Práce s datovými sadami k řízení viditelných dat pro parametry sestavy
- Definování výchozích hodnot a vlastních hodnot pro parametry
Odhadovaná doba dokončení tohoto kurzu je 25 minut.
Poznámka:
Následující postupy obsahují stručné pokyny pro práci s Report Builder. V některých případech se několik akcí průvodce konsoliduje do jednoho kroku. Podrobné pokyny krok za krokem se snímky obrazovky najdete v tématu Tutorial: Vytvoření základního tabulkového reportu (Report Builder). Článek popisuje, jak přejít na server sestav, vybrat zdroj dat, vytvořit datovou sadu a další.
Předpoklady
Informace o požadavcích najdete v tématu Prerequisites for tutorials (Report Builder).
Vytvořte sestavu pomocí Průvodce tabulkou nebo maticí
Pokud chcete vytvořit stránkovanou (maticovou) sestavu pomocí Průvodce tabulkou nebo maticí, postupujte takto:
Startujte Report Builder z počítače, webového portálu Reporting Services nebo SharePoint integrovaného režimu.
Otevře se dialogové okno Nová sestava nebo datová sada . Pokud se dialogové okno neotevře, vyberte Nový soubor>.
Vyberte kartu Nová sestava a v pravém podokně vyberte Průvodce tabulkou nebo maticí.
Na stránce Zvolit datovou sadu vyberte možnost Vytvořit datovou sadu a pak vyberte Další.
Na stránce Zvolit připojení ke zdroji dat vyberte zdroj dat. Zdroj dat můžete vybrat z rozevíracího seznamu, nebo přejděte na server reportů a vyberte zdroj. Zdroj dat musí být typu SQL Server.
Na kartě Obecné vyberte Test připojení a ověřte, že se můžete připojit ke zdroji dat.
Měli byste vidět vyskakovací okno: "Připojení bylo úspěšně vytvořeno." Vyberte OK k zavření vyskakovacího okna.
Chcete-li dokončit nastavení zdroje dat, vyberte OK a pak vyberte Další.
Na stránce Návrh dotazu vyberte Upravit jako text.
V dialogovém okně Query Designer vložte do horního pole následující dotaz Transact-SQL:
;WITH CTE (StoreID, Subcategory, Quantity) AS ( SELECT 200 AS StoreID, 'Digital SLR Cameras' AS Subcategory, 2002 AS Quantity UNION SELECT 200 AS StoreID, 'Camcorders' AS Subcategory, 1954 AS Quantity UNION SELECT 200 AS StoreID, 'Accessories' AS Subcategory, 1895 AS Quantity UNION SELECT 199 AS StoreID, 'Digital Cameras' AS Subcategory, 1849 AS Quantity UNION SELECT 306 AS StoreID, 'Digital SLR Cameras' AS Subcategory, 1579 AS Quantity UNION SELECT 306 AS StoreID, 'Camcorders' AS Subcategory, 1561 AS Quantity UNION SELECT 306 AS StoreID, 'Digital Cameras' AS Subcategory, 1553 AS Quantity UNION SELECT 306 AS StoreID, 'Accessories' AS Subcategory, 1534 AS Quantity UNION SELECT 307 AS StoreID, 'Accessories' AS Subcategory, 1755 AS Quantity UNION SELECT 307 AS StoreID, 'Camcorders' AS Subcategory, 1631 AS Quantity UNION SELECT 307 AS StoreID, 'Digital SLR Cameras' AS Subcategory, 1772 AS Quantity) SELECT StoreID, Subcategory, Quantity FROM CTETento dotaz kombinuje výsledky několika příkazů Transact-SQL SELECT uvnitř společného výrazu tabulky. Výraz určuje hodnoty založené na zjednodušených prodejních datech pro kamery z ukázkové databáze Contoso. Podkategorie jsou digitální fotoaparáty, digitální zrcadlové reflexní kamery (SLR), videokamery a příslušenství.
Na panelu nástrojů Návrhář dotazů vyberte Spustit (!).
Dotaz se spustí a zobrazí sadu výsledků pro pole StoreID, Subcategory a Quantity.
Sada výsledků se skládá z 11 řádků dat, které zobrazují množství položek prodaných pro každou podkategorii pro čtyři obchody. Název obchodu není součástí sady výsledků. Později v tomto kurzu vyhledáte název úložiště, který odpovídá identifikátoru úložiště z samostatné datové sady.
Tento dotaz neobsahuje parametry dotazu. Parametry dotazu přidáte později v tomto kurzu.
Chcete-li pokračovat v průvodci, vyberte Další.
Naformátujte rozložení sestavy a přidejte součty
Průvodce poskytuje počáteční návrh pro zobrazení dat v sestavě. V následujícím postupu uspořádáte hodnoty Prodané množství v řádcích seskupených podle podkategorie s jedním sloupcem pro každé ID obchodu. Podokno náhledu vám pomůže před dokončením návrhu sestavy vizualizovat výsledek seskupování dat.
Uspořádání dat tabulky do skupin na stránce Uspořádat pole :
Z pole Dostupná pole přetáhněte pole Podkategorie do pole Skupiny řádků .
Přetáhněte pole StoreID do pole Skupiny sloupců .
Přetáhněte pole Množství do pole Hodnoty .
Funkce Sum automaticky agreguje data Množství, což je výchozí agregace číselných polí. Hodnota je
[Sum(Quantity)].Chcete-li pokračovat v průvodci, vyberte Další.
Na stránce Zvolit rozložení v části Možnosti vyberte možnost Zobrazit mezisoučty a celkové součty .
Při spuštění sestavy se v posledním sloupci zobrazí celkové množství jednotlivých podkategorií pro všechna úložiště (StoreID). Poslední řádek zobrazuje celkové množství pro všechny podkategorie pro každý obchod (StoreID).
Klikněte na Další pro kontrolu tabulky v podokně Náhled. Při spuštění sestavy byste měli vidět tři řádky, které ukazují rozložení tabulky:
První řádek se jednou opakuje, aby se v tabulce zobrazily záhlaví sloupců.
Druhý řádek se opakuje jednou pro každé ID obchodu, aby se zobrazilo množství prodaných položek a množství pro každou podkategorii.
Třetí řádek se jednou opakuje, aby se zobrazilo celkové množství prodaných položek a celkové množství podle podkategorie pro všechny obchody.
Vyberte Dokončit.
Report Builder přidá matici na návrhovou plochu. Tabulka obsahuje tři řádky a tři sloupce: Podkategorie, [StoreID] a Total.
Zvětšete šířku tabulky, aby se data podkategorie zobrazovala na jednom řádku v sestavě:
Na návrhové ploše vyberte v matici, aby se zobrazily úchyty řádků a sloupců. Úchyty se zobrazují jako šedé pruhy podél okrajů tabulky.
Najeďte myší na čáru mezi sloupci Subcategory a StoredID a zobrazte kurzor dvojité šipky.
Výběrem a přetažením čáry zvětšíte šířku sloupce Podkategorie:
Na kartě Domů vyberte Spustit a zobrazte náhled sestavy.
Sestava se spustí na serveru sestav a zobrazí čas, kdy došlo ke zpracování sestavy:
V aktuálním návrhu matice zobrazují záhlaví sloupců identifikátor úložiště, ale ne název úložiště. Později přidáte výraz, který vyhledá název obchodu v datové sadě, jež obsahuje páry identifikátorů obchodů a názvů obchodů.
Vytvořte parametry dotazu, parametry sestavy a nakonfigurujte vlastnosti
V Návrháři dotazů můžete upravit dotaz a přidat parametry. Když přidáte parametr dotazu, Report Builder automaticky vytvoří do sestavy parametr s jednou hodnotou. Každý parametr má několik vlastností s výchozími hodnotami, jako je název, výzva a datový typ. Tyto vlastnosti můžete nakonfigurovat podle požadavků na sestavu.
Přidat parametry dotazu a vytvořit parametry sestavy
Když do dotazu přidáte parametr dotazu, Report Builder automaticky vytvoří jednohodnotový parametr sestavy s výchozími vlastnostmi pro název, text výzvy a datový typ.
Pokud chcete přidat parametr dotazu, postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V podokně Data sestavy rozbalte složku Datové sady . Klikněte pravým tlačítkem myši na DataSet1 a pak vyberte Dotaz.
Otevře se dialogové okno Návrhář dotazů . Existující dotaz se zobrazí v horním poli dialogového okna.
Použijte oddělovač mezi dvěma poli v dialogovém okně a zvětšete velikost horního pole.
Posuňte se dolů v horním poli, aby byl vidět poslední řádek dotazu.
Výběrem klávesy Enter přidejte nový řádek na konec dotazu.
Do posledního řádku dotazu vložte následující klauzuli Transact-SQL
WHERE:WHERE StoreID = (@StoreID)Klauzule
WHEREomezuje načtená data na identifikátor úložiště určený parametrem\@StoreIDdotazu .Na panelu nástrojů Návrhář dotazů vyberte Spustit (!).
Otevře se dialogové okno Definovat parametry dotazu a zobrazí výzvu k zadání hodnoty parametru
\@StoreIDdotazu .Tip
Pokud nevidíte celé buňky tabulky a záhlaví sloupců, zvětšete velikost dialogového okna.
Do pole Hodnota parametru zadejte 200 a pak vyberte OK:
Sada výsledků zobrazí množství prodané pro příslušenství, videokamery a digitální SLR kamery pro identifikátor obchodu 200.
Výběrem možnosti OK zavřete Návrháře dotazů.
V podokně Data sestavy rozbalte uzel Parametry :
Uzel teď obsahuje parametr sestavy s názvem StoreID. Když vyberete parametr, vlastnosti parametru se zobrazí v podokně Parametry na návrhové ploše. Toto podokno můžete použít k formátování rozložení parametrů sestavy.
Tip
Pokud podokno Parametry není viditelné, zaškrtněte políčko Zobrazit a zaškrtněte políčko Parametry .
Aktualizace vlastností parametrů sestavy
Po vytvoření parametrů sestavy můžete upravit hodnoty vlastností těchto parametrů. V příkladu kurzu má parametr sestavy StoreID výchozí datový typ Text. Vzhledem k tomu, že identifikátor úložiště je celé číslo, můžete změnit datový typ na Integer.
Pro změnu datového typu parametru sestavy postupujte podle těchto kroků:
V podokně Data sestavy v uzlu Parametry klikněte pravým tlačítkem myši na parametr StoreID a pak vyberte Vlastnosti parametru.
V dialogovém okně Vlastnosti parametru sestavy nakonfigurujte na kartě Obecné následující vlastnosti:
Výzva: Zadejte identifikátor úložiště?. Tato výzva se zobrazí na panelu nástrojů Prohlížeče sestav při spuštění sestavy.
Datový typ: V rozevíracím seznamu vyberte celé číslo . Toto nastavení nakonfiguruje datový typ pro vstup povolený na příkazovém řádku.
Ostatní vlastnosti a možnosti můžete ponechat beze změny.
Výběrem OK použijte změny.
Vyberte Spustit pro zobrazení náhledu sestavy. Prohlížeč sestav teď zobrazuje výzvu Identifikátor úložiště? jako hodnotu parametru StoreID.
Na panelu nástrojů Prohlížeč sestav u výzvy identifikátor obchodu? zadejte 200 a poté vyberte Zobrazit sestavu:
Použití datových sad k zadání hodnot
Čtenářům sestavy můžete zajistit, aby zadávali pouze platné hodnoty parametru tím, že jim nabídnete rozevírací seznam možných hodnot. Sada hodnot může pocházet z datové sady nebo ze seznamu, který zadáte. Dostupné hodnoty musí být zadané z datové sady s dotazem, který neobsahuje odkaz na parametr.
Vytvoření datové sady pro platné hodnoty parametrů
Pokud chcete vytvořit datovou sadu se seznamem platných hodnot pro parametr, postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V podokně Data sestavy klikněte pravým tlačítkem myši na uzel Datové sady a zvolte možnost Přidat datovou sadu.
V dialogovém okně Vlastnosti datové sady nakonfigurujte následující vlastnosti a možnosti:
Jako vlastnost Name zadejte Stores.
Vyberte možnost Použít datovou sadu vloženou do mé sestavy.
Rozbalte rozevírací seznam Zdroje dat a vyberte zdroj dat uvedený dříve v tomto kurzu.
U vlastnosti Typ dotazu ověřte, zda je vybrána možnost Text .
Do pole Dotaz vložte následující dotaz:
SELECT 200 AS StoreID, 'Contoso Catalog Store' as StoreName UNION SELECT 199 AS StoreID, 'Contoso North America Online Store' as StoreName UNION SELECT 307 AS StoreID, 'Contoso Asia Online Store' as StoreName UNION SELECT 306 AS StoreID, 'Contoso Europe Online Store' as StoreName
Výběrem OK použijte změny.
Podokno Data sestavy přidá pod uzel Datové sady datovou sadu Stores s vlastnostmi StoreID a StoreName.
Zadání seznamu dostupných hodnot
Jakmile budete mít datovou sadu s dostupnými hodnotami, můžete aktualizovat vlastnosti sestavy, abyste identifikovali datovou sadu a vlastnost a naplnili seznam dostupných hodnot na panelu nástrojů Prohlížeče sestav .
Zadejte dostupné hodnoty parametru z datové sady pomocí následujícího postupu:
V podokně Data sestavy v uzlu Parametry klikněte pravým tlačítkem myši na parametr StoreID a pak vyberte Vlastnosti parametru.
V dialogovém okně Vlastnosti parametru sestavy nakonfigurujte na kartě Dostupné hodnoty následující vlastnosti:
Vyberte možnost Získat hodnoty z dotazu .
U vlastnosti Dataset (Datová sada) vyberte Stores (Obchody ) z rozevíracího seznamu.
U vlastnosti Pole Hodnota vyberte v rozevíracím seznamu StoreID .
U vlastnosti pole Štítek vyberte StoreName z rozevíracího seznamu. Pole popisku určuje zobrazovaný název hodnoty.
Přepněte na kartu Obecné a změňte výzvu na název obchodu:.
Výběrem OK použijte změny.
Čtenáři sestav si teď vybírají ze seznamu názvů obchodů místo identifikátorů obchodů. Datový typ parametru zůstává celé číslo , protože parametr je založený na identifikátoru úložiště, nikoli na názvu úložiště.
Vyberte Spustit pro zobrazení náhledu sestavy. Prohlížeč sestavy nyní zobrazuje výzvu Název prodejny: jako hodnotu parametru StoreID.
Na panelu nástrojů Prohlížeč sestav teď výzva zobrazí rozevírací seznam s počáteční hodnotou Vybrat hodnotu:
V rozevíracím seznamu vyberte Úložiště katalogu Contoso, a potom vyberte Zobrazit sestavu.
Sestava zobrazí množství prodané z příslušenství, videokamer a digitálních zrcadlovek pro obchod s názvem pro zobrazení Contoso Catalog Store, který odpovídá identifikátoru obchodu 200.
Vyhledání párů název/hodnota v datových sadách
Datová sada může obsahovat parametr identifikátoru i odpovídající parametr názvu. Pokud máte jenom hodnotu identifikátoru, můžete vyhledat odpovídající název v datové sadě. Pro tento přístup potřebujete datovou sadu, kterou jste vytvořili, která obsahuje páry název/hodnota.
Pokud chcete vyhledat hodnotu názvu z datové sady, postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
Na návrhové ploše klikněte v řádku záhlaví sloupce v matici pravým tlačítkem myši na
[StoreID]parametr a pak vyberte Výraz.V dialogovém okně Výraz nakonfigurujte následující vlastnosti:
Ve vstupním poli nastavení výrazu pro: Hodnota nahoře odstraňte veškerý text.
V poli Kategorie rozbalte uzel Společné funkce a vyberte Různé. Pole Položka se aktualizuje, aby se zobrazila sada funkcí.
V poli Položka poklikejte na Vyhledat. Horní pole se aktualizuje, aby se zobrazil výraz
=Lookup(. Pole Příklad ukazuje příkladLookupsyntaxe funkce.Do horního pole vložte následující výraz:
=Lookup(Fields!StoreID.Value,Fields!StoreID.Value,Fields!StoreName.Value,"Stores")Funkce
Lookuppřebírá hodnotu parametru sestavy StoreID, vyhledá ji v datové sadě Stores a vrátí hodnotu parametru StoreName.
Výběrem OK použijte změny.
Záhlaví sloupce se změní na komplexní výraz <<Expr>>.
Vyberte Spustit pro zobrazení náhledu sestavy.
V náhledu sestavy nyní záhlaví každého sloupce zobrazuje název prodejny místo identifikátoru prodejny.
Konfigurace výchozích a vlastních hodnot
Výchozí hodnoty parametrů sestavy můžete nakonfigurovat tak, aby se sestava spouštěla automaticky bez výzvy čtenáře k zadání vstupu. Výchozí hodnotu parametru lze vybrat z existujícího seznamu hodnot nebo můžete zadat vlastní hodnotu.
Zadání výchozí hodnoty z datové sady
Při konfiguraci výchozích hodnot pomocí datové sady postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V podokně Data sestavy v uzlu Parametry klikněte pravým tlačítkem myši na parametr StoreID a pak vyberte Vlastnosti parametru.
V dialogovém okně Vlastnosti parametru sestavy nakonfigurujte na kartě Výchozí hodnoty následující vlastnosti:
Vyberte možnost Získat hodnoty z dotazu .
U vlastnosti Dataset (Datová sada) vyberte Stores (Obchody ) z rozevíracího seznamu.
U vlastnosti Pole Hodnota vyberte v rozevíracím seznamu StoreID .
Výběrem OK použijte změny.
Vyberte Spustit pro zobrazení náhledu sestavy.
Sestava teď zobrazuje ve výchozím nastavení hodnotu výzvy Contoso North America Online Store, protože se jedná o první hodnotu v sadě výsledků pro datovou sadu Stores. V sestavě se zobrazí prodávané množství digitálních fotoaparátů pro identifikátor obchodu 199, který odpovídá zobrazovanému názvu obchodu Contoso North America Online Store.
Zadání vlastní výchozí hodnoty
Můžete také zadat vlastní hodnotu, kterou chcete použít jako výchozí hodnotu parametru:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V podokně Data sestavy v uzlu Parametry klikněte pravým tlačítkem myši na parametr StoreID a pak vyberte Vlastnosti parametru.
V dialogovém okně Vlastnosti parametru sestavy nakonfigurujte na kartě Výchozí hodnoty následující vlastnosti:
Vyberte možnost Zadat hodnoty a pak vyberte Přidat. Do pole Hodnota se přidá nový řádek hodnoty . Výchozí hodnota v rozevíracím seznamu je (Null).
V rozbalovacím seznamu zadejte číslo 200.
Výběrem OK použijte změny.
Vyberte Spustit pro zobrazení náhledu sestavy.
Sestava teď zobrazuje hodnotu parametru Contoso Catalog Store, protože je to zobrazovací název pro identifikační číslo obchodu 200. Report zobrazuje množství prodané pro příslušenství, videokamery a digitální SLR kamery pro identifikátor obchodu 200.
Vylepšení sestavy pomocí parametrů
Existuje mnoho způsobů, jak můžete pracovat s parametry sestavy a vylepšit tak sestavu. Následující části popisují několik technik přizpůsobení:
- Identifikace parametrů aktuálně vybraných čtenářem sestavy
- Povolit čtenářům sestavy filtrovat data sestavy
- Podporujte parametry s více hodnotami ve své sestavě
- Přidejte boolovské parametry pro podmíněnou viditelnost dat sestavy
Zobrazení parametrů vybraných pro čtenáře
Když mají čtenáři sestavy otázky týkající se sestavy, je užitečné znát jejich aktuální výběr parametrů. Můžete zachovat hodnoty, které uživatel vybral, u každého parametru v sestavě. Jedním z přístupů je zobrazení parametrů v textovém poli v zápatí stránky.
Pokud chcete zobrazit vybranou hodnotu parametru s popiskem v zápatí stránky, postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
Klikněte pravým tlačítkem myši na zápatí stránky, vyberte Vložit a pak vyberte Textové pole:
Přetáhněte textové pole vedle textového pole s časovým razítkem. Použijte boční úchyt textového pole a rozbalte šířku.
V podokně Data sestavy přetáhněte v uzlu Parametry parametr StoreID do textového pole na zápatí stránky. Textové pole se aktualizuje, aby se zobrazila
[@StoreID]hodnota.Aktualizujte textové pole a přidejte popisek pro hodnotu parametru:
Vyberte v textovém poli, dokud se kurzor nevloží za existujícím výrazem, a pak zadejte mezeru.
Přetáhněte další kopii parametru StoreID z podokna Data sestavy do textového pole. Textové pole se aktualizuje, aby se zobrazilo
[@StoreID] [@StoreID].V textovém poli klikněte pravým tlačítkem myši na první
[StoreID]parametr a pak vyberte Výraz.V dialogovém okně Výraz aktualizujte výraz v poli Nastavit výraz pro: Hodnota v horní části. Nahraďte text
ValuetextemLabel.
Výběrem OK použijte změny.
Textové pole se aktualizuje, aby se zobrazilo
[@StoreID.Label] [@StoreID].Vyberte Spustit pro zobrazení náhledu sestavy.
Sestava teď zobrazuje název a identifikátor vybraného obchodu v zápatí stránky spolu s informacemi o časovém razítku.
Filtrování dat sestavy pomocí parametrů
Filtry pomáhají určit, která data se použijí v sestavě poté, co přijdou z externího zdroje dat. Pokud chcete čtenářům umožnit kontrolu nad daty, která vidí v sestavě, můžete do filtru pro matici zahrnout parametr sestavy.
V maticovém filtru zadejte parametr pomocí těchto kroků:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V matici sestavy klikněte pravým tlačítkem myši na záhlaví sloupce a pak vyberte vlastnosti objektu Tablix.
V dialogovém okně Vlastnosti tablix vyberte kartu Filtry a pak zvolte Přidat. Zobrazí se nový řádek filtru.
Pro vlastnost Expression vyberte datovou sadu StoreID z rozevíracího seznamu. Pole typu dat zobrazuje Integer. Pokud je hodnota výrazu pole datové sady, datový typ se nastaví automaticky.
U vlastnosti Operátor ověřte, zda je vybrán symbol rovná se (=).
Do vlastnosti Value zadejte [@StoreID].
[@StoreID]je jednoduchá syntaxe, která představuje delší výraz=Parameters!StoreID.Value.
Výběrem OK použijte změny.
Vyberte Spustit pro zobrazení náhledu sestavy.
Sestava zobrazuje data jenom pro úložiště katalogu Společnosti Contoso.
Na panelu nástrojů v Prohlížeči sestav v výzvě 'Název obchodu' vyberte Contoso Asia Online Store a pak zvolte Zobrazit sestavu.
Matice zobrazí data odpovídající vybranému úložišti.
Použití parametrů s více hodnotami
Parametr s více hodnotami je pole hodnot. V dotazu datové sady musí syntaxe dotazu testovat zahrnutí jedné hodnoty do sady hodnot. Ve výrazu sestavy musí syntaxe přistupovat k poli hodnot namísto k jednotlivé hodnotě.
Pokud změníte parametr z jedné hodnoty na více hodnot, musíte také změnit dotaz a všechny výrazy, které obsahují odkaz na parametr, včetně filtrů.
Pokud chcete změnit existující parametr s jednou hodnotou tak, aby podporoval více hodnot, postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V podokně Data sestavy v uzlu Parametry klikněte pravým tlačítkem myši na parametr StoreID a pak vyberte Vlastnosti parametru.
Na kartě Obecné vyberte možnost Povolit více hodnot a vyberte OK.
Aktualizujte dotaz tak, aby správně zpracovával hodnoty:
V podokně Data sestavy klikněte v uzlu Datové sady pravým tlačítkem myši na datovou sadu DataSet1 a pak vyberte Dotaz.
V dialogovém okně Návrhář dotazů se posuňte do dolní části dotazu v horním poli.
V klauzuli Transact-SQL
WHEREv posledním řádku dotazu změňte symbol equals (=) naIN:WHERE StoreID IN (@StoreID)Operátor
INtestuje hodnotu pro zahrnutí do sady hodnot.Vyberte OK pro použití změn.
Aktualizujte filtr parametrů tak, aby správně zpracovával více hodnot:
V matici sestavy klikněte pravým tlačítkem myši na záhlaví sloupce a pak vyberte vlastnosti objektu Tablix.
V dialogovém okně Vlastnosti tablix vyberte kartu Filtry .
U vlastnosti Operátor vyberte z rozevíracího seznamu In.
Vyberte OK pro použití změn.
Aktualizujte zápatí stránky, aby se správně zobrazila data parametrů s více hodnotami:
V zápatí stránky v matici vyberte textové pole, které zobrazuje parametr.
Odstraní veškerý text v textovém poli.
Klikněte pravým tlačítkem myši na textové pole a vyberte Výraz.
V dialogovém okně Výraz vložte do horního pole následující výraz:
=Join(Parameters!StoreID.Label, ", ")Tento výraz zřetězí všechny názvy úložiště, které uživatel vybral, oddělené čárkou a mezerou.
Vyberte OK pro použití změn.
Textové pole v zápatí stránky se změní na komplexní výraz <<Expr>>.
V zápatí stránky vyberte v textovém poli a pomocí úchytů zvětšete šířku pole.
V textovém poli umístěte kurzor před výraz a zadejte textové hodnoty parametru vybrané:.
Vyberte vybrané hodnoty parametru popisku: a na text použijte tučný formát. Můžete použít klávesovou zkratku (Ctrl+B).
Zkontrolujte sestavu a otestujte podporu pro parametr s více hodnotami:
Vyberte Spustit pro zobrazení náhledu sestavy.
Na panelu nástrojů Prohlížeč sestav u výzvy Název obchodu rozbalte rozevírací seznam.
Každá hodnota parametru v seznamu má zaškrtávací políčko. Pokud je hodnota parametru zahrnuta v zobrazení sestavy, je zaškrtnuto políčko.
V rozevíracím seznamu zvolte možnost Vybrat vše . Tato možnost zaškrtne všechna políčka v seznamu, což způsobí zobrazení všech hodnot parametrů v reportu.
Na panelu nástrojů Prohlížeč sestav vyberte Zobrazit sestavu. Sestava zobrazí množství prodané ve všech obchodech pro všechny podkategorie:
Tip
U dlouhých hodnot parametrů nebo širokých sestav s mnoha sloupci zvyšte šířku sestavy nebo šířku sloupců na návrhové ploše, abyste zlepšili čitelnost dat v zobrazení sestavy. Můžete také upravit formátování záhlaví sloupců nebo dat buněk, například pomocí zarovnání na střed, aby se dlouhé hodnoty zalamovaly čitelně.
V rozevíracím seznamu zrušte výběr možnosti Vybrat vše a pak vyberte dvě hodnoty: Contoso Catalog Store a Contoso Asia Online Store.
Znovu vyberte Zobrazit sestavu , aby se zobrazily aktualizované výsledky.
Přidání logických parametrů pro podmíněnou viditelnost
Při implementaci Boolean parametru (True nebo False) v sestavě můžete řídit viditelnost dat parametru podle aktuálního nastavení.
Pokud chcete do sestavy přidat logický parametr, postupujte takto:
Na kartě Spustit vyberte Návrh a vraťte se do návrhového zobrazení.
V podokně Data sestavy klikněte pravým tlačítkem myši na uzel Parametry a vyberte Přidat parametr.
V dialogovém okně Vlastnosti parametru sestavy nakonfigurujte na kartě Obecné následující vlastnosti:
Název: Zadejte ShowSelections.
Výzva: Zadejte Zobrazit výběry?.
Datový typ: V rozevíracím seznamu vyberte logickou hodnotu .
Přepněte na kartu Výchozí hodnoty a nakonfigurujte následující vlastnosti:
Vyberte možnost Zadat hodnotu a pak zvolte Přidat.
Do pole Hodnota zadejte False.
Chcete-li použít změny vlastností, vyberte OK .
Teď můžete nastavit viditelnost na základě nastavení parametru:
V zápatí stránky v matici klikněte pravým tlačítkem myši na textové pole, které zobrazuje parametr, a vyberte Vlastnosti textového pole.
V dialogovém okně Vlastnosti textového pole nakonfigurujte následující vlastnosti:
Vyberte kartu Viditelnost .
Vyberte možnost Zobrazit nebo skrýt na základě možnosti výrazu .
Vyberte možnost Výraz (Fx).
V dialogovém okně Výraz vložte do horního pole následující výraz:
=Not Parameters!ShowSelections.ValueVlastnost Skrytý řídí možnost Viditelnost textového pole. Pokud je k dispozici operátor Not (
!) a čtenář vybere parametr, vlastnost Hidden je False a textové pole zobrazí data parametru.Pokud chcete výraz použít, vyberte OK .
Znovu vyberte OK , aby se použily vlastnosti textového pole.
Zkontrolujte zprávu a podporu testu pro logický parametr:
Vyberte Spustit pro zobrazení náhledu sestavy.
Na panelu nástrojů Prohlížeč sestav nastavte možnost Zobrazit výběry? na Hodnotu True. Vyberte Zobrazit sestavu.
Když čtenář nastaví Zobrazit výběry na True, v sestavě se zobrazí informace o vybraných hodnotách parametru.
Přidejte název sestavy
Přidejte do sestavy název pomocí následujícího postupu:
V Report Builder vyberte Design a vraťte se do návrhového zobrazení.
Na návrhové ploše vyberte textové pole Click to add title.
Do textového pole Pro přidání názvu zadejte text Parameterized Product Sales a pak vyberte mimo textové pole.
Uložte sestavu.
Pokud chcete sestavu uložit na server sestav, postupujte takto:
Vyberte Soubor>Uložit jako.
V dialogovém okně Uložit jako sestavu v pravém podokně vyberte Poslední weby a servery.
Vyberte nebo zadejte název serveru sestav, kde máte oprávnění k ukládání sestav.
Zobrazí se zpráva Připojení k serveru sestav. Po dokončení připojení se otevře výchozí složka sestavy. Správce serveru sestav určuje výchozí umístění složky.
U sestavy názvu nahraďte výchozí hodnotu Bez názvu hodnotou Parameterized_Product_Sales.
Vyberte Uložit.
Sestava se uloží na server sestav. Na stavové liště v dolní části okna se zobrazuje název reportovacího serveru pro připojení.