Tutoriál: Vytvořte si bezplatnou zprávu (Report Builder)

V tomto tutoriálu vytvoříte stránkovanou zprávu, která funguje jako newsletter. Každá stránka zobrazuje statický text, shrnuté vizuály a podrobná ukázková prodejní data.

Snímek obrazovky sestavy volného tvaru v aplikaci Report Builder.

Zpráva seskupuje informace podle teritorií a zobrazuje jméno obchodního manažera daného teritoria, stejně jako podrobné a souhrnné informace o prodeji. Začínáte s datovou oblastí seznamu jako základem pro volnou formu zprávy. Pak přidáte dekorativní panel s obrázkem, statický text s vloženými daty, tabulku pro podrobné informace a případně koláčové a sloupcové grafy pro zobrazení souhrnných informací.

Odhadovaná doba dokončení tohoto kurzu: 20 minut.

Požadavky

Další informace o požadavcích najdete v tématu Prerequisites for tutorials (Report Builder).

1. Vytvořte prázdnou zprávu, zdroj dat a datovou sadu

Note

V tomto kurzu dotaz obsahuje hodnoty dat, aby nepotřebovál externí zdroj dat. Díky tomu je dotaz poměrně dlouhý. V obchodním prostředí by dotaz neobsahoval data. To je pouze pro účely výuky.

Vytvořte prázdnou sestavu

  1. Start Report Builder z počítače, webového portálu Reporting Services nebo SharePoint integrovaného režimu.

    Otevře se dialogové okno Nová sestava nebo datová sada .

    Pokud dialogové okno Nová sestava nebo datová sada nevidíte, v nabídce Soubor klikněte na >Nový.

  2. V levém panelu se ujistěte, že je vybráno Nová zpráva .

  3. V pravém podokně vyberte Prázdnou sestavu.

Vytvořit nový zdroj dat

  1. V podokně s daty sestavy vyberte Nový>zdroj dat.

  2. Do pole s názvem Název zadejte: ListDataSource

  3. Vyberte Použít připojení vnořené do sestavy.

  4. Ověřte, že typ připojení je Microsoft SQL Server, a potom do pole řetězce připojení zadejte: Data Source = <servername>

    <servername>, například Report001, specifikuje počítač, na kterém je nainstalována instance Databázový stroj systému SQL Server. Protože data pro tuto zprávu nejsou extrahována z databáze SQL Server, není nutné uvádět název databáze. Výchozí databáze na určeném serveru slouží pouze k analýze dotazu.

  5. Vyberte přihlašovací údaje a zadejte potřebné přihlašovací údaje k připojení k instanci Databázový stroj systému SQL Server.

  6. Vyberte OK.

Vytvořit novou datovou sadu

  1. V podokně Data sestavy vyberte Nový>datový soubor.

  2. V poli Název zadejte ListDataset.

  3. Vyberte Použít datovou sadu vloženou do mé zprávy a ověřte, že zdrojem dat je ListDataSource.

  4. Ověřte, že je vybraný typ textového dotazu, a pak zvolte Návrhář dotazů.

  5. Vyberte Upravit jako text.

  6. Zkopírujte a vložte následující dotaz do podokna dotazu:

    SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Carrying Case' as Product, CAST(16996.60 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(13747.25 AS money) AS Sales, 55 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Carrying Case' as Product, CAST(9248.15 AS money) As Sales, 37 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1350.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1800.00 AS money) AS Sales, 24 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1125.00 AS money) AS Sales, 15 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1147.50 AS money) AS Sales, 17 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,  'Lens Adapter' as Product, CAST(742.50 AS money) AS Sales, 11 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1417.50 AS money) AS Sales, 21 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(13497.30 AS money) AS Sales, 54 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(11997.60 AS money) AS Sales, 48 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory, 'Carrying Case' as Product, CAST(10247.95 AS money) As Sales, 41 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory, 'Tripod' as Product, CAST(1200.00 AS money) AS Sales, 16 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(2025.00 AS money) AS Sales, 27 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Tripod' as Product, CAST(1425.00 AS money) AS Sales, 19 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(887.50 AS money) AS Sales, 13 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Accessories' as Subcategory, 'Lens Adapter' as Product, CAST(607.50 AS money) AS Sales, 9 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Accessories' as Subcategory,'Lens Adapter' as Product, CAST(1215.00 AS money) AS Sales, 18 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(10191.00 AS money) AS Sales, 79 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(8772.00 AS money) AS Sales, 68 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate,  'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(10578.00 AS money) AS Sales, 82 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory,'Digital' as Subcategory, 'Slim Digital' as Product, CAST(7218.10 AS money) AS Sales, 38 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory,'Digital' as Subcategory, 'Slim Digital' as Product, CAST(8357.80 AS money) AS Sales, 44 as Quantity  
    UNION SELECT CAST('2009-01-05' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory,'Digital' as Subcategory,'Slim Digital' as Product, CAST(9307.55 AS money) AS Sales, 49 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(3870.00 AS money) AS Sales, 30 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory,'Compact Digital' as Product, CAST(5805.00 AS money) AS Sales, 45 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate,  'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Compact Digital' as Product, CAST(8643.00 AS money) AS Sales, 67 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Lauren Johnson' as FullName,'Central' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(9877.40 AS money) AS Sales, 52 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Warren Pal' as FullName,'North' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(12536.70 AS money) AS Sales, 66 as Quantity  
    UNION SELECT CAST('2009-01-06' AS date) as SalesDate, 'Fernando Ross' as FullName,'South' as Territory, 'Digital' as Subcategory, 'Slim Digital' as Product, CAST(6648.25 AS money) AS Sales, 35 as Quantity  
    
  7. Vyberte ikonu Run (!) pro spuštění dotazu.

    Výsledky dotazu jsou data dostupná pro zobrazení v sestavě.

    Snímek obrazovky Návrháře dotazů, který zobrazuje data dostupná k zobrazení v sestavě volného formátu v nástroji Report Builder.

  8. Vyberte OK.

2. Přidat a nastavit seznam

V Reporting Services je datová oblast seznamu ideální pro vytváření volných reportů. Je založena na datové oblasti Tablix , stejně jako tabulky a matice. Další informace najdete v tématu Vytváření faktur a formulářů se seznamy ve stránkované sestavě (Tvůrce sestav).

V tomto tutoriálu použijete seznam k zobrazení prodejních informací pro prodejní oblasti ve zprávě formátované jako newsletter. Informace jsou seskupeny podle teritoria. Také přidáte novou skupinu řádků, která seskupuje data podle teritoria, a pak smažete vestavěnou skupinu řádků Detail.

Přidání seznamu

  1. Na záložce Vložit přejděte naSeznamdatových regionů>.

  2. Vyberte v těle zprávy (mezi titulkem a patou) a přetáhněte tlačítko, abyste vytvořili seznam. Udělejte krabici na seznam vysokou 7 palců a širokou 6,25 palce. Chcete-li zadat přesnou velikost, v podokně Vlastnosti v části Poloha zadejte hodnoty vlastností Šířka a Výška.

    Note

    Tato zpráva používá formát papíru Letter (8,5 x 11) a okraje o velikosti 1 palec. Seznamová krabice vyšší než 9 palců nebo širší než 6,5 palce může generovat prázdné stránky.

  3. Vyberte uvnitř seznamu a klikněte pravým tlačítkem na lištu nahoře v seznamu a vyberte vlastnosti Tablixu.

    Snímek obrazovky zobrazující možnost Tablix Properties pro sestavu ve volném formuláři v aplikaci Report Builder.

  4. V rozbalovacím seznamu názvů datové sady vyberte ListDataset.

  5. Vyberte OK.

  6. Klikněte pravým tlačítkem uvnitř seznamu a vyberte Vlastnosti obdélníku.

  7. Na kartě Obecné zaškrtněte políčko Přidat za sebou konec stránky.

  8. Vyberte OK.

Přidejte novou skupinu řádků a smažte skupinu Detaily

  1. V panelu Skupiny řádků klikněte pravým tlačítkem na skupinu Detaily, zaměřte na Přidat skupinu a poté vyberte Nadřadná skupina.

    Screenshot, který ukazuje, jak přidat rodičovskou skupinu do bezplatné zprávy Report Builder.

  2. V seznamu Seskupit podle vyberte [Territory].

  3. Vyberte OK.

    Do seznamu se přidá sloupec, který obsahuje buňku [Territory].

  4. Klikněte pravým tlačítkem na sloupec Území v seznamu a poté vyberte Smazat sloupce.

    Screenshot, který ukazuje, jak smazat sloupec z bezplatného formuláře Report Builder.

  5. Vyberte Odstranit pouze sloupce.

  6. V podokně Skupiny řádků klikněte pravým tlačítkem myši na skupinu Podrobnosti>Odstranit skupinu.

  7. Vyberte Odstranit pouze skupinu.

  8. Vyberte OK.

3. Přidejte grafické prvky

Jednou z výhod datových regionů seznamu je, že můžete přidávat položky reportů, jako jsou obdélníky a textová pole, kdekoli, místo abyste byli omezeni na tabulkové rozložení. Vzhled zprávy můžete vylepšit přidáním grafiky (obdélník vyplněný barvou).

Přidejte grafické prvky do zprávy

  1. Na záložce Vložit vyberte Obdélník.

  2. Vyberte v levém horním rohu seznamu a táhněte prstem, aby byl obdélník vysoký 7 palců a široký 3,5 palce. Opět pro přesné určení velikosti zadejte v panelu Vlastnosti pod Polohou hodnoty pro šířku a výšku.

  3. Klikněte pravým tlačítkem na obdélník >Rectangle Properties.

  4. Vyberte záložku Vyplnit .

  5. V Fill-color vyberte světle šedou.

  6. Vyberte OK.

  7. Vyberte Spustit pro zobrazení náhledu sestavy.

Levá strana zprávy nyní obsahuje vertikální grafiku tvořenou světle šedým obdélníkem, jak je znázorněno na následujícím obrázku.

Screenshot z Report Builder, který ukazuje vertikální grafiku tvořenou světle šedým obdélníkem.

4. Přidejte volný text

Můžete přidat textová pole pro zobrazení statického textu, který se opakuje na každé stránce reportu a na datových polích.

Přidat text do zprávy

  1. Vyberte Návrh a vraťte se do návrhového zobrazení.

  2. Na záložce Vložit přejděte do Textového pole. Vyberte levý horní roh seznamu, uvnitř obdélníku, který jste přidali dříve, a táhněte, aby bylo textové pole asi 3,45 palce široké a 5 palců vysoké.

  3. Umístěte kurzor do textového pole a zadejte: Zpravodaj pro. Přidejte mezeru za slovem "for", abyste oddělili text od pole, které přidáte v dalším kroku.

    Screenshot Design View, který ukazuje zprávu s nadpisem.

  4. Přetáhněte [Territory] pole z ListDataSet v panelu Report Data do textového pole a umístěte ho za "Newsletter for ".

    Screenshot, který ukazuje, jak přetáhnout pole Territory do bezplatného formuláře Report Builder.

  5. Vyberte text a [Territory] pole.

  6. Na kartě >Domovská stránkaFont vyberte:

    • Segoe Semibold.
    • 20 bodů.
    • Rajče.
  7. Umístěte kurzor pod text, který jste zadali v kroku 3, a zadejte: Hello s mezerou za slovem, abyste oddělili text a pole, které jste přidali v dalším kroku.

  8. Přetáhněte [FullName] pole z ListDataSet v panelu Report Data do textového pole a umístěte ho za "Hello", poté zadejte čárku (,).

  9. Vyberte text, který jste přidali v předchozích krocích.

  10. Na kartě >Domovská stránkaFont vyberte:

    • Segoe Semibold.
    • 16 pt.
    • Černý.
  11. Umístěte kurzor pod text, který jste přidali v krocích 9 až 13, a pak zkopírujte a vložte následující bezvýznamný text:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit. Proin sed dolor in ipsum pulvinar egestas. Sed sed lacus at leo ornare ultricies. Vivamus velit risus, euismod nec sodales gravida, gravida in dui. Etiam ullamcorper elit vitae justo fermentum ut ullamcorper augue sodales. 
    Ut placerat, nisl quis feugiat adipiscing, nibh est aliquet est, mollis faucibus mauris lectus quis arcu. In mollis tincidunt lacinia. In vitae erat ut lorem tincidunt luctus. Curabitur et magna nunc, sit amet adipiscing nisi. Nulla rhoncus elementum orci nec tincidunt. 
    Aliquam imperdiet cursus erat vel tincidunt. Donec et neque ac urna rutrum sodales. In id purus et nisl dignissim dapibus. Sed rhoncus metus at felis feugiat eu tempor dolor vehicula. Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nullam faucibus consectetur diam eu pellentesque.   
    
    
  12. Vyberte text, který jste právě přidali.

  13. Na kartě >Domovská stránkaFont vyberte:

    • Uživatelské rozhraní Segoe.
    • 10 bodů.
    • Černý.
  14. Vložte kurzor do textového pole pod bezvýznamný text a zadejte: Gratulujeme k celkovým prodejům, s mezerou za slovem, která oddělí text a pole, které přidáte v dalším kroku.

  15. Přetáhněte pole Prodej do textového pole, umístěte ho za text, který jste zadali v předchozím kroku, a pak zadejte vykřičník (!).

  16. Vyberte text a pole, které jste právě přidali.

  17. Na kartě >Domovská stránkaFont vyberte:

    • Segoe Semibold.
    • 16 pt.
    • Černý.
  18. Vyberte pouze [Sales] pole, klikněte pravým tlačítkem na pole >Expression.

  19. V rámečku Expression změňte výraz tak, aby zahrnoval funkci Součet následovně:

    =Sum(Fields!Sales.value)  
    
  20. Vyberte OK.

    Screenshot, který ukazuje textové pole v bezplatném formuláři Report Builder reportu.

  21. Se stále vybraným [Sum(Sales)] na kartě Domů> ve skupině Číslo> klikněte na Měna.

  22. Klikněte pravým tlačítkem na textové pole s textem "Klikněte pro přidání názvu" a poté vyberte Smazat.

  23. Vyberte seznamové pole. Vyberte dvě obousměrné šipky a přesuňte je do horní části stránky.

    Screenshot, který ukazuje, jak přetáhnout seznam v bezplatném formuláři Report Builder.

  24. Vyberte Spustit pro zobrazení náhledu sestavy.

Zpráva zobrazuje statický text a každá stránka zprávy obsahuje data týkající se určitého území. Tržby jsou ve formátu měny.

Screenshot, který ukazuje náhled stránky newsletteru v bezplatném formuláři Report Builder reportu.

5. Přidat tabulku pro zobrazení prodejních údajů

Použijte průvodce Novou tabulkou a maticí k přidání tabulky do volné formy reportu. Po dokončení průvodce ručně přidáte řádek pro součty.

Přidání tabulky

  1. Na kartě Insert přejděte do oblasti Data Regions>Table>Průvodce tabulkou.

  2. Na stránce Vybrat datovou sadu vyberte ListDataset>Next.

  3. Na stránce Uspořádat pole přetáhněte pole Produkt z dostupných polí na Hodnoty.

  4. Opakujte krok 3 pro SalesDate, Quantity a Sales. Umístěte SalesDate za produkt, Quantity za SalesDate a Sales za SalesDate.

  5. Vyberte Další.

  6. Na stránce Vybrat rozložení si můžete zobrazit rozložení tabulky.

    Tabulka je jednoduchá: pět sloupců bez skupin řádků nebo sloupců. Protože nemá žádné skupiny, nejsou dostupné možnosti rozložení pro skupiny. Tabulku ručně aktualizujete tak, aby byla uvedena celková hodnota později v tutoriálu.

  7. Vyberte Další.

  8. Vyberte Dokončit.

  9. Přetáhněte tabulku pod textové pole, které jste přidali ve 4. lekci.

    Note

    Ujistěte se, že tabulka je uvnitř pole se seznamem a uvnitř šedého obdélníku.

  10. S vybranou tabulkou klikněte v panelu Skupina řádků pravým tlačítkem na Detaily>Přidat celkový součet>po.

    Snímek obrazovky ukazující, jak přidat součty do sestavy ve volném formuláři v nástroji Report Builder.

  11. Vyberte buňku ve sloupci Produkt a zadejte Celkové.

    Snímek obrazovky buňky ve sloupci Product, do které bylo zadáno „Total“.

  12. Vyberte pole [SalesDate]. Na záložce >Domovská karta Číslo změňte výchozí na Datum.

  13. Vyberte pole [Sum(Sales)]. Na záložce >Domovské číslo změňte výchozí na měnu.

Vyberte Spustit pro zobrazení náhledu sestavy.

Zpráva zobrazuje tabulku s prodejními detaily a součty.

Screenshot, který ukazuje náhled tabulky v bezplatném formuláři Report Builder.

6. Uložte si zprávu

Sestavy můžete uložit na server sestav, do knihovny SharePoint nebo do počítače.

V tomto kurzu uložte sestavu na server pro sestavy. Pokud nemáte přístup k serveru sestav, uložte sestavu do počítače.

Uložte sestavu na server sestav

  1. Na tlačítku Report Builder vyberte Save As.

  2. Vyberte Poslední lokality a servery.

  3. Vyberte nebo zadejte název serveru sestav, kde máte oprávnění k ukládání sestav.

    Zobrazí se zpráva Připojení k serveru sestav. Po dokončení připojení se zobrazí obsah složky sestavy, kterou správce serveru sestav určil jako výchozí umístění pro sestavy.

  4. V názvu nahraďte výchozí název SalesInformationByTerritory.

  5. Vyberte Uložit.

Sestava se uloží na server sestav. Název serveru sestav, ke kterému jste připojeni, je zobrazován na stavovém řádku v dolní části okna.

Uložte sestavu na počítač

  1. Na tlačítku Report Builder vyberte Save As.

  2. Vyberte Plocha, Moje dokumenty nebo Můj počítač a pak procházejte do složky, do které chcete sestavu uložit.

  3. V názvu nahraďte výchozí název SalesInformationByTerritory.

  4. Vyberte Uložit.

7. (Volitelné) Přidat řádek do samostatných oblastí zprávy

Přidejte řádek pro oddělení redakční a detailní části zprávy.

Přidat řádek

  1. Vyberte Návrh a vraťte se do návrhového zobrazení.

  2. Na záložce Vložit přejděte dořádkuNahlásit položky>.

  3. Nakreslte čáru pod textové pole, které jste přidali ve 4. lekci.

  4. Vyberte řádek a na kartě >Ohraničení vyberte:

    • Šířka vyberte 3 pt.
    • Barva: vyberte Tomato.

8. (Volitelné) Přidat vizualizace souhrnných dat

Obdélníky vám pomáhají ovládat, jak se zpráva vykresluje. Vložte koláčový a sloupcový graf do obdélníku, abyste zajistili, že se zpráva zobrazí tak, jak chcete.

Přidání obdélníku

  1. Vyberte Návrh a vraťte se do návrhového zobrazení.

  2. Na záložce Vložit přejděte naObdélníkNahlásit položky>. Přetáhněte obdélník uvnitř seznamového boxu doprava od stolu a vytvořte obdélník asi 2,25 palce široký a 7,9 palce vysoký.

  3. S novým obdélníkem vybraným v panelu Vlastnosti nastavte BorderColor Světle šedý, BorderStyle Solid a BorderWidth 2 pt.

  4. Zarovnejte horní okraje obdélníku a tabulky.

Přidejte výsečový graf

  1. Na kartě Vložit přejděte na Vizualizace dat>>.

  2. Na stránce Vybrat datovou sadu vyberte ListDataset>Next.

  3. Vyberte Koláč>další.

  4. Na stránce s uspořádáním polí grafu přetáhněte Produkt do kategorií.

  5. Přetáhněte množství na hodnoty a vyberte další.

  6. Vyberte Dokončit.

  7. Změňte velikost grafu, který se objevuje v levém horním rohu zprávy, na přibližně 2,25 palce na šířku a 3,6 palce na výšku.

  8. Přetáhněte graf dovnitř obdélníku.

  9. Vyberte název grafu a zadejte: Množství produktů prodané.

  10. Na kartě >Domů, Písmo vytvořte nadpis:

    • PísmoSegoe UI Semibold.
    • Velikost12 pt.
    • Barvačerná.
  11. Klikněte pravým tlačítkem na legendu >Legend Properties.

  12. Na záložce Obecné , v pozici Legenda, vyberte střední tečku dole.

  13. Vyberte OK.

  14. Pokud je to nutné, přetáhněte je, aby byla oblast grafu vyšší.

    Snímek obrazovky zobrazující koláčový graf, který má být přidán do reportu ve volném formátu v nástroji Report Builder.

Přidání sloupcového grafu

  1. Na záložce >Vložit graf Vizualizace>> dat, Průvodce grafy.

  2. Na stránce Vybrat datovou sadu vyberte ListDataset a poté zvolte Další.

  3. Vyberte sloupec a pak zvolte Další.

  4. Na stránce Uspořádat pole grafu přetáhněte pole Produkt do kategorií.

  5. Přetáhněte Prodeje do Hodnoty a potom vyberte Další.

    Hodnoty se zobrazují na svislé ose.

  6. Vyberte Dokončit.

    Sloupcový graf je přidán do levého horního rohu zprávy.

  7. Zvětšit graf na přibližně 2,25 palce na šířku a téměř 4 palce na výšku.

  8. Přetáhněte graf do obdélníku pod koláčovým grafem.

  9. Vyberte název grafu a zadejte: Prodej produktů.

  10. Na kartě >Domů, Písmo vytvořte nadpis:

    • PísmoSegoe UI Semibold.
    • Velikost12 pt.
    • Barvačerná.
  11. Klikněte pravým tlačítkem na legendu a pak vyberte Smazat legendu.

    Note

    Odstranění legendy zvyšuje čitelnost grafu, když je graf malý.

    Snímek obrazovky zobrazující sloupcový graf, který má být přidán do sestavy Report Builder ve volném formátu.

  12. Vyberte osu grafu a na kartě >ve skupině Číslo> klikněte na možnost Měna.

  13. Vyberte Snížit desetinné číslo dvakrát, aby číslo ukazovalo jen dolary a žádné centy.

Ověřte, že grafy jsou uvnitř obdélníku

Obdélníky můžete použít jako kontejnery pro jiné položky na stránce zprávy. Přečtěte si více o obdélnících jako nádobách.

  1. Vyberte obdélník, který jste vytvořili a do kterého jste přidali tabulky dříve v této lekci.

    V panelu Vlastnosti se vlastnost Jméno zobrazuje název obdélníku.

    Screenshot, který ukazuje, jak zobrazit vlastnost Name v bezplatném formuláři Report Builder.

  2. Vyberte koláčový graf.

  3. V panelu Vlastnosti ověřte, že nadřazená vlastnost obsahuje název obdélníku.

    Screenshot, který ukazuje, jak zobrazit mateřskou nemovitost v bezplatném formuláři Report Builder reportu.

  4. Vyberte sloupcový graf a opakujte krok 3.

    Note

    Pokud grafy nejsou uvnitř obdélníku, vykreslená zpráva nezobrazuje grafy dohromady.

Udělejte grafy stejně velké

  1. Vyberte koláčový graf, stiskněte klávesu Ctrl a poté vyberte sloupcový graf.

  2. Když jsou vybrány oba grafy, klikněte pravým tlačítkem myši na >Rozložení>Nastavit stejnou šířku.

    Note

    Položka, kterou vyberete jako první, určuje šířku všech vybraných položek.

  3. Vyberte Spustit pro zobrazení náhledu sestavy.

Zpráva nyní zobrazuje souhrnná prodejní data v koláčových a sloupcových grafech.