Emails with IRM are getting stuck in Poison queue on Hub Server
Scenario:
Transport service crashing on the transport servers causing delayed emails or mails are stuck in queue
Emails with IRM are getting stuck in Poison queue on Hub Server
Log Name: Application
Source: MSExchange Common
Date: 9/29/2016 11:54:20 AM
Event ID: 4999
Task Category: General
Level: Error
Keywords: Classic
User: N/A
Computer: xyx.contoso.com
Description:
Watson report about to be sent for process id: 14256, with parameters: E12, c-RTL-AMD64, 14.03.0235.001, edgetransport, M.E.Data.Storage, M.E.D.S.R.RmsoProxyUtil.CheckRedirectUrl, System.ArgumentException, a11a, 14.03.0235.001.
ErrorReportingEnabled: False
Cause:
IRM Protected message enters Poison queue and Crashes Transport Service
Resolution:
- Set the Default registry key set it to value not set
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\IRM\CertificationServerRedirection
- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExchangeServer\v14\IRM\LicenseServerRedirection