Konfigurace BFD přes ExpressRoute

ExpressRoute podporuje obousměrné zjišťování předávání (BFD) přes privátní i partnerský vztah Microsoftu. Když povolíte BFD přes ExpressRoute, můžete zrychlit detekci selhání propojení mezi hraničními zařízeními Microsoft Enterprise (MSEE) a směrovači, které má váš okruh ExpressRoute nakonfigurované (CE/PE). ExpressRoute můžete nakonfigurovat přes hraniční směrovací zařízení nebo směrovací zařízení Partner Edge (pokud pracujete se spravovanou službou připojení vrstvy 3). Tento dokument vás provede nutností BFD a povoleníM BFD přes ExpressRoute.

Potřeba BFD

Následující diagram ukazuje výhodu povolení BFD přes okruh ExpressRoute: 1

Okruh ExpressRoute můžete povolit buď podle připojení vrstvy 2, nebo spravovaných připojení vrstvy 3. V obou případech platí, že pokud v cestě připojení ExpressRoute existuje více než jedno zařízení vrstvy 2, odpovědnost za detekci selhání propojení v cestě spočívá v nadměrné relaci protokolu BGP.

Na zařízeních MSEE se protokol BGP udržuje a uchovává čas obvykle nakonfigurovaný jako 60 a 180 sekund. Z tohoto důvodu může selhání propojení trvat až tři minuty, než zjistí případné selhání propojení a přepnout provoz na alternativní připojení.

Časovače protokolu BGP můžete řídit tak, že nakonfigurujete nižší dobu uchování protokolu BGP a dobu uchování na hraničním partnerském zařízení. Pokud časovače protokolu BGP nejsou stejné mezi dvěma partnerskými zařízeními, relace protokolu BGP se vytvoří pomocí nižší hodnoty času. Udržování protokolu BGP může být nastaveno tak nízké jako tři sekundy a doba uchování je tak nízká jako 10 sekund. Nastavení velmi agresivního časovače protokolu BGP se ale nedoporučuje, protože protokol je náročný na proces.

V tomto scénáři vám může pomoct BFD. BFD poskytuje detekci selhání propojení s nízkou režií v podsekundovém časovém intervalu.

Poznámka

BFD poskytuje rychlejší dobu převzetí služeb při selhání při zjištění selhání propojení, ale celková konvergence připojení bude trvat až minutu pro převzetí služeb při selhání mezi bránami virtuální sítě ExpressRoute a msEEs.

Povolení BFD

BFD je ve výchozím nastavení nakonfigurované ve všech nově vytvořených privátních rozhraních ExpressRoute a partnerského vztahu Microsoftu v prostředí MSEEs. Pokud chcete BFD povolit, stačí nakonfigurovat BFD jenom na primárních i sekundárních zařízeních. Konfigurace BFD je dvoustupňový proces. Nakonfigurujete BFD v rozhraní a pak ho propotete s relací protokolu BGP.

Níže je znázorněna příklad konfigurace CE/PE (pomocí Cisco IOS XE).

interface TenGigabitEthernet2/0/0.150
   description private peering to Azure
   encapsulation dot1Q 15 second-dot1q 150
   ip vrf forwarding 15
   ip address 192.168.15.17 255.255.255.252
   bfd interval 300 min_rx 300 multiplier 3


router bgp 65020
   address-family ipv4 vrf 15
      network 10.1.15.0 mask 255.255.255.128
      neighbor 192.168.15.18 remote-as 12076
      neighbor 192.168.15.18 fall-over bfd
      neighbor 192.168.15.18 activate
      neighbor 192.168.15.18 soft-reconfiguration inbound
   exit-address-family

Poznámka

Pokud chcete povolit BFD v rámci již existujícího privátního partnerského vztahu nebo partnerského vztahu Microsoftu, budete muset partnerský vztah resetovat. To bude potřeba provést u okruhů nakonfigurovaných s privátním partnerským vztahem před srpnem 2018 a partnerským vztahem Microsoftu před lednem 2020. Viz Resetování partnerských vztahů ExpressRoute

Vyjednávání časovače BFD

Mezi partnerskými vztahy BFD určují pomalejší dva peery přenosovou rychlost. Intervaly přenosu a příjmu BFD BFD jsou nastaveny na 300 milisekund. V některých scénářích může být interval nastaven na vyšší hodnotu 750 milisekund. Když nakonfigurujete vyšší hodnotu, můžete tyto intervaly vynutit, aby byly delší, ale není možné je zkrátit.

Poznámka

Pokud jste nakonfigurovali geograficky redundantní okruhy ExpressRoute nebo jako zálohu použijte připojení VPN typu Site-to-Site. Povolení BFD by pomohlo rychlejší převzetí služeb při selhání po selhání připojení ExpressRoute.

Další kroky

Další informace nebo nápovědu najdete na následujících odkazech: