Poznámka:
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Nabídky vám umožňují uspořádat příkazy logicky a tak, aby byly snadno nalezitelné. Pomocí Editoru nabídek můžete vytvářet a upravovat nabídky tak, že budete pracovat přímo s řádkem nabídek, který se bude podobat řádku nabídek v dokončené aplikaci.
Návod
Když používáte Editor nabídek, v mnoha případech můžete kliknutím pravým tlačítkem myši zobrazit vyskakovací nabídku často používaných příkazů. Dostupné příkazy závisí na tom, na co ukazatel ukazuje.
Jak na to
Editor nabídek umožňuje:
Vytvoření standardní nabídky
Přejděte do nabídky Zobrazit>Zobrazení zdrojů nebo Zobrazit>Jiná okna>Zobrazení zdrojů a klikněte pravým tlačítkem myši na nadpis Nabídka. Zvolte Přidat prostředek a pak Menu.
Na nabídkové liště vyberte pole Nová položka (obdélník, který obsahuje Typ sem).
Pole Nová položkaZadejte název nové nabídky, například Soubor.
Text, který zadáte, se zobrazí v Editoru nabídek i v poli Titulek v okně vlastností. Vlastnosti nové nabídky můžete upravit na kterémkoli místě.
Jakmile novou nabídku pojmenujete na řádku nabídek, pole nová položka se posune doprava (abyste mohli přidat další nabídku). Pod vaší první nabídkou se otevře další blok nové položky, abyste do něj mohli přidat příkazy nabídky.
Pole Nová položka s fokusem posunuté po zadání názvu nabídkyPoznámka:
Pokud chcete vytvořit nabídku s jednou položkou na řádku nabídek, nastavte vlastnost Popup na False.
Vytvoření podnabídky
Vyberte příkaz nabídky, pro který chcete vytvořit podnabídku.
Do pole Nová položka, které se zobrazí vpravo, zadejte název nového příkazu nabídky. Tento nový příkaz se zobrazí jako první v podnabídce.
Přidejte do podnabídky další příkazy.
Vložení nové nabídky mezi existující nabídky
Vyberte název existující nabídky a stiskněte klávesu Insert nebo klikněte pravým tlačítkem na řádek nabídek a zvolte Vložit nový.
Pole Nová položka se vloží před vybranou položku.
Pro přidání příkazů do nabídky
Vytvořte nabídku. Pak vyberte název nabídky, například Soubor.
Každé menu se rozbalí a zpřístupní nový box položek pro příkazy. Můžete například přidat příkazy Nové, Otevřít a Zavřít do nabídky Soubor .
Do pole pro novou položku zadejte název příkazu do nové nabídky.
Poznámka:
Text, který zadáte, se zobrazí jak v Editoru nabídek, tak v poli Popisek v okně Vlastnosti. Vlastnosti vaší nové nabídky můžete upravit na libovolném ze dvou míst.
Návod
Můžete definovat klávesu pro mnemotechnickou pomůcku (horkou klávesu), která umožňuje uživateli vybrat příkaz nabídky. Před písmeno vložte ampersand (
&), aby bylo určeno jako mnemonik. Uživatel může vybrat příkaz nabídky zvolením toho písmene.V okně Vlastnosti vyberte vlastnosti příkazu nabídky, které platí. Podrobnosti naleznete v části Parametry příkazu nabídky.
Do pole Výzva v okně Vlastnosti zadejte řetězec výzvy, který se má zobrazit ve stavovém řádku vaší aplikace.
Tento krok vytvoří položku v řetězcové tabulce se stejným identifikátorem prostředku jako příkaz nabídky, který jste vytvořili.
Poznámka:
Výzvy lze použít pouze u položek nabídky s vlastností vyskakovacíTrue. Například položky nabídky nejvyšší úrovně mohou mít návěští, pokud mají položky dílčí nabídky. Účelem Promptu je ukázat, co se stane, když uživatel vybere položku nabídky.
Stisknutím klávesy Enter dokončete příkaz nabídky.
Box "Nová položka" je vybrán, abyste mohl vytvořit další příkazy menu.
Vybrat více příkazů z nabídky pro spuštění hromadných operací, jako je odstranění nebo změna vlastností.
Podržte klávesu Ctrl stisknutou a vyberte požadované nabídky nebo podnabídky.
Přesunutí a kopírování nabídek a příkazů nabídky
Použijte metodu přetažení:
Přetáhněte nebo zkopírujte položku, na kterou chcete přejít:
Nové umístění v aktuální nabídce.
Jiná nabídka. Do jiných nabídek můžete přejít přetažením ukazatele myši na ně.
Upusťte příkaz z nabídky, když vodítko pro vložení zobrazuje požadovanou pozici.
Používejte příkazy místní nabídky:
Klikněte pravým tlačítkem myši na jednu nebo více nabídek nebo příkazů nabídky a pak zvolte Vyjmout (přesunout) nebo Kopírovat.
Pokud přesouváte položky do jiného prostředku nabídky nebo souboru skriptu prostředku, otevřete jej v jiném okně.
Vyberte umístění nabídky nebo příkazu nabídky, kam chcete přesunout nebo zkopírovat.
V místní nabídce zvolte Vložit. Přesunutá nebo zkopírovaná položka se umístí před položku, kterou vyberete.
Poznámka:
Můžete také přetáhnout, zkopírovat a vložit do jiných nabídek v jiných oknech nabídek.
Odstranit nabídku nebo příkaz nabídky
Klikněte pravým tlačítkem myši na název nabídky nebo příkaz a zvolte Odstranit.
Poznámka:
Podobně můžete pomocí místní nabídky provádět další akce, jako je Kopírování, Vyjmout, Vložit, Vložit nový, Vložit oddělovač, Upravit ID, Zobrazit jako vyskakovací okno, Zkontrolovat mnemoniky atd.
Kontextové nabídky
Vyskakovací nabídky zobrazují často používané příkazy. Mohou být kontextově citlivé na umístění ukazatele. Použití automaticky otevíraných nabídek ve vaší aplikaci vyžaduje vytvoření samotné nabídky a následné připojení k kódu aplikace.
Jakmile prostředek nabídky vytvoříte, kód aplikace musí načíst prostředek nabídky a použít TrackPopupMenu, aby se nabídka zobrazila. Jakmile uživatel zavře místní nabídku kliknutím mimo ni nebo výběrem příkazu, příslušná funkce se vrátí. Pokud uživatel zvolí příkaz, odešle se tato zpráva příkazu do okna, jehož popisovač byl předán.
Poznámka:
Pro programy knihovny MFC (Microsoft Foundation Class) a knihovny ATL použijte Průvodce kódu k připojení příkazů nabídky ke kódu. Další informace najdete v tématu Přidání události a mapování zpráv do funkcí.
Pokud chcete vytvořit místní nabídku, vytvořte nabídku s prázdným názvem a nezadávejte titulek. Potom do nové nabídky přidejte příkaz nabídky. Přejděte na první příkaz nabídky pod prázdným názvem nabídky (má dočasné označení Type Here) a zadejte titulek a všechny další potřebné informace.
Tento postup opakujte pro všechny ostatní příkazy v místní nabídce a nezapomeňte uložit prostředek nabídky.
Pokud chcete k aplikaci připojit místní nabídku, přidejte například obslužnou rutinu zprávy pro WM_CONTEXTMENU a pak do obslužné rutiny zprávy přidejte následující kód:
CMenu menu; VERIFY(menu.LoadMenu(IDR_MENU1)); CMenu* pPopup = menu.GetSubMenu(0); ASSERT(pPopup != NULL); pPopup->TrackPopupMenu(TPM_LEFTALIGN | TPM_RIGHTBUTTON, point.x, point.y, AfxGetMainWnd());
Při práci v Editoru nabídek se prostředek nabídky obvykle zobrazí jako řádek nabídky. Můžete ale mít položky nabídky, které se během běhu programu přidají do řádku nabídek aplikace.
Pokud chcete prostředek nabídky zobrazit jako kontextovou nabídku, klikněte pravým tlačítkem myši na nabídku a zvolte Zobrazit jako kontextovou nabídku.
Tato možnost je jenom předvolba zobrazení a nezmění vaši nabídku.
Návod
Pokud chcete přejít zpět do zobrazení řádku nabídek, znovu vyberte Zobrazit jako překryvné okno . Tato akce odstraní zaškrtnutí a obnoví zobrazení řádku nabídek.
Požadavky
Win32
Viz také
Editor zdrojů
Příkazy nabídky
Identifikátory objektů uživatelského rozhraní a příkazů
Nabídky
Nabídky