Sdílet prostřednictvím


Outlook nemá přístup k veřejným složkám hostovaným na starších serverech Exchange

Původní číslo KB: 3177600

Příznaky

Zvažte následující příklad:

V tomto scénáři nemají uživatelé, kteří mají poštovní schránku založenou na Exchange 2013 nebo Exchange 2016, přístup k veřejným složkám pomocí Microsoft Outlooku.

Příčina

K tomuto problému dochází, pokud je databáze poštovní schránky, která je hostitelem poštovní schránky uživatele, nakonfigurována pro databázi veřejných složek, která se liší od databáze poštovní schránky zjišťování veřejné složky.

Řešení

Pokud chcete tento problém vyřešit, nakonfigurujte databázi poštovních schránek uživatele tak, aby používala stejnou databázi veřejných složek jako poštovní schránka zjišťování:

  1. Poštovní schránku zjišťování veřejných složek přiřaďte poštovní schránce uživatele pomocí rutiny Set-Mailbox následujícím způsobem:

    Set-Mailbox <User> -DefaultPublicFolderMailbox <ProxyMailbox>
    
  2. Databázi veřejných složek pro databázi poštovních schránek uživatele přiřaďte pomocí rutiny Set-MailboxDatabase následujícím způsobem:

    Set-MailboxDatabase (Get-Mailbox <User>).Database -PublicFolderDatabase (Get-MailboxDatabase (Get-Mailbox <ProxyMailbox>).Database).PublicFolderDatabase
    
  3. Spuštěním následující rutiny restartujte službu Microsoft Exchange Rpc Client Access na serveru, na kterém běží Exchange Server, který je hostitelem veřejných složek:

    Restart-Service MSExchangeRPC