Poznámka
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Původní číslo KB: 3032395
Tento článek se týká pouze problémů s připojením k aplikaci Microsoft Outlook, které jsou způsobeny požadavkem na šifrování RPC.
Příznaky
Když spustíte aplikaci Microsoft Office Outlook pomocí profilu, který obsahuje poštovní schránku na serveru se systémem Microsoft Exchange Server 2010, Exchange Server 2013 nebo Exchange Server 2016, mohou se zobrazit následující chybové zprávy:
Nelze spustit aplikaci Microsoft Office Outlook. Nelze otevřít okno aplikace Outlook. Sadu složek nelze otevřít.
Nelze otevřít výchozí e-mailové složky. Počítač Microsoft Exchange Server není k dispozici. Buď došlo k problémům se sítí, nebo je počítač Microsoft Exchange Server mimo provoz z důvodu údržby.
Připojení k serveru Microsoft Exchange Server není k dispozici. K dokončení této akce musí být aplikace Outlook v režimu online nebo připojena.
Nelze otevřít výchozí e-mailové složky. Úložiště informací nelze otevřít.
Aplikace Outlook se nemohla přihlásit. Zkontrolujte, zda jste připojeni k síti a používáte správný název serveru a poštovní schránky. Připojení k serveru Microsoft Exchange Server není k dispozici. K dokončení této akce musí být aplikace Outlook v režimu online nebo připojena.
Pokud však používáte profil režimu s mezipamětí, aplikace Outlook nezobrazí chybu. Mohou se objevit následující příznaky:
Aplikace Outlook se spustí ve stavu Odpojeno (v pravém dolním rohu okna aplikace Outlook se zobrazí „Odpojeno“, snímek obrazovky stavu je uveden níže).
Spustí se aplikace Outlook a můžete odesílat a přijímat e-mailové zprávy. V části „Stav připojení aplikace Microsoft Exchange“ se ale zobrazí jenom dvě připojení a může se zobrazit adresář typů zobrazený jako Odpojeno/Připojování.
Při pokusu o vytvoření nového profilu aplikace Outlook pro poštovní schránku na serveru se systémem Exchange 2010 nebo Exchange Server 2013 se mohou zobrazit následující chybové zprávy:
Akci nebylo možné dokončit. Připojení k serveru Microsoft Exchange Server není k dispozici. K dokončení této akce musí být aplikace Outlook v režimu online nebo připojena.
Název se nepodařilo přeložit. Připojení k serveru Microsoft Exchange Server není k dispozici. K dokončení této akce musí být aplikace Outlook v režimu online nebo připojena.
Aplikace Outlook se nemohla přihlásit. Zkontrolujte, zda jste připojeni k síti a používáte správný název serveru a poštovní schránky. Připojení k serveru Microsoft Exchange Server není k dispozici. K dokončení této akce musí být aplikace Outlook v režimu online nebo připojena.
Název se nepodařilo přeložit. Akci nebylo možné dokončit.
Název vašeho serveru nebo poštovní schránky nelze přeložit.
Řešení
Poznámka
Pokud používáte jednu z automatizovaných metod (zásady skupiny nebo soubor .prf), ujistěte se, že jste tuto metodu před nasazením ve velkém měřítku plně otestovali.
Metoda 1: Aktualizace nebo vytvoření profilu aplikace Outlook pomocí šifrování RPC
Ruční aktualizace existujícího profilu
Chcete-li ručně aktualizovat existující profil aplikace Outlook tak, aby používal šifrování RPC, postupujte takto:
V Ovládacím panelu otevřete položku Pošta.
Vyberte Zobrazit profily.
Vyberte svůj profil a poté klikněte na Vlastnosti.
Vyberte E-mailové účty.
Vyberte Microsoft Exchange (ve výchozím nastavení odesílat z tohoto účtu) účet >Změnit.
V dialogovém okně, které obsahuje váš poštovní server a uživatelské jméno, vyberte Další nastavení.
V dialogovém okně Microsoft Exchange klikněte na kartu Bezpečnost.
Vyberte Šifrovat data mezi aplikacemi Microsoft Office Outlook a Microsoft Exchange>OK (Snímek obrazovky pro tento krok najdete zde).
Vyberte Další>Dokončit.
Vyberte Zavřít>Zavřít>OK.
Nasazením nastavení zásad skupiny aktualizujte stávající profily aplikace Outlook pomocí šifrování RPC
Z pohledu klienta je nasazení nastavení šifrování Outlook-Exchange pravděpodobně nejjednodušším řešením pro organizace, které mají mnoho klientů používající Outlook. Toto řešení zahrnuje jedinou změnu na serveru (řadiči domény) a vaši klienti jsou automaticky aktualizováni po stažení zásady do klienta.
Outlook 2010
Ve výchozím nastavení je v aplikaci Outlook 2010 povoleno nastavení šifrování RPC. Toto nastavení byste tedy měli nasadit pouze pomocí zásad skupiny z některého z následujících důvodů:
- Vaše původní nasazení aplikace Outlook 2010 deaktivovalo šifrování RPC mezi aplikacemi Outlook a Exchange.
- Chcete uživatelům zabránit ve změně nastavení šifrování RPC v jejich profilu aplikace Outlook.
Výchozí šablona zásad skupiny pro aplikaci Outlook 2010 obsahuje nastavení zásad skupiny, které řídí šifrování RPC Outlook-Exchange. Chcete-li aktualizovat stávající profily aplikace Outlook 2010 pomocí zásad skupiny, postupujte takto:
Stáhněte si nejnovější verzi šablony zásad skupiny Outlk14.adm.
Přidejte soubor .adm do řadiče domény.
Poznámka
Postup přidání souboru .adm do řadiče domény se liší podle verze systému Windows, kterou používáte. Navíc vzhledem k tomu, že zásady můžete aplikovat na organizační jednotku, a ne na doménu, můžou se tyto kroky také lišit v tomto aspektu použití zásady. Podrobné informace si proto vyhledejte v dokumentaci k systému Windows.
Po přidání šablony .adm do Editoru místních zásad skupiny přejděte ke kroku 3.
V části Konfigurace uživatele rozbalte položku Šablony pro správu (ADM) a vyhledejte uzel zásad pro svou šablonu. Pomocí šablony Outlk14.adm bude tento uzel pojmenován Microsoft Outlook 2010.
V části Nastavení účtu vyberte uzel Exchange (snímek obrazovky pro tento krok najdete zde).
Poklepejte na nastavení zásad Povolit šifrování RPC.
Na kartě Nastavení vyberte možnost Povoleno.
Vyberte OK.
V tomto okamžiku bude nastavení zásad použito na vašich klientských pracovních stanicích aplikace Outlook při replikaci aktualizace zásad skupiny. Chcete-li tuto změnu otestovat, spusťte následující příkaz:
gpupdate /force
Po spuštění tohoto příkazu spusťte na pracovní stanici Editor registru a ujistěte se, že na klientovi existují následující data registru:
Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\RPC
DWORD: EnableRPCEncryption
Value: 1
Pokud se tato data registru v registru zobrazí, použije se na tohoto klienta nastavení Zásady skupiny. Spusťte aplikaci Outlook a ověřte, zda změna problém vyřeší.
Outlook 2013
Ve výchozím nastavení je v Outlooku 2013 povoleno nastavení šifrování RPC. Toto nastavení byste tedy měli nasadit pouze pomocí zásad skupiny z některého z následujících důvodů:
- Vaše původní nasazení aplikace Outlook 2013 deaktivovalo šifrování RPC mezi Outlookem a Exchange.
- Chcete uživatelům zabránit ve změně nastavení šifrování RPC v jejich profilu aplikace Outlook.
Výchozí šablona zásad skupiny pro aplikaci Outlook 2013 obsahuje nastavení zásad skupiny, které řídí šifrování RPC Outlook-Exchange. Chcete-li aktualizovat stávající profily aplikace Outlook 2013 pomocí zásad skupiny, postupujte takto:
Stáhněte si Šablony ADM Office 2013.
Přidejte soubory .admx a .adml do řadiče domény. Tím se přidá šablona Outlook ADM, aby byla dostupná v Editoru místních zásad skupiny.
Poznámka
Postup přidání souborů .admx a adml do řadiče domény se liší podle verze systému Windows, kterou používáte. Navíc vzhledem k tomu, že zásady můžete aplikovat na organizační jednotku, a ne na doménu, můžou se tyto kroky také lišit v tomto aspektu aplikace zásad. Podrobné informace najdete v dokumentaci k systému Windows. (Tento článek je označený pro Office 2010. Platí to ale i pro Office 2013.)
Spusťte Editor místních zásad skupiny.
V části Konfigurace uživatele rozbalte položku Šablony pro správu (ADM) a vyhledejte uzel zásad pro svou šablonu. Když použijete šablonu Outlk15.admx, bude tento uzel pojmenován Microsoft Outlook 2013.
V části Nastavení účtu vyberte uzel Exchange (snímek obrazovky pro tento krok najdete zde).
Poklepejte na nastavení zásad Povolit šifrování RPC.
Na kartě Nastavení vyberte možnost Povoleno.
Vyberte OK.
V tomto okamžiku bude nastavení zásad použito na vašich klientských pracovních stanicích aplikace Outlook při replikaci aktualizace zásad skupiny. Chcete-li tuto změnu otestovat, spusťte na pracovní stanici následující příkaz:
gpupdate /force
Po spuštění tohoto příkazu spusťte na pracovní stanici Editor registru a ujistěte se, že na klientovi existují následující data registru:
Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\RPC
DWORD: EnableRPCEncryption
Value: 1
Pokud se tato data registru v registru zobrazí, použije se na tohoto klienta nastavení Zásady skupiny. Spusťte aplikaci Outlook a ověřte, zda změna problém vyřeší.
Metoda 2: Zakázání požadavků na šifrování na všech serverech CAS
Důležité
Společnost Microsoft důrazně doporučuje ponechat na serveru povolený požadavek na šifrování a použít jednu z dalších metod uvedených v tomto článku. Metoda 2 je v tomto článku k dispozici pouze pro situace, kdy nemůžete okamžitě nasadit nezbytná nastavení šifrování RPC na klienty Outlook. Pokud pomocí metody 2 povolíte klientům aplikace Outlook připojení bez šifrování RPC, povolte požadavek na šifrování RPC na svých serverech CAS co nejrychleji, aby byla zachována nejvyšší úroveň komunikace mezi klienty a servery.
Chcete-li zakázat požadované šifrování mezi aplikací Outlook a Exchange, postupujte takto:
Spusťte následující příkaz v prostředí Exchange Management Shell:
Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$False
Poznámka
Zástupný symbol Exchange_server_name představuje název Exchange Server, který má roli serveru klientského přístupu.
Tuto rutinu musíte spustit pro všechny servery s klientským přístupem, které používají Exchange Server 2010 nebo novější verzi.
Spusťte tento příkaz znovu pro každý server Exchange, který má roli Server klientského přístupu. Příkaz je také nutné spustit na každé roli Poštovní server, která obsahuje Úložiště veřejných složek. Připojení k veřejné složce z klienta MAPI jdou přímo do služby klientského přístupu RPC na poštovním serveru.
Poté, co jsou vaši klienti Outlook aktualizováni nastavením umožňujícím šifrovanou komunikaci RPC se serverem Exchange (viz kroky uvedené níže), můžete znovu povolit požadavek na šifrování RPC na svých serverech Exchange, které mají roli Server klientského přístupu.
Chcete-li znovu povolit požadavek na šifrování RPC na vašich serverech Exchange, které mají roli Server klientského přístupu, spusťte v prostředí Exchange Management Shell následující příkaz:
Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$True
Poznámka
Zástupný symbol Exchange_server_name představuje název serveru Exchange, který má roli serveru klientského přístupu.
Tuto rutinu musíte spustit pro všechny servery s klientským přístupem, které používají Exchange Server 2010 nebo novější verzi.
Příčina
Jednou z možných příčin je, že používáte aplikaci Outlook a deaktivujete nastavení profilu Šifrovat data mezi aplikacemi Microsoft Office Outlook a Microsoft Exchange. Výchozí konfigurace pro Exchange Server 2013 vyžaduje šifrování RPC z klienta Outlook. To zabrání klientovi v připojení.
Poznámka
Výchozí konfigurace Exchange Server 2010 Release to Manufacturing (RTM) vyžaduje šifrování RPC. Toto chování je změnou oproti Exchange Serveru 2010 Service Pack 1, kde je požadavek na šifrování RPC ve výchozím nastavení zakázán. Jakýkoli server klientského přístupu (CAS) nasazený před aktualizací Service Pack 1 nebo upgradovaný na aktualizaci Service Pack 1 si však zachová stávající nastavení požadavku na šifrování RPC, které by stále mohlo bránit klientovi v připojení.