Chyba při vyhledávání více poštovních schránek v Exchange Server 2010: Uživatel nemá poštovní schránku exchange

Původní číslo KB: 2702446

Příznaky

Zvažte následující příklad:

  • Exchange Ovládací panely (ECP) spustíte v Microsoft Exchange Server 2010 Enterprise nebo v Exchange Server 2010 Standard.
  • Provedete vyhledávání ve více poštovních schránkách.
  • Hledání ve více poštovních schránkách používá jako cíl pro hledání systémovou poštovní schránku, poštovní schránku vyhledávání zjišťování nebo federovanou poštovní schránku.

V tomto scénáři se může zobrazit následující chybová zpráva:

Uživatel nemá poštovní schránku exchange.

Kromě toho je v protokolu aplikace zaznamenána následující událost:

Log Name: Application
Source: MSExchange Configuration Cmdlet - Remote Management
Event ID: 5
Task Category: General
Level: Error
Keywords: Classic
Description:
(PID 6268, Thread 53) Task New-MailboxSearch throwing terminating exception at stage Microsoft.Exchange.Data.Storage.UserHasNoMailboxException: The user does not have an Exchange mailbox.
at Microsoft.Exchange.Data.Storage.ExchangePrincipal.InternalFromADUser(ADUser user, ADObjectId mdb, DatabaseLocationInfo databaseLocationInfo, Boolean ignoreSiteBoundary)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore.OpenMailboxSession(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore..ctor(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.OpenMailboxStore()
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.Exists[T](String name)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.PreSaveValidate(SearchObject savedObject)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.InternalEndProcessing(). Exception: {4c1ab22a-bd1d-41e9-b178-5e75ffd14563}

Příčina

K tomuto problému může dojít, pokud je jedna nebo více z následujících poštovních schránek v nekonzistentním stavu, protože pro HomeMDB atribut není nastavena žádná hodnota:

  • Jedna nebo více systémových poštovních schránek
  • Federovaná poštovní schránka
  • Poštovní schránka vyhledávání zjišťování

Řešení

Pokud chcete tento problém vyřešit, postupujte takto:

  1. Spusťte ECP.

  2. Ověřte, že jedna nebo více poštovních schránek je v nekonzistentním stavu. Uděláte to tak, že zadáte následující rutinu a stisknete klávesu Enter:

    Get-Mailbox -Arbitration |fl name, alias
    

    Poznámka

    Může se zobrazit chybová zpráva podobná následující. Tato chybová zpráva potvrzuje, že jedna nebo více systémových poštovních schránek nebo federovaných poštovních schránek je v nekonzistentním stavu:

    UPOZORNĚNÍ: Objekt SystemMailbox{1f05a927-9daf-4003-9bf7-036822f96290} je poškozený a je
    v nekonzistentním stavu. Došlo k následujícím chybám ověření:
    UPOZORNĚNÍ: Databáze je povinná v UserMailboxu.
    UPOZORNĚNÍ: Databáze je povinná v UserMailboxu.

  3. Ověřte, že pro poštovní schránku HomeMDB chybí hodnota atributu. Uděláte to tak, že do ecp zadáte následující rutinu a stisknete Enter:

        Get-Mailbox |fl name, alias
    

    Poznámka

    Následující chybová zpráva indikuje, že chybí hodnota atributu HomeMDB :
    Databáze je v UserMailboxu povinná.

  4. HomeMDB Zkopírujte hodnotu atributu poštovní schránky ve stejné databázi jako systémová poštovní schránka, federovaná poštovní schránka nebo poštovní schránka vyhledávání zjišťování. Postupujte takto:

    1. Klikněte na Start, do pole Prohledat programy a soubory zadejte Adsi Edit a stiskněte Enter.

    2. V nabídce Akce klikněte na Připojit k.

    3. Klikněte na Vybrat nebo zadejte doménu nebo server, vyberte požadovaný server a klikněte na OK.

    4. Rozbalte položku Výchozí názvový kontext a potom klikněte na následující položku:

      DC=doména,DC=com

    5. Poklikejte na CN=Users.

    6. Klikněte pravým tlačítkem na poštovní schránku uživatele a potom klikněte na Vlastnosti.

    7. V části Atribut klikněte na homeMDB>Upravit.

    8. Zkopírujte hodnotu atributu HomeMDB a potom dvakrát klikněte na OK .

  5. Nastavte hodnotu atributu HomeMDB u systémové poštovní schránky, federované poštovní schránky nebo účtu poštovní schránky vyhledávání zjišťování. Postupujte takto:

    1. V nástroji ADSI Edit klikněte pravým tlačítkem na účet pro systémovou poštovní schránku, federovanou poštovní schránku nebo poštovní schránku vyhledávání zjišťování a potom klikněte na Vlastnosti.
    2. V části Atribut klikněte na homeMDB>Upravit.
    3. Zadejte nebo vložte hodnotu atributu HomeMDB , kterou jste zkopírovali v kroku 4.
    4. Dvakrát klikněte na OK .
  6. V nabídce File (Soubor) klikněte na Exit (Ukončit).

  7. Replikace doménové struktury Uděláte to tak, že na příkazovém řádku se zvýšenými oprávněními zadáte následující rutinu a stisknete klávesu Enter:

    repadmin /syncall /e
    

Další informace

Další informace o atributu najdete v HomeMDB tématu Vlastnost HomeMDB.

Další informace o problému, ke kterému může dojít v případě, že v poštovní schránce System Attendant chybí hodnota atributu HomeMDB System Attendant, najdete v tématu Chybí atribut System Attendant homeMDB.