Poznámka
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Příznaky
Při spuštění dávkové úlohy migrace veřejné složky se zobrazí následující chybová zpráva:
ErrorFoldersRestoredDuringMigrationPermanentException
Příčina
K tomuto problému dochází, protože operace obnovení veřejné složky není podporována během migrací, které začínají parametrem ExcludeDumpster . K problému dochází, pokud jsou splněny následující podmínky:
- Dávka migrace veřejné složky byla vytvořena pomocí parametru
ExcludeDumpster
. - Během spuštění dávkové úlohy migrace jste obnovili odstraněné veřejné složky ze složky dumpster ve zdroji.
Řešení
Chcete-li tento problém vyřešit, použijte jednu z následujících metod, jak je to vhodné pro vaši situaci.
Metoda 1: Odebrání obnovených veřejných složek
Identifikujte ID položek obnovených složek. Tady je postup, jak zkontrolovat sestavu a identifikovat ID položek.
Metoda 1: Použití Centra pro správu Exchange
V Centru pro správu Exchange vyberte Možnost Migrace příjemců>.
Vyberte dávku migrace a pak v části Stav poštovní schránky vyberte Zobrazit podrobnosti.
Vyberte poštovní schránku neúspěšné migrace a pak vyberte Stáhnout sestavu pro tohoto uživatele.
Poznamenejte si identitu poštovní schránky neúspěšné migrace. V následujícím příkladu je identita Mailbox1.
V sestavě vyhledejte klíčové slovo "obnoveno" a vyhledejte ID položek obnovených složek. ID položky je první datová hodnota obnovené položky složky, jak je znázorněno v následujícím příkladu.
Metoda 2: Použití PowerShellu
Připojení k modulu Exchange Online PowerShell.
Spuštěním následující rutiny načtěte požadavek na migraci poštovní schránky se nezdařilou veřejnou složkou:
$failed_req = Get-PublicFolderMailboxMigrationRequest -Status Failed $failed_req
Poznamenejte si identitu poštovní schránky neúspěšné migrace.
Spuštěním následující rutiny exportujte statistiku neúspěšné žádosti o migraci poštovní schránky veřejné složky do souboru XML:
$failed_req | foreach { Get-PublicFolderMailboxMigrationRequestStatistics $_.Identity -IncludeReport -DiagnosticInfo verbose | Export-Clixml "PF_failed_$($_.TargetMailbox)_$($_.RequestGuid).xml" }
Soubor .xml se vytvoří na vašem počítači, jak je znázorněno v následujícím příkladu.
Importujte soubor XML spuštěním následující rutiny:
$failedreport=Import-Clixml "<Path of the xml file>"
Poznámka:
$failedreport
je proměnná, kterou můžete přizpůsobit. <Cesta k souboru> XML představuje skutečnou cestu.Spuštěním následující rutiny načtěte ID položek obnovených složek
$failedreport
:$failedreport.Report.Entries|where {[string]$_ -like "*recovered*"}|%{[string]$_}
ID položky je první datová hodnota obnovené položky složky, jak je znázorněno v následujícím příkladu.
Odeberte obnovenou veřejnou složku spuštěním následující rutiny:
Remove-PublicFolder -Identity "<EntryID>"
<Zástupný symbol EntryID> nahraďte ID položky, které jste našli v kroku 1. Další informace o této rutině naleznete v části Příklady remove-PublicFolder.
Spuštěním následující rutiny spusťte migraci neúspěšné poštovní schránky:
Start-MigrationUser "<FailedMailbox>"
<Zástupný symbol FailedMailbox> nahraďte identitou poštovní schránky pro neúspěšnou migraci, kterou jste si poznamenali v kroku 1. Další informace o této rutině najdete v tématu Start-MigrationUser.
Metoda 2: Nezadávejte parametr ExcludeDumpster
Pokud nechcete odebrat obnovené veřejné složky, restartujte migraci bez zadání parametru ExcludeDumpster
.
Více informací
Stále potřebujete pomoc? Přejděte na web Microsoft Community.