Sdílet prostřednictvím


Chyby při migraci veřejné složky

Příznaky

Během migrace veřejné složky narazíte na jeden z následujících problémů:

  • Nejde odebrat primární poštovní schránku veřejné složky

    Když se pokusíte vrátit zpět migraci veřejné složky, zablokujete se v kroku odebrání primární poštovní schránky veřejné složky. Kromě toho se zobrazí jedna z následujících chybových zpráv:

    Operaci nešlo provést, protože Mailbox1 odpovídá více položkám.

    Poštovní schránka "Mailbox1" je primární poštovní schránka veřejné složky pro uživatele. Pokud chcete tuto poštovní schránku odebrat, nejprve odeberte všechny ostatní poštovní schránky veřejných složek.

  • Nejde vytvořit koncový bod migrace veřejných složek

    Při pokusu o vytvoření koncového bodu migrace veřejné složky se zobrazí jedna z následujících chybových zpráv:

    Položka se stejným klíčem už byla přidána.

    Více uživatelů poštovní schránky odpovídá identitě Mailbox1. Zadejte jedinečnou hodnotu.

  • Migrace veřejné složky se nezdařila

    Při analýze sestavy migrace neúspěšných žádostí o migraci poštovních schránek veřejné složky se zobrazí následující chybová položka:

    Více uživatelů poštovní schránky odpovídá identitě Mailbox1. Zadejte jedinečnou hodnotu.

Příčina

K tomuto problému dochází, pokud platí jedna nebo obě následující podmínky:

  • Poštovní schránky veřejných složek, které jsou obnovitelné odstranění, mají stejné názvy jako aktivní poštovní schránky.
  • Buď primární poštovní schránka veřejné složky nebo sekundární poštovní schránka veřejné složky má osamocený objekt CNF (konflikt).

Řešení

Pokud chcete tento problém vyřešit, postupujte takto:

Krok 1: Odebrání obnovitelně odstraněných poštovních schránek veřejných složek, které mají stejné názvy jako aktivní poštovní schránky

Chcete-li najít a odebrat obnovitelně odstraněné poštovní schránky veřejných složek, které mají stejné názvy jako aktivní poštovní schránky, postupujte takto:

  1. Připojení k nástroji Exchange Online PowerShell.

  2. Získejte poštovní schránky (včetně obnovitelně odstraněných poštovních schránek veřejných složek) spuštěním následující rutiny:

    Get-Recipient  -IncludeSoftDeletedRecipients -RecipientTypeDetails publicfoldermailbox |fl Name, OrganizationalUnit, DistinguishedName, ExchangeGuid
    

    Ve výstupu vyhledejte "Obnovitelně odstraněné objekty" a zkontrolujte, jestli je odpovídající název obnovitelně odstraněné poštovní schránky stejný jako název jakékoli aktivní poštovní schránky.

    Tady je příklad výstupu:

    Název: Poštovní schránka1
    Organizační jednotka: <Domain_name.prod.outlook.com/Microsoft> Exchange Hosted Organizations/contoso.onmicrosoft.com/Obnovitelné odstraněné objekty
    DistinguishedName: CN=Mailbox1,OU=Obnovitelně odstraněné objekty,OU=contoso.onmicrosoft.com,OU=Hostované organizace Microsoft Exchange,DC=<Domain_name,DC>=PROD,DC=OUTLOOK,DC=COM
    ExchangeGuid: <Guid_number>

    Název: Poštovní schránka1
    Organizační jednotka: <Domain_name.prod.outlook.com/Microsoft> Exchange hostované organizace/contoso.onmicrosoft.com
    DistinguishedName: CN=Mailbox1,OU= contoso.onmicrosoft.com,OU=Microsoft Exchange Hosted Organizations,DC=<Domain_name,DC>=PROD,DC=OUTLOOK,DC=COM
    ExchangeGuid: <Guid_number>

    Poznámka: Pokud ve výstupu nejsou nalezeny žádné poštovní schránky obnovitelně odstraněné veřejné složky, přejděte na Krok 2: Odebrání všech existujících osamocených poštovních schránek veřejných složek.

  3. Spuštěním následující rutiny odeberte poštovní schránku obnovitelně odstraněné veřejné složky:

    Remove-Mailbox -PublicFolder "<ExchangeGuid>" -PermanentlyDelete
    

    Poznámky:

    • V této rutině nahraďte <ExchangeGuid> identifikátorem GUID, který jste získali z výstupu rutiny v předchozím kroku.
    • Opakujte tuto rutinu, dokud nebudou všechny poštovní schránky veřejných složek odstraněné obnovitelně odstraněny.

Krok 2: Odebrání všech existujících osamocených poštovních schránek veřejných složek

Pokud chcete najít a odebrat všechny existující osamocené poštovní schránky veřejných složek, postupujte takto:

  1. Připojení k nástroji Exchange Online PowerShell.

  2. Spuštěním následujících rutin vyhledejte osamocené poštovní schránky veřejných složek CNF:

    Get-Mailbox –PublicFolder | fl Name,Identity,ExchangeGuid,Guid
    Get-Mailbox -PublicFolder -SoftDeletedMailbox | fl Name,Identity,ExchangeGuid,Guid
    

    Pokud rutiny nehlásí žádné osamocené poštovní schránky veřejných složek CNF, spusťte následující rutinu:

    Get-Recipient -RecipientTypeDetails PublicFolderMailbox -IncludeSoftDeletedRecipients | fl Name,Identity,ExchangeGuid,Guid
    

    Tady je příklad výstupu z této rutiny, ve kterém má objekt hodnotu CNF v názvu a identitě.

    Snímek obrazovky s výstupem příkazu, ve kterém je zvýrazněná funkce ExchangeGuid

  3. Pokud chcete odebrat jednotlivé osamocené poštovní schránky veřejné složky, spusťte následující rutinu:

    Remove-Mailbox -PublicFolder -RemoveCNFPublicFolderMailboxPermanently <ExchangeGuid> 
    

    Poznámka: V této rutině nahraďte <ExchangeGuid> hodnotou, kterou jste získali z výstupu rutiny v kroku 2 pro objekty poštovní schránky, které mají hodnotu CNF v polích Název a Identita.

    Pokud rutina v kroku 2 hlásí více osamocených poštovních schránek veřejných složek, můžete je najít a odebrat v dávce spuštěním následující rutiny:

    $soft= Get-Recipient -RecipientTypeDetails PublicFolderMailbox –IncludeSoftDeletedRecipients ; foreach ($mbx in $soft){if ($mbx.Name -like "*CNF:*" -or $mbx.identity -like "*CNF:*") {Remove-Mailbox -PublicFolder $mbx.ExchangeGUID.GUID -RemoveCNFPublicFolderMailboxPermanently}}