Sdílet prostřednictvím


Zprávy odeslané ze sdílené poštovní schránky se neuloží do složky Odeslaná pošta.

Příznaky

Předpokládejme, že používáte Microsoft Outlook 2016 nebo novější verzi a máte delegovaná oprávnění k odesílání e-mailových zpráv jako jiného uživatele nebo jménem jiného uživatele ze sdílené poštovní schránky. Pokud ale zprávu odešlete jako jiného uživatele nebo jménem uživatele, odeslaná zpráva se neuloží do složky Odeslaná pošta sdílené poštovní schránky. Místo toho se uloží do složky Odeslaná pošta vaší poštovní schránky.

Příčina

V Microsoftu 365 sdílené poštovní schránky nevyžadují licenci a nedají se do Outlooku přidat jako nezávislé poštovní schránky. Nemůžete se přihlásit ke sdílené poštovní schránce. Místo toho se přihlásíte k vlastní poštovní schránce a pak otevřete sdílenou poštovní schránku. Když odešlete novou zprávu ze sdílené poštovní schránky nebo na ni odpovíte, Outlook automaticky odešle nebo odpoví z účtu odesílatele. Zprávy jsou proto uloženy ve složce Odeslaná pošta poštovní schránky odesílatele.

Řešení problému

Chcete-li tento problém vyřešit, použijte jednu z následujících metod.

Poznámka: Pokud používáte nový Outlook, použije se pouze metoda 1.

Metoda 1

Nakonfigurujte poštovní schránku tak, aby ukládala kopii zprávy do složky Odeslaná pošta sdílené poštovní schránky v Exchangi Online nebo na místním Exchange Serveru.

Pro e-maily odeslané jako sdílenou poštovní schránku spusťte v Prostředí Exchange PowerShell následující příkaz:

set-mailbox <mailbox name> -MessageCopyForSentAsEnabled $True

U e-mailů odeslaných jménem sdílené poštovní schránky spusťte v Prostředí Exchange PowerShell následující příkaz:

set-mailbox <mailbox name> -MessageCopyForSendOnBehalfEnabled $True

Metoda 2

Důležité

Tato část, metoda nebo úloha obsahuje kroky, které vám říkají, jak upravit registr. Pokud však registr upravíte nesprávně, může dojít k vážným problémům. Proto se ujistěte, že tyto kroky pečlivě dodržujete. Před úpravou registru zálohujte registr, abyste ho mohli obnovit, pokud dojde k problému. Další informace o zálohování a obnovení registru naleznete v tématu Postup zálohování a obnovení registru v systému Windows.

Nastavte hodnotu registru DelegateSentItemsStyle v klientovi Outlooku.

Poznámka:

Aby tato možnost fungovala správně, musí být Aplikace Outlook nakonfigurovaná tak, aby běžela v režimu Cached Exchange. Další informace naleznete v článku E-mail zůstává v poštovní schránce při použití hodnoty registru DelegateSentItemsStyle.

Použijte následující kroky:

  1. Spusťte Editor registru.

  2. Vyhledejte a klikněte na následující podklíč registru:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Preferences

  3. V nabídce Upravit přejděte na příkaz Nový a klepněte na příkaz DWORD 32bitová hodnota.

  4. Zadejte DelegateSentItemsStyle a stiskněte Enter.

  5. Klepněte pravým tlačítkem myši DelegateSentItemsStyle a klepněte na tlačítko Změnit.

  6. Do pole Údaj hodnoty zadejte 1 a klepněte na tlačítko OK.

  7. Ukončete Editor registru.

Více informací

Následující tabulka uvádí očekávané chování na základě různých kombinací DelegateSentItemsStyle nastavení hodnoty registru a hodnoty parametru MessageCopyForSentAsEnabled poštovní schránky.

Styl odeslaných položek delegovaného uživatele Kopie zprávy pro odeslané jako povoleno Očekávané chování
0 Pravdivé Kopie e-mailu se uloží v primární i sdílené poštovní schránce.
1 Pravdivé Dvě kopie e-mailu budou uloženy ve sdílené poštovní schránce a nebudou v primární poštovní schránce žádné kopie.
0 Nepravda Kopie e-mailu se uloží do primární poštovní schránky a ve sdílené poštovní schránce nebudou žádné kopie.
1 Nepravda Kopie e-mailu se uloží do sdílené poštovní schránky a v primární poštovní schránce nebudou žádné kopie.

Potřebujete ještě pomoc? Přejděte do komunity Microsoftu nebo na fóra Exchange TechNet.