Sdílet prostřednictvím


Nejde se přihlásit k desktopovým aplikacím Microsoftu 365

Příznaky

Na zařízení s Windows s nainstalovaným softwarem zabezpečení může při pokusu o přihlášení k desktopovým aplikacím Microsoft 365 dojít k některým z následujících problémů:

  • Výzvy k přihlášení jsou přerušované.

  • V přihlašovacím okně se zobrazí prázdná ověřovací obrazovka.

    Snímek obrazovky s prázdnou obrazovkou ověřování

  • Přihlašovací okno se zasekne při ověřování.

    Snímek obrazovky s přihlašovacím oknem, které se zasekne při ověřování

  • Desktopový klient Outlooku zobrazí zprávu "Probíhá pokus o připojení...".

  • Desktopový klient Teams zobrazí zprávu"Nemohli jsme se připojit. Přihlaste se a zkusíme to znovu."

  • Otevřete Prohlížeč událostí a vyberete Protokoly systému Windows>Aplikace. Když prozkoumáte podrobnosti položek AppModel-State ve sloupci Zdroj tabulky, zobrazí se jedna z následujících zpráv událostí, které končí upozorněním nebo kódem -2147xxxxxxchyby:

    • Selhání načtení nastavení aplikace pro balíček

    • Oprava stavu umístění pro operaci SettingsInitialize vůči balíčku Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy s chybou

    • Oprava pro činnost LocalSettings proti balíčku Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy, s chybou

    • Aktivovaná oprava, protože operace LocalSettings pro balíček Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy narazila na chybu

    • Spuštění opravy stavových umístění, protože došlo k chybě během operace SettingsInitialize pro balíček Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy.

      Snímek obrazovky Prohlížeče událostí zobrazující výsledky filtrované pro položku Zdroj appmodel-State a zprávu události, která obsahuje kód chyby, který začíná v roce 2147

Příčina

Tento problém může být způsobený existujícími nebo zastaralými ovladači platformy WFP (Windows Filtering Platform) v softwaru zabezpečení. V takovém případě software zabezpečení brání navázání síťové komunikace nebo udržování předchozího stavu komunikace. Kromě toho může bezpečnostní software blokovat zásuvné moduly Správce webových účtů (WAM) nebo je odebrat jako vedlejší účinek své aktivity na zařízení.

Pokud Prohlížeč událostí zobrazí některou ze zpráv událostí uvedených v části Příznaky , zprávy indikují, že moduly plug-in WAM jsou poškozené nebo byly manipulovány.

Poznámka:

  • Moduly plug-in WAM používají aplikace Microsoft 365 k vytváření a obnovování přihlašovacích relací. Moduly plug-in se instalují v kontextu profilu uživatele. To znamená, že i když jeden uživatel může mít problémy, jiný uživatel na stejném zařízení nemusí. Proto by se mělo jakékoli zmírnění a diagnostika provést v kontextu ovlivněného uživatele, ne na úrovni zařízení nebo správce.
  • Pokud byly moduly plug-in poškozeny, manipulovány nebo odebrány z profilu uživatele z důvodu kontroly softwaru zabezpečení, zkuste moduly plug-in nainstalovat opakovaně pomocí skriptu PowerShellu na pozadí nebo přihlašovacího skriptu zásad skupiny. Tato akce může tento problém dočasně zmírnit až do další antivirové kontroly.

Řešení

Důležité

Pokud je problém způsobený poškozeným nebo manipulovaným modulem plug-in WAM, přeskočte ke kroku 3 v následujícím postupu a přeinstalujte moduly plug-in WAM. Pokud se problém opakuje, ve spolupráci se softwarem zabezpečení a dodavatelem ovladačů WFP nakonfigurujte příslušná vyloučení uvedená v kroku 5.

Pokud chcete tyto problémy vyřešit, postupujte na zařízení takto:

  1. Přihlaste se pomocí účtu správce a potom z zařízení dočasně odinstalujte bezpečnostní software a všechny samostatné nebo zastaralé ovladače WFP.

  2. Přihlaste se pomocí přihlašovacích údajů ovlivněného uživatele a zkontrolujte, jestli jsou nainstalované moduly plug-in WAM a jestli se můžou úspěšně spustit v profilu uživatele.

    1. Spusťte následující rutiny PowerShellu:

      Get-AppxPackage Microsoft.AAD.BrokerPlugin
      Get-AppxPackage Microsoft.Windows.CloudExperienceHost 
      
    2. Pokud ani jeden z rutinních příkazů nic nevrátí, přejděte ke kroku 3. V opačném případě spusťte na příkazovém řádku následující příkazy:

      explorer.exe shell:appsFolder\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy!App
      explorer.exe shell:appsFolder\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy!App
      

      Pokud se neotevře pracovní nebo školní účet nebo okno účtu Microsoft , přejděte ke kroku 3. V opačném případě přejděte ke kroku 4.

  3. Pokud krok 2 není úspěšný, nainstalujte znovu zásuvné moduly WAM pomocí následujících rutin PowerShell:

    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    Add-AppxPackage -Register "$env:windir\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy\Appxmanifest.xml" -DisableDevelopmentMode -ForceApplicationShutdown
    
  4. Monitorujte 48 hodin. Pokud se problém opakuje, obraťte se na podporu Microsoftu. Jinak přejděte ke kroku 5.

    Poznámka:

    Při řešení potíží doporučujeme shromáždit data z monitorování procesů při reprodukování problému. Tyto informace vám můžou pomoct určit, jestli:

    • Moduly třetích stran se načítají společně s WAM pluginy.
    • Moduly třetích stran uchovávají zámek souboru nebo registru a brání procesu přihlášení.
    • Zastaralé ovladače softwaru WFP nebo zabezpečení jsou nainstalovány v systému.
  5. Přihlaste se pomocí účtu správce a přeinstalujte software zabezpečení a samostatné ovladače WFP, které byly odinstalovány v kroku 1. Pak ve spolupráci se softwarem zabezpečení a dodavatelem ovladačů WFP nakonfigurujte následující balíčky, složky a vyloučení procesů v ovladačích zabezpečení a WFP.

    Vyloučení jmen rodiny balíčků

    • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy

    Umístění složek, která mají být vyloučena

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
    • %windir%\SystemApps\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Packages\Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %localappdata%\Microsoft\TokenBroker
    • %localappdata%\Microsoft\OneAuth
    • %localappdata%\Microsoft\IdentityCache

    Procesy, které se mají vyloučit

    • %windir%\SystemApps\Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy\Microsoft.AAD.BrokerPlugin.exe
    • %windir%\System32\backgroundTaskHost.exe pro následující názvy balíčků:
      • Microsoft.AAD.BrokerPlugin_cw5n1h2txyewy
      • Microsoft.Windows.CloudExperienceHost_cw5n1h2txyewy
    • %windir%\System32\svchost.exe načítání služby TokenBroker NT jako TokenBroker.dll