Poznámka
Přístup k této stránce vyžaduje autorizaci. Můžete se zkusit přihlásit nebo změnit adresáře.
Přístup k této stránce vyžaduje autorizaci. Můžete zkusit změnit adresáře.
Původní číslo KB: 4025591
Příznaky
Pokusíte se přidat internetový kalendář v Microsoft Outlooku 2016, Outlooku 2019 nebo Outlook pro Microsoft 365 následujícím postupem:
- Přepněte do modulu kalendáře.
- Ve skupině Spravovat kalendáře na panelu nástrojů vyberte Otevřít kalendář.
- Vyberte možnost Z internetu.
- Zadejte cestu k souboru internetového kalendáře.
- Vyberte OK.
Pokud použijete tuto metodu pro některé internetové servery, kalendář se úspěšně nepřidá. Po krátkém otevření okna průběhu se vrátíte do modulu kalendáře bez přidání nového kalendáře. Navíc se nezobrazí žádná chybová zpráva.
Příčina
Ve výchozím nastavení používají Outlook 2016, Outlook 2019 a Outlook pro Microsoft 365 nový moderní zásobník ověřování. I když soubor internetového kalendáře, který se pokusíte otevřít, nevyžaduje ověření, Outlook vysílá svou schopnost provádět moderní ověřování na serveru, který obsahuje kalendář. Většina serverového softwaru reaguje na toto vysílání podporou moderního ověřování. Některé servery však považují všesměrové vysílání za neplatný požadavek klienta. Proto vrátí odpověď, která způsobí, že Outlook zruší pokus o přidání kalendáře.
Například serverový software, který běží na Amazon Web Services (AWS), může zvážit, že ověřovací vysílání je neplatné a odmítne připojení.
Alternativní řešení
Tento problém můžete vyřešit pomocí Outlook Web Appu (OWA). OWA toto chování hlavičky ověřování nemá. Proto se otevře internetový kalendář, který chcete přidat.
Chcete-li přidat kalendář pomocí OWA, postupujte takto:
- Přihlaste se k OWA.
- Přepněte do modulu Kalendář.
- Vyberte nabídku Přidat kalendář.
- Vyberte možnost Z internetu.
- Zadejte adresu URL a volitelný název kalendáře.
- Zvolte Uložit.
Více informací
Když přidáte internetový kalendář pomocí OWA, server, na kterém běží Exchange Server, spravuje odběr kalendáře a aktualizace. Aktualizace kalendáře se synchronizují přibližně každé čtyři hodiny.
Kalendář přidaný z OWA se v desktopové aplikaci Outlook nezobrazuje jako internetový kalendář. Místo toho se zobrazí jako položka kalendáře ve skupině Jiné kalendáře . Vzhledem k tomu, že desktopová aplikace Outlook nezpracuje ani neřídí žádné informace o předplatném, nemusíte pro kalendář přidaný prostřednictvím OWA konfigurovat žádné možnosti internetového kalendáře na straně klienta.
Kontaktní informace třetích stran právních omezení
Společnost Microsoft vám usnadňuje získání technické podpory poskytnutím informací o kontaktech na jiné výrobce. Tyto informace se mohou změnit bez předchozího upozornění. Společnost Microsoft neručí za správnost informací o kontaktech na jiné výrobce.